Home page on localhost shows script instead of webpage

Discussion in 'ASP .Net' started by =?Utf-8?B?SGVtaWw=?=, Jan 11, 2005.

  1. Hello friends,

    I had my laptop reformatted and rebuilt recently. After this, when I try to
    open my asp.net web application by using http://localhost, it shows the
    script code in the browser instead of the web page. I have enabled the
    default document as .aspx under the IIS settings.

    Any ideas as to what might be causing the problem ?

    Thanks,
    Hemil.
    =?Utf-8?B?SGVtaWw=?=, Jan 11, 2005
    #1
    1. Advertising

  2. Assuming .NET is still installed, it sounds like the script mapping has come
    undone. The fix is here:

    How To Repair IIS Mapping After You Remove and Reinstall IIS

    http://support.microsoft.com/default.aspx?scid=kb;en-us;306005

    PRB: ASP.NET Pages Exhibit Unexpected Behavior Because the Server-Side Code
    Is Not Processed

    http://support.microsoft.com/default.aspx?scid=kb;en-us;325093


    "Hemil" <> wrote in message
    news:...
    > Hello friends,
    >
    > I had my laptop reformatted and rebuilt recently. After this, when I try
    > to
    > open my asp.net web application by using http://localhost, it shows the
    > script code in the browser instead of the web page. I have enabled the
    > default document as .aspx under the IIS settings.
    >
    > Any ideas as to what might be causing the problem ?
    >
    > Thanks,
    > Hemil.
    Ken Cox [Microsoft MVP], Jan 11, 2005
    #2
    1. Advertising

  3. Hi Ken,

    I repaired the IIS mapping and registered the dll as suggested by the
    articles. It's working fine now.

    Thank you very much for your prompt response. Very much appreicated.

    Cheers
    Hemil.

    "Ken Cox [Microsoft MVP]" wrote:

    > Assuming .NET is still installed, it sounds like the script mapping has come
    > undone. The fix is here:
    >
    > How To Repair IIS Mapping After You Remove and Reinstall IIS
    >
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;306005
    >
    > PRB: ASP.NET Pages Exhibit Unexpected Behavior Because the Server-Side Code
    > Is Not Processed
    >
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;325093
    >
    >
    > "Hemil" <> wrote in message
    > news:...
    > > Hello friends,
    > >
    > > I had my laptop reformatted and rebuilt recently. After this, when I try
    > > to
    > > open my asp.net web application by using http://localhost, it shows the
    > > script code in the browser instead of the web page. I have enabled the
    > > default document as .aspx under the IIS settings.
    > >
    > > Any ideas as to what might be causing the problem ?
    > >
    > > Thanks,
    > > Hemil.

    >
    >
    =?Utf-8?B?SGVtaWw=?=, Jan 11, 2005
    #3
  4. Hi Hemil,

    Glad to hear you got going.

    Thanks for letting us know.

    Ken
    Toronto

    "Hemil" <> wrote in message
    news:D...
    > Hi Ken,
    >
    > I repaired the IIS mapping and registered the dll as suggested by the
    > articles. It's working fine now.
    >
    > Thank you very much for your prompt response. Very much appreicated.
    >
    > Cheers
    > Hemil.
    >
    > "Ken Cox [Microsoft MVP]" wrote:
    >
    >> Assuming .NET is still installed, it sounds like the script mapping has
    >> come
    >> undone. The fix is here:
    >>
    >> How To Repair IIS Mapping After You Remove and Reinstall IIS
    >>
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;306005
    >>
    >> PRB: ASP.NET Pages Exhibit Unexpected Behavior Because the Server-Side
    >> Code
    >> Is Not Processed
    >>
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;325093
    >>
    >>
    >> "Hemil" <> wrote in message
    >> news:...
    >> > Hello friends,
    >> >
    >> > I had my laptop reformatted and rebuilt recently. After this, when I
    >> > try
    >> > to
    >> > open my asp.net web application by using http://localhost, it shows the
    >> > script code in the browser instead of the web page. I have enabled the
    >> > default document as .aspx under the IIS settings.
    >> >
    >> > Any ideas as to what might be causing the problem ?
    >> >
    >> > Thanks,
    >> > Hemil.

    >>
    >>
    Ken Cox [Microsoft MVP], Jan 11, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jiong Feng
    Replies:
    0
    Views:
    820
    Jiong Feng
    Nov 19, 2003
  2. Alex
    Replies:
    4
    Views:
    567
    Hasani Blackwell
    Feb 8, 2005
  3. gce
    Replies:
    0
    Views:
    767
  4. =?Utf-8?B?S2VuTGVl?=
    Replies:
    5
    Views:
    2,708
  5. Gianni

    IE shows false and Firefox shows true

    Gianni, Jul 10, 2009, in forum: Javascript
    Replies:
    3
    Views:
    450
    Thomas 'PointedEars' Lahn
    Jul 10, 2009
Loading...

Share This Page