How do I fix this problem

Discussion in 'ASP .Net Security' started by Husam, Jul 8, 2007.

  1. Husam

    Husam Guest

    Hi everybody:

    when I make the web.config file to make the authentication and the
    autherization for my web site.

    the code is as following:

    <configuration>
    <appSettings/>
    <connectionStrings/>
    <system.web>
    <authentication mode="Forms">
    <forms name="Default" loginUrl="~/Default.aspx" />
    </authentication>
    </system.web>
    </configuration>

    But when I dubbge my page I recive the following message:

    It is an error to use a section registered as
    allowDefinition='MachineToApplication' beyond application level. This error
    can be caused by a virtual directory not being configured as an application
    in IIS.

    the red line is :

    <authentication mode="Forms">
    Husam, Jul 8, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sean
    Replies:
    4
    Views:
    324
    Alvin Bruney [MVP]
    Mar 2, 2004
  2. Patrick Philippot
    Replies:
    0
    Views:
    446
    Patrick Philippot
    Apr 14, 2006
  3. Xah Lee
    Replies:
    22
    Views:
    1,103
    Tim Roberts
    Mar 21, 2006
  4. Xah Lee
    Replies:
    23
    Views:
    1,040
    Tim Roberts
    Mar 21, 2006
  5. Xah Lee
    Replies:
    21
    Views:
    763
    Tim Roberts
    Mar 21, 2006
Loading...

Share This Page