How to control vritual directory not requests dlls on top directory? thanks

Discussion in 'ASP .Net' started by davidw, May 28, 2005.

  1. davidw

    davidw Guest

    I have a website, in web.config, I have set several httphandler dll like

    <httpHandlers>
    <add verb="*" path="default.aspx" type="Link.MainHandler, link" />
    ....

    I then create a virutal directory under the site, the vritual directory has
    its own dll, but when I run files in the virtual directory, it always ask
    for the dll link in the top level. I even added

    <httpHandlers>
    <clear/>
    ...

    in the web.config in the virtual directory, but in vain. any idea?

    Thanks!

    --

    David WENG
    davidw, May 28, 2005
    #1
    1. Advertising

  2. RE: How to control vritual directory not requests dlls on top director

    Try using 'Remove' only for your custom httpHandler.

    On using <clear>(which should be the last statement in httpHandler section)
    - you should have got an error saying no handlers found for verb=GET.

    -pSm

    "davidw" wrote:

    > I have a website, in web.config, I have set several httphandler dll like
    >
    > <httpHandlers>
    > <add verb="*" path="default.aspx" type="Link.MainHandler, link" />
    > ....
    >
    > I then create a virutal directory under the site, the vritual directory has
    > its own dll, but when I run files in the virtual directory, it always ask
    > for the dll link in the top level. I even added
    >
    > <httpHandlers>
    > <clear/>
    > ...
    >
    > in the web.config in the virtual directory, but in vain. any idea?
    >
    > Thanks!
    >
    > --
    >
    > David WENG
    >
    >
    >
    >
    =?Utf-8?B?cFNt?=, May 29, 2005
    #2
    1. Advertising

  3. davidw

    Brock Allen Guest

    When you add them in the parent you can add the validate=false option, then
    when you use remove in the child web.config you won't have problems.

    <httpHandlers>
    <add verb="*" path="default.aspx" type="Link.MainHandler, link" validate="false"
    />

    -Brock
    DevelopMentor
    http://staff.develop.com/ballen



    > I have a website, in web.config, I have set several httphandler dll
    > like
    >
    > <httpHandlers>
    > <add verb="*" path="default.aspx" type="Link.MainHandler, link" />
    > ....
    > I then create a virutal directory under the site, the vritual
    > directory has its own dll, but when I run files in the virtual
    > directory, it always ask for the dll link in the top level. I even
    > added
    >
    > <httpHandlers>
    > <clear/>
    > ...
    > in the web.config in the virtual directory, but in vain. any idea?
    >
    > Thanks!
    >
    Brock Allen, May 30, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Fernando Arámburu

    web requests and mobile requests

    Fernando Arámburu, Apr 8, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    433
    Joerg Jooss
    Apr 8, 2005
  2. Frederic HOUDE
    Replies:
    4
    Views:
    586
    Frederic HOUDE
    Aug 31, 2004
  3. Cuthbert
    Replies:
    8
    Views:
    421
    Ancient_Hacker
    Sep 13, 2006
  4. AAaron123
    Replies:
    6
    Views:
    557
    AAaron123
    Nov 5, 2009
  5. find clausen

    window.opener.top.location.top.close ???

    find clausen, Oct 5, 2003, in forum: Javascript
    Replies:
    2
    Views:
    422
    find clausen
    Oct 5, 2003
Loading...

Share This Page