How to restrict ASP.NET to specific processors in a multiprocessor system

Discussion in 'ASP .Net' started by bonse, Oct 10, 2005.

  1. bonse

    bonse Guest

    According to reference
    http://support.microsoft.com/default.aspx?scid=kb;en-us;815156 , I added
    <processModel enable="true" webGarden="true" cpuMask="8" /> on web.config,
    restart iis service, the w3wp.exe process always use all cpu. The iis server
    is windows 2003 iis6, how can i restrict ASP.NET to specific processors in a
    multiprocessor system?
     
    bonse, Oct 10, 2005
    #1
    1. Advertising

  2. If the WebGarden property is set to false, the CpuMask
    attribute is ignored and only one worker process runs :

    <processModel enable="true" webGarden="false" />




    Juan T. Llibre, ASP.NET MVP
    ASP.NET FAQ : http://asp.net.do/faq/
    Foros de ASP.NET en Español : http://asp.net.do/foros/
    ======================================
    "bonse" <> wrote in message
    news:...
    > According to reference http://support.microsoft.com/default.aspx?scid=kb;en-us;815156 ,
    > I added <processModel enable="true" webGarden="true" cpuMask="8" /> on web.config,
    > restart iis service, the w3wp.exe process always use all cpu. The iis server is windows
    > 2003 iis6, how can i restrict ASP.NET to specific processors in a multiprocessor system?
     
    Juan T. Llibre, Oct 10, 2005
    #2
    1. Advertising

  3. bonse

    Damien Guest

    bonse wrote:
    > According to reference
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;815156 , I added
    > <processModel enable="true" webGarden="true" cpuMask="8" /> on web.config,
    > restart iis service, the w3wp.exe process always use all cpu. The iis server
    > is windows 2003 iis6, how can i restrict ASP.NET to specific processors in a
    > multiprocessor system?


    in machine.config, it states the processModel is ignored in it and the
    settings are taken from IIS. Don't know if the same is true in
    web.config? I've taken a quick look through the IIS Manager, but cannot
    see anywhere to set processor afinity (but you can throttle total CPU
    usage)

    Damien
     
    Damien, Oct 10, 2005
    #3
  4. rer:
    > I've taken a quick look through the IIS Manager,
    > but cannot see anywhere to set processor afinity


    If you're using IIS 6, right-click "Application Pools" in the IIS Manager.
    Select "Properties", and then the "Performance" tab.

    There, you can set the number of processors enabled in a webGarden.

    But, as mentioned, simply setting webGarden to "false"
    in machine.config will do that for you at the machine level.




    Juan T. Llibre, ASP.NET MVP
    ASP.NET FAQ : http://asp.net.do/faq/
    Foros de ASP.NET en Español : http://asp.net.do/foros/
    ======================================
    "Damien" <> wrote in message
    news:...
    > bonse wrote:
    >> According to reference
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;815156 , I added
    >> <processModel enable="true" webGarden="true" cpuMask="8" /> on web.config,
    >> restart iis service, the w3wp.exe process always use all cpu. The iis server
    >> is windows 2003 iis6, how can i restrict ASP.NET to specific processors in a
    >> multiprocessor system?

    >
    > in machine.config, it states the processModel is ignored in it and the
    > settings are taken from IIS. Don't know if the same is true in
    > web.config? I've taken a quick look through the IIS Manager, but cannot
    > see anywhere to set processor afinity (but you can throttle total CPU
    > usage)
    >
    > Damien
    >
     
    Juan T. Llibre, Oct 10, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jaytersen

    multiprocessor problem

    Jaytersen, Oct 26, 2003, in forum: VHDL
    Replies:
    2
    Views:
    574
    Mike Treseler
    Oct 27, 2003
  2. Jon
    Replies:
    4
    Views:
    443
    Jon Paugh
    Feb 20, 2004
  3. Ohaya
    Replies:
    0
    Views:
    346
    Ohaya
    Feb 22, 2004
  4. jacky shi

    A problem related with multiprocessor

    jacky shi, Dec 15, 2005, in forum: C Programming
    Replies:
    0
    Views:
    300
    jacky shi
    Dec 15, 2005
  5. bonse
    Replies:
    0
    Views:
    115
    bonse
    Oct 10, 2005
Loading...

Share This Page