How to TimeOut a long running Request ??

Discussion in 'ASP .Net' started by =?Utf-8?B?U2hhbGluaQ==?=, Jan 5, 2005.

  1. If I have an ASPX page that is just sleeping for 3 minutes ormore and later
    does some processing and the ExecutionTimeout parameter in the machine.config
    is 90 seconds then the page does not timeout after 90 seconds.
    Even if the ExecutionTimeout parameter in the web.config is set or the
    Server.ScriptTimeout is set in the aspx.cs still the page does not timeout
    after the timeout period.
    Can someone please tell us as to how we can timeout an aspx page that is
    doing some lengthy processing? Also when exactly does the ExecutionTimeout
    take effect?
    =?Utf-8?B?U2hhbGluaQ==?=, Jan 5, 2005
    #1
    1. Advertising

  2. I am not sure if this is your situation, but I could never get a "Request
    Timed Out." when I was running the browser and the server on my local
    machine. I had to use my browser to hit a remote machine. My
    machine.config timeout is 90 seconds, and it does timeout remotely. Are you
    running everything on your local machine?

    bill

    "Shalini" <> wrote in message
    news:...
    > If I have an ASPX page that is just sleeping for 3 minutes ormore and

    later
    > does some processing and the ExecutionTimeout parameter in the

    machine.config
    > is 90 seconds then the page does not timeout after 90 seconds.
    > Even if the ExecutionTimeout parameter in the web.config is set or the
    > Server.ScriptTimeout is set in the aspx.cs still the page does not timeout
    > after the timeout period.
    > Can someone please tell us as to how we can timeout an aspx page that is
    > doing some lengthy processing? Also when exactly does the ExecutionTimeout
    > take effect?
    William F. Robertson, Jr., Jan 5, 2005
    #2
    1. Advertising

  3. I am not getting the timeout in any case whether I am ruuning the application
    locally or remotely. I have tried several times. Even though the
    'ExecutionTimeout' in machine.config is set to 90 seconds, the request
    doesnot timeout. The 'debug' attribute in web.config is set to true. Is some
    other setting required to be made? If not then what is the reason for the
    timeout not happening? Could anyone please elaborate?

    "William F. Robertson, Jr." wrote:

    > I am not sure if this is your situation, but I could never get a "Request
    > Timed Out." when I was running the browser and the server on my local
    > machine. I had to use my browser to hit a remote machine. My
    > machine.config timeout is 90 seconds, and it does timeout remotely. Are you
    > running everything on your local machine?
    >
    > bill
    >
    > "Shalini" <> wrote in message
    > news:...
    > > If I have an ASPX page that is just sleeping for 3 minutes ormore and

    > later
    > > does some processing and the ExecutionTimeout parameter in the

    > machine.config
    > > is 90 seconds then the page does not timeout after 90 seconds.
    > > Even if the ExecutionTimeout parameter in the web.config is set or the
    > > Server.ScriptTimeout is set in the aspx.cs still the page does not timeout
    > > after the timeout period.
    > > Can someone please tell us as to how we can timeout an aspx page that is
    > > doing some lengthy processing? Also when exactly does the ExecutionTimeout
    > > take effect?

    >
    >
    >
    =?Utf-8?B?U2hhbGluaQ==?=, Jan 6, 2005
    #3
  4. re:
    >The 'debug' attribute in web.config is set to true.


    'ExecutionTimeout' only applies if the debug
    attribute in the compilation element is set to false.




    Juan T. Llibre
    ===========
    "Shalini" <> wrote in message
    news:...
    >I am not getting the timeout in any case whether I am ruuning the
    >application
    > locally or remotely. I have tried several times. Even though the
    > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
    > doesnot timeout. The 'debug' attribute in web.config is set to true. Is
    > some
    > other setting required to be made? If not then what is the reason for the
    > timeout not happening? Could anyone please elaborate?
    >
    > "William F. Robertson, Jr." wrote:
    >
    >> I am not sure if this is your situation, but I could never get a "Request
    >> Timed Out." when I was running the browser and the server on my local
    >> machine. I had to use my browser to hit a remote machine. My
    >> machine.config timeout is 90 seconds, and it does timeout remotely. Are
    >> you
    >> running everything on your local machine?
    >>
    >> bill
    >>
    >> "Shalini" <> wrote in message
    >> news:...
    >> > If I have an ASPX page that is just sleeping for 3 minutes ormore and

    >> later
    >> > does some processing and the ExecutionTimeout parameter in the

    >> machine.config
    >> > is 90 seconds then the page does not timeout after 90 seconds.
    >> > Even if the ExecutionTimeout parameter in the web.config is set or the
    >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
    >> > timeout
    >> > after the timeout period.
    >> > Can someone please tell us as to how we can timeout an aspx page that
    >> > is
    >> > doing some lengthy processing? Also when exactly does the
    >> > ExecutionTimeout
    >> > take effect?

    >>
    >>
    >>



    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
    Juan T. Llibre [MVP], Jan 6, 2005
    #4
  5. Thanx a lot everyone.
    Struggled a lot with this problem.



    "Juan T. Llibre [MVP]" wrote:

    > re:
    > >The 'debug' attribute in web.config is set to true.

    >
    > 'ExecutionTimeout' only applies if the debug
    > attribute in the compilation element is set to false.
    >
    >
    >
    >
    > Juan T. Llibre
    > ===========
    > "Shalini" <> wrote in message
    > news:...
    > >I am not getting the timeout in any case whether I am ruuning the
    > >application
    > > locally or remotely. I have tried several times. Even though the
    > > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
    > > doesnot timeout. The 'debug' attribute in web.config is set to true. Is
    > > some
    > > other setting required to be made? If not then what is the reason for the
    > > timeout not happening? Could anyone please elaborate?
    > >
    > > "William F. Robertson, Jr." wrote:
    > >
    > >> I am not sure if this is your situation, but I could never get a "Request
    > >> Timed Out." when I was running the browser and the server on my local
    > >> machine. I had to use my browser to hit a remote machine. My
    > >> machine.config timeout is 90 seconds, and it does timeout remotely. Are
    > >> you
    > >> running everything on your local machine?
    > >>
    > >> bill
    > >>
    > >> "Shalini" <> wrote in message
    > >> news:...
    > >> > If I have an ASPX page that is just sleeping for 3 minutes ormore and
    > >> later
    > >> > does some processing and the ExecutionTimeout parameter in the
    > >> machine.config
    > >> > is 90 seconds then the page does not timeout after 90 seconds.
    > >> > Even if the ExecutionTimeout parameter in the web.config is set or the
    > >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
    > >> > timeout
    > >> > after the timeout period.
    > >> > Can someone please tell us as to how we can timeout an aspx page that
    > >> > is
    > >> > doing some lengthy processing? Also when exactly does the
    > >> > ExecutionTimeout
    > >> > take effect?
    > >>
    > >>
    > >>

    >
    >
    > ---
    > Outgoing mail is certified Virus Free.
    > Checked by AVG anti-virus system (http://www.grisoft.com).
    > Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
    >
    >
    >
    =?Utf-8?B?SW5kaXJh?=, Jan 10, 2005
    #5
  6. FYI:
    I've never known that executionTimeout to actually work irespective of the
    settings applied.

    --
    Regards,
    Alvin Bruney
    [ASP.NET MVP http://mvp.support.microsoft.com/default.aspx]
    Got tidbits? Get it here... http://tinyurl.com/27cok
    "Indira" <> wrote in message
    news:...
    > Thanx a lot everyone.
    > Struggled a lot with this problem.
    >
    >
    >
    > "Juan T. Llibre [MVP]" wrote:
    >
    >> re:
    >> >The 'debug' attribute in web.config is set to true.

    >>
    >> 'ExecutionTimeout' only applies if the debug
    >> attribute in the compilation element is set to false.
    >>
    >>
    >>
    >>
    >> Juan T. Llibre
    >> ===========
    >> "Shalini" <> wrote in message
    >> news:...
    >> >I am not getting the timeout in any case whether I am ruuning the
    >> >application
    >> > locally or remotely. I have tried several times. Even though the
    >> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
    >> > doesnot timeout. The 'debug' attribute in web.config is set to true. Is
    >> > some
    >> > other setting required to be made? If not then what is the reason for
    >> > the
    >> > timeout not happening? Could anyone please elaborate?
    >> >
    >> > "William F. Robertson, Jr." wrote:
    >> >
    >> >> I am not sure if this is your situation, but I could never get a
    >> >> "Request
    >> >> Timed Out." when I was running the browser and the server on my local
    >> >> machine. I had to use my browser to hit a remote machine. My
    >> >> machine.config timeout is 90 seconds, and it does timeout remotely.
    >> >> Are
    >> >> you
    >> >> running everything on your local machine?
    >> >>
    >> >> bill
    >> >>
    >> >> "Shalini" <> wrote in message
    >> >> news:...
    >> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
    >> >> > and
    >> >> later
    >> >> > does some processing and the ExecutionTimeout parameter in the
    >> >> machine.config
    >> >> > is 90 seconds then the page does not timeout after 90 seconds.
    >> >> > Even if the ExecutionTimeout parameter in the web.config is set or
    >> >> > the
    >> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
    >> >> > timeout
    >> >> > after the timeout period.
    >> >> > Can someone please tell us as to how we can timeout an aspx page
    >> >> > that
    >> >> > is
    >> >> > doing some lengthy processing? Also when exactly does the
    >> >> > ExecutionTimeout
    >> >> > take effect?
    >> >>
    >> >>
    >> >>

    >>
    >>
    >> ---
    >> Outgoing mail is certified Virus Free.
    >> Checked by AVG anti-virus system (http://www.grisoft.com).
    >> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
    >>
    >>
    >>
    Alvin Bruney [MVP], Jan 10, 2005
    #6
  7. It seems to have worked for Indira.



    Juan T. Llibre
    ASP.NET MVP
    ===========
    "Alvin Bruney [MVP]" <vapor at steaming post office> wrote in message
    news:%...
    > FYI:
    > I've never known that executionTimeout to actually work irespective of the
    > settings applied.
    > Regards,
    > Alvin Bruney


    > "Indira" <> wrote in message
    > news:...
    >> Thanx a lot everyone.
    >> Struggled a lot with this problem.
    >>
    >>
    >>
    >> "Juan T. Llibre [MVP]" wrote:
    >>
    >>> re:
    >>> >The 'debug' attribute in web.config is set to true.
    >>>
    >>> 'ExecutionTimeout' only applies if the debug
    >>> attribute in the compilation element is set to false.
    >>>
    >>>
    >>>
    >>>
    >>> Juan T. Llibre
    >>> ===========
    >>> "Shalini" <> wrote in message
    >>> news:...
    >>> >I am not getting the timeout in any case whether I am ruuning the
    >>> >application
    >>> > locally or remotely. I have tried several times. Even though the
    >>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the request
    >>> > doesnot timeout. The 'debug' attribute in web.config is set to true.
    >>> > Is
    >>> > some
    >>> > other setting required to be made? If not then what is the reason for
    >>> > the
    >>> > timeout not happening? Could anyone please elaborate?
    >>> >
    >>> > "William F. Robertson, Jr." wrote:
    >>> >
    >>> >> I am not sure if this is your situation, but I could never get a
    >>> >> "Request
    >>> >> Timed Out." when I was running the browser and the server on my local
    >>> >> machine. I had to use my browser to hit a remote machine. My
    >>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
    >>> >> Are
    >>> >> you
    >>> >> running everything on your local machine?
    >>> >>
    >>> >> bill
    >>> >>
    >>> >> "Shalini" <> wrote in message
    >>> >> news:...
    >>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
    >>> >> > and
    >>> >> later
    >>> >> > does some processing and the ExecutionTimeout parameter in the
    >>> >> machine.config
    >>> >> > is 90 seconds then the page does not timeout after 90 seconds.
    >>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
    >>> >> > the
    >>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
    >>> >> > timeout
    >>> >> > after the timeout period.
    >>> >> > Can someone please tell us as to how we can timeout an aspx page
    >>> >> > that
    >>> >> > is
    >>> >> > doing some lengthy processing? Also when exactly does the
    >>> >> > ExecutionTimeout
    >>> >> > take effect?
    >>> >>
    >>> >>
    >>> >>
    >>>
    >>>
    >>> ---
    >>> Outgoing mail is certified Virus Free.
    >>> Checked by AVG anti-virus system (http://www.grisoft.com).
    >>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
    >>>
    >>>
    >>>

    >
    >
    Juan T. Llibre, Jan 10, 2005
    #7
  8. indira,
    you mind saying what you tweaked in addition to the config file setting to
    get this to work?

    --
    Regards,
    Alvin Bruney
    [ASP.NET MVP http://mvp.support.microsoft.com/default.aspx]
    Got tidbits? Get it here... http://tinyurl.com/27cok
    "Juan T. Llibre" <> wrote in message
    news:%...
    > It seems to have worked for Indira.
    >
    >
    >
    > Juan T. Llibre
    > ASP.NET MVP
    > ===========
    > "Alvin Bruney [MVP]" <vapor at steaming post office> wrote in message
    > news:%...
    >> FYI:
    >> I've never known that executionTimeout to actually work irespective of
    >> the settings applied.
    >> Regards,
    >> Alvin Bruney

    >
    >> "Indira" <> wrote in message
    >> news:...
    >>> Thanx a lot everyone.
    >>> Struggled a lot with this problem.
    >>>
    >>>
    >>>
    >>> "Juan T. Llibre [MVP]" wrote:
    >>>
    >>>> re:
    >>>> >The 'debug' attribute in web.config is set to true.
    >>>>
    >>>> 'ExecutionTimeout' only applies if the debug
    >>>> attribute in the compilation element is set to false.
    >>>>
    >>>>
    >>>>
    >>>>
    >>>> Juan T. Llibre
    >>>> ===========
    >>>> "Shalini" <> wrote in message
    >>>> news:...
    >>>> >I am not getting the timeout in any case whether I am ruuning the
    >>>> >application
    >>>> > locally or remotely. I have tried several times. Even though the
    >>>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the
    >>>> > request
    >>>> > doesnot timeout. The 'debug' attribute in web.config is set to true.
    >>>> > Is
    >>>> > some
    >>>> > other setting required to be made? If not then what is the reason for
    >>>> > the
    >>>> > timeout not happening? Could anyone please elaborate?
    >>>> >
    >>>> > "William F. Robertson, Jr." wrote:
    >>>> >
    >>>> >> I am not sure if this is your situation, but I could never get a
    >>>> >> "Request
    >>>> >> Timed Out." when I was running the browser and the server on my
    >>>> >> local
    >>>> >> machine. I had to use my browser to hit a remote machine. My
    >>>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
    >>>> >> Are
    >>>> >> you
    >>>> >> running everything on your local machine?
    >>>> >>
    >>>> >> bill
    >>>> >>
    >>>> >> "Shalini" <> wrote in message
    >>>> >> news:...
    >>>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
    >>>> >> > and
    >>>> >> later
    >>>> >> > does some processing and the ExecutionTimeout parameter in the
    >>>> >> machine.config
    >>>> >> > is 90 seconds then the page does not timeout after 90 seconds.
    >>>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
    >>>> >> > the
    >>>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
    >>>> >> > timeout
    >>>> >> > after the timeout period.
    >>>> >> > Can someone please tell us as to how we can timeout an aspx page
    >>>> >> > that
    >>>> >> > is
    >>>> >> > doing some lengthy processing? Also when exactly does the
    >>>> >> > ExecutionTimeout
    >>>> >> > take effect?
    >>>> >>
    >>>> >>
    >>>> >>
    >>>>
    >>>>
    >>>> ---
    >>>> Outgoing mail is certified Virus Free.
    >>>> Checked by AVG anti-virus system (http://www.grisoft.com).
    >>>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
    >>>>
    >>>>
    >>>>

    >>
    >>

    >
    >
    Alvin Bruney [MVP], Jan 10, 2005
    #8
  9. Nothin else.
    I just made sure 'executionTimeout' attribute of httpRuntime element is set
    to its default value of 90 seconds in the machine.config and that it is not
    being overridden in web.config.
    I just needed to change the value of the 'debug' attribute to true and the
    executionTimeout took effect.

    "Alvin Bruney [MVP]" wrote:

    > indira,
    > you mind saying what you tweaked in addition to the config file setting to
    > get this to work?
    >
    > --
    > Regards,
    > Alvin Bruney
    > [ASP.NET MVP http://mvp.support.microsoft.com/default.aspx]
    > Got tidbits? Get it here... http://tinyurl.com/27cok
    > "Juan T. Llibre" <> wrote in message
    > news:%...
    > > It seems to have worked for Indira.
    > >
    > >
    > >
    > > Juan T. Llibre
    > > ASP.NET MVP
    > > ===========
    > > "Alvin Bruney [MVP]" <vapor at steaming post office> wrote in message
    > > news:%...
    > >> FYI:
    > >> I've never known that executionTimeout to actually work irespective of
    > >> the settings applied.
    > >> Regards,
    > >> Alvin Bruney

    > >
    > >> "Indira" <> wrote in message
    > >> news:...
    > >>> Thanx a lot everyone.
    > >>> Struggled a lot with this problem.
    > >>>
    > >>>
    > >>>
    > >>> "Juan T. Llibre [MVP]" wrote:
    > >>>
    > >>>> re:
    > >>>> >The 'debug' attribute in web.config is set to true.
    > >>>>
    > >>>> 'ExecutionTimeout' only applies if the debug
    > >>>> attribute in the compilation element is set to false.
    > >>>>
    > >>>>
    > >>>>
    > >>>>
    > >>>> Juan T. Llibre
    > >>>> ===========
    > >>>> "Shalini" <> wrote in message
    > >>>> news:...
    > >>>> >I am not getting the timeout in any case whether I am ruuning the
    > >>>> >application
    > >>>> > locally or remotely. I have tried several times. Even though the
    > >>>> > 'ExecutionTimeout' in machine.config is set to 90 seconds, the
    > >>>> > request
    > >>>> > doesnot timeout. The 'debug' attribute in web.config is set to true.
    > >>>> > Is
    > >>>> > some
    > >>>> > other setting required to be made? If not then what is the reason for
    > >>>> > the
    > >>>> > timeout not happening? Could anyone please elaborate?
    > >>>> >
    > >>>> > "William F. Robertson, Jr." wrote:
    > >>>> >
    > >>>> >> I am not sure if this is your situation, but I could never get a
    > >>>> >> "Request
    > >>>> >> Timed Out." when I was running the browser and the server on my
    > >>>> >> local
    > >>>> >> machine. I had to use my browser to hit a remote machine. My
    > >>>> >> machine.config timeout is 90 seconds, and it does timeout remotely.
    > >>>> >> Are
    > >>>> >> you
    > >>>> >> running everything on your local machine?
    > >>>> >>
    > >>>> >> bill
    > >>>> >>
    > >>>> >> "Shalini" <> wrote in message
    > >>>> >> news:...
    > >>>> >> > If I have an ASPX page that is just sleeping for 3 minutes ormore
    > >>>> >> > and
    > >>>> >> later
    > >>>> >> > does some processing and the ExecutionTimeout parameter in the
    > >>>> >> machine.config
    > >>>> >> > is 90 seconds then the page does not timeout after 90 seconds.
    > >>>> >> > Even if the ExecutionTimeout parameter in the web.config is set or
    > >>>> >> > the
    > >>>> >> > Server.ScriptTimeout is set in the aspx.cs still the page does not
    > >>>> >> > timeout
    > >>>> >> > after the timeout period.
    > >>>> >> > Can someone please tell us as to how we can timeout an aspx page
    > >>>> >> > that
    > >>>> >> > is
    > >>>> >> > doing some lengthy processing? Also when exactly does the
    > >>>> >> > ExecutionTimeout
    > >>>> >> > take effect?
    > >>>> >>
    > >>>> >>
    > >>>> >>
    > >>>>
    > >>>>
    > >>>> ---
    > >>>> Outgoing mail is certified Virus Free.
    > >>>> Checked by AVG anti-virus system (http://www.grisoft.com).
    > >>>> Version: 6.0.794 / Virus Database: 538 - Release Date: 11/10/2004
    > >>>>
    > >>>>
    > >>>>
    > >>
    > >>

    > >
    > >

    >
    >
    >
    =?Utf-8?B?SW5kaXJh?=, Jan 24, 2005
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?TWljcm9zb2Z0IENlbnRyZSBPZiBFeGNlbGxlbmNl

    Unable to timeout a long running request

    =?Utf-8?B?TWljcm9zb2Z0IENlbnRyZSBPZiBFeGNlbGxlbmNl, Jan 5, 2005, in forum: ASP .Net
    Replies:
    4
    Views:
    429
    =?Utf-8?B?SW5kaXJh?=
    Jan 7, 2005
  2. George Marsaglia

    Assigning unsigned long to unsigned long long

    George Marsaglia, Jul 8, 2003, in forum: C Programming
    Replies:
    1
    Views:
    672
    Eric Sosman
    Jul 8, 2003
  3. John Nagle
    Replies:
    0
    Views:
    494
    John Nagle
    Jan 3, 2008
  4. Stupid48
    Replies:
    6
    Views:
    148
    Ken Schaefer
    Mar 18, 2005
  5. Mark Probert

    Timeout::timeout and Socket timeout

    Mark Probert, Oct 6, 2004, in forum: Ruby
    Replies:
    1
    Views:
    1,279
    Brian Candler
    Oct 6, 2004
Loading...

Share This Page