HTTP 500 status error

Discussion in 'Java' started by mahajan.vibhor@gmail.com, Dec 25, 2005.

  1. Guest

    Hello

    I have installed JDK 1.4.06 and Tomcat 5.0.28 on Win2000 machine. I
    have set JAVA_HOME to java home directory and not bin directory.

    I am able to run Tomcat default index. jsp page and examples of JSP and
    servelet provided with the Tomcat.

    When I try run my jsp and servelet I get error HTTP 500 status error
    with this message "Unable to find a javac compiler;
    com.sun.tools.javac.Main is not on the classpath. Perhaps JAVA_HOME
    does not point to the JDK"

    I have set JAVA_HOME for both user nad system variables. I also tried
    setting CATALINA_HOME to Tomcat hoime directory. Setting of CLASSPATH
    variable is also not working.

    Thanks in advance
     
    , Dec 25, 2005
    #1
    1. Advertising

  2. JScoobyCed Guest

    wrote:
    > Hello
    >
    > I have installed JDK 1.4.06 and Tomcat 5.0.28 on Win2000 machine. I
    > have set JAVA_HOME to java home directory and not bin directory.
    >
    > I am able to run Tomcat default index. jsp page and examples of JSP and
    > servelet provided with the Tomcat.
    >
    > When I try run my jsp and servelet I get error HTTP 500 status error
    > with this message "Unable to find a javac compiler;
    > com.sun.tools.javac.Main is not on the classpath. Perhaps JAVA_HOME
    > does not point to the JDK"
    >
    > I have set JAVA_HOME for both user nad system variables. I also tried
    > setting CATALINA_HOME to Tomcat hoime directory. Setting of CLASSPATH
    > variable is also not working.
    >
    > Thanks in advance
    >


    It seems you have set the JAVA_HOME to the JRE, not the JDK. When you
    install java from the j2sdk installer, it will put the public JRE in
    (for windows) c:\program files\java\jre. But also it installs the SDK in
    c:\j2sdk_xxx by default, or any path you have specified. In this folder
    there is another jre (the same, just a duplication for development purpose).
    So you should set the JAVA_HOME to the SDK path, not the JRE.

    --
    JSC
     
    JScoobyCed, Dec 26, 2005
    #2
    1. Advertising

  3. Roedy Green Guest

    On Mon, 26 Dec 2005 08:31:16 +0700, JScoobyCed <> wrote,
    quoted or indirectly quoted someone who said :

    >> I have set JAVA_HOME for both user nad system variables. I also tried
    >> setting CATALINA_HOME to Tomcat hoime directory. Setting of CLASSPATH
    >> variable is also not working.


    see http://mindprod.com/jgloss/jdk.html#TESTING
    --
    Canadian Mind Products, Roedy Green.
    http://mindprod.com Java custom programming, consulting and coaching.
     
    Roedy Green, Dec 26, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. NNTP
    Replies:
    2
    Views:
    1,010
    =?Utf-8?B?S2V2aW4gVG9kZA==?=
    Mar 18, 2005
  2. larkpics
    Replies:
    9
    Views:
    9,055
    Patrick.O.Ige
    Oct 22, 2005
  3. Matt
    Replies:
    1
    Views:
    617
    Ryan Stewart
    Jun 9, 2004
  4. James
    Replies:
    2
    Views:
    9,155
    Jacek Dziedzic
    Nov 3, 2004
  5. Tony V
    Replies:
    0
    Views:
    179
    Tony V
    Aug 12, 2003
Loading...

Share This Page