HTTP Error 404 - File or directory not found

Discussion in 'ASP General' started by anuragsaxenajpr@hotmail.com, Jan 19, 2006.

  1. Guest

    I am using IIS 6.0 under windows 2003 server and unable to run the .ASP
    page, when I try to run ASP page the error comes on IE is


    HTTP Error 404 - File or directory not found.
    Internet Information Services (IIS)


    The file exist in respective directory and directory is also virtual.
    Also I am very much able to run .ASPX page exist on the same directory.

    I also checked configuration settings for .ASP extension and found that
    all settings are correct.

    This is somewhat urgent, Please help me on that issue.
    Thanks in Advance.
     
    , Jan 19, 2006
    #1
    1. Advertising

  2. You may open the IIS manager window, click the "Web Service Extesions", is
    "Active Server Pages" set "allowed" here? if not, you may set it to
    "allowed" and reset your IIS to see if this will help.

    Luke
     
    Luke Zhang [MSFT], Jan 19, 2006
    #2
    1. Advertising

  3. dNagel Guest

    Make sure that Parent Paths is turned on in the properties for your site or web.
    ???
    Is it possible that you're trying to ref something up the directory hierarchy and
    with Parent Paths turned off, it can't get there?

    D.


    Edward Low wrote:
    > Hi all,
    >
    > I am facing the same problem. The ASP page in the main virtual dircetory
    > running well, but the asp page in the sub folder will give me the error 404.
    > I have checked, the Web service extension for "ASP" is set to allowed, yet
    > still giving me the same problem.
    >
    > any best way to solve this issue?
    >
    > Best Regard,
    > Edward
    >
    > "Luke Zhang [MSFT]" <> wrote in message
    > news:...
    >
    >>You may open the IIS manager window, click the "Web Service Extesions", is
    >>"Active Server Pages" set "allowed" here? if not, you may set it to
    >>"allowed" and reset your IIS to see if this will help.
    >>
    >>Luke
    >>

    >
    >
    >
     
    dNagel, Jan 20, 2006
    #3
  4. Edward Low Guest

    Hi all,

    I am facing the same problem. The ASP page in the main virtual dircetory
    running well, but the asp page in the sub folder will give me the error 404.
    I have checked, the Web service extension for "ASP" is set to allowed, yet
    still giving me the same problem.

    any best way to solve this issue?

    Best Regard,
    Edward

    "Luke Zhang [MSFT]" <> wrote in message
    news:...
    > You may open the IIS manager window, click the "Web Service Extesions", is
    > "Active Server Pages" set "allowed" here? if not, you may set it to
    > "allowed" and reset your IIS to see if this will help.
    >
    > Luke
    >
     
    Edward Low, Jan 20, 2006
    #4
  5. Edward Low Guest

    Hi,

    thanks! Got it done.

    Edward

    "dNagel" <> wrote in message
    news:...
    > Make sure that Parent Paths is turned on in the properties for your site
    > or web.
    > ???
    > Is it possible that you're trying to ref something up the directory
    > hierarchy and
    > with Parent Paths turned off, it can't get there?
    >
    > D.
    >
    >
    > Edward Low wrote:
    >> Hi all,
    >>
    >> I am facing the same problem. The ASP page in the main virtual dircetory
    >> running well, but the asp page in the sub folder will give me the error
    >> 404. I have checked, the Web service extension for "ASP" is set to
    >> allowed, yet still giving me the same problem.
    >>
    >> any best way to solve this issue?
    >>
    >> Best Regard,
    >> Edward
    >>
    >> "Luke Zhang [MSFT]" <> wrote in message
    >> news:...
    >>
    >>>You may open the IIS manager window, click the "Web Service Extesions",
    >>>is
    >>>"Active Server Pages" set "allowed" here? if not, you may set it to
    >>>"allowed" and reset your IIS to see if this will help.
    >>>
    >>>Luke
    >>>

    >>
    >>
     
    Edward Low, Jan 21, 2006
    #5
  6. Guest

    IIS 6.0 is different with IIS 5.x
    if you used "include" in your pages and you had not changed the default
    settings, it will be show file not find.
    you can try to change some settings in IIS.
     
    , Feb 2, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Brent Martin

    AXD 404 File or Directory Not Found Error

    Brent Martin, Nov 10, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    5,102
    epi_boy
    Jan 23, 2008
  2. Replies:
    0
    Views:
    438
  3. Deven
    Replies:
    0
    Views:
    513
    Deven
    Nov 26, 2008
  4. Deven
    Replies:
    5
    Views:
    7,676
    Deven
    Aug 2, 2009
  5. Replies:
    4
    Views:
    205
    Tim Slattery
    Feb 7, 2007
Loading...

Share This Page