HttpHandler, User Control image display issue when deployed

Discussion in 'ASP .Net' started by =?Utf-8?B?TWFuaWtrb3Ro?=, Aug 29, 2005.

  1. Hello,
    We are using a user control and a HttpHandler to display an image in a grid.
    The images are stored in a RDBMS. Here is the approach that we use in brief.
    The cells are added to the grid in the page load. One of the cell is the
    control. The control Response.Writes an img tag. The src for the img tag is
    "something.img". Now we have a HttpHandler for *.img, the hander reads the
    image from DB and does a Response.BinaryWrite. Everything is working fine
    when we run it in Visual Studio (debug / run). But when we deploy it in a
    virtual directory, the images are not displayed (shows a thumbnail "red
    cross"). We did add the handler in web.config, and in IIS.
    Any clues?

    Thanks,
     
    =?Utf-8?B?TWFuaWtrb3Ro?=, Aug 29, 2005
    #1
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Joe
    Replies:
    1
    Views:
    600
  2. Replies:
    1
    Views:
    1,391
    Metalore
    Oct 18, 2006
  3. =?Utf-8?B?TWFuaWtrb3Ro?=

    HttpHandler not working when deployed in a virtual directory

    =?Utf-8?B?TWFuaWtrb3Ro?=, Aug 26, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    601
    =?Utf-8?B?TWFuaWtrb3Ro?=
    Aug 26, 2005
  4. Mad Scientist Jr
    Replies:
    0
    Views:
    892
    Mad Scientist Jr
    Mar 22, 2006
  5. Replies:
    1
    Views:
    717
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=
    Sep 16, 2007
  6. Replies:
    0
    Views:
    720
  7. Jonathan Wood

    User Control to Control Other User Control

    Jonathan Wood, Jan 24, 2010, in forum: ASP .Net
    Replies:
    4
    Views:
    806
    Jonathan Wood
    Feb 2, 2010
  8. Replies:
    1
    Views:
    347
Loading...