HTTPS - Window. code not working anymore

Discussion in 'ASP .Net Security' started by Tersia Ehlert, Jan 10, 2005.

  1. Hi

    I have an .NET web application where I redirect a page on submit to a blank page where the code below runs client side.

    I want to, with this code, refresh two frames - the one my page was opened in and another frame loading a list of items assigned to me.

    This code was working 100% until we chnaged the site to a secure site (HTTPS) - now it seems that I cannot use window. anumore in code.

    Does anyone know who I can overcome this issue?

    Thanks
    Tersia Ehlert

    function window_onload()

    ' Sets variable equal to obj - worklist.aspx

    dim workspacePage

    dim itemClosedPage


    workspacePage = "k2v3/workspace/worklist.aspx"

    itemClosedPage = "k2v3/workspace/worklist/itemclosed.aspx"


    '// Find where the parent application (K2.net Workspace) was installed and

    '// and get the ItemClosed.aspx location

    dim loc

    on error resume next

    loc = LCase(window.parent.location.toString())

    if err.number > 0 then

    '// Cannot continue

    loc = "ERROR"

    end if


    'Check if this pages is housed inside the K2.net workspace

    if instr(1, loc, workspacePage) > 0 then

    dim newloc

    newloc = Replace(loc, workspacePage, itemClosedPage)


    '// Display the ItemClosed.aspx page

    window.location = newloc

    '// Refresh the WorkList frame in the K2.net Workspace

    dim itmFrame

    set itmFrame = window.parent.frames("ItemsFrame")

    itmFrame.location.reload

    else

    window.close

    end if



    End Function
     
    Tersia Ehlert, Jan 10, 2005
    #1
    1. Advertising

  2. Tersia Ehlert

    Brad Roberts Guest

    This is probably security related. Try it with your web site in Trusted
    Sites. The browser security settings may be preventing you from doing
    anything malicious(useful).

    "Tersia Ehlert" wrote:

    > Hi
    >
    > I have an .NET web application where I redirect a page on submit to a blank page where the code below runs client side.
    >
    > I want to, with this code, refresh two frames - the one my page was opened in and another frame loading a list of items assigned to me.
    >
    > This code was working 100% until we chnaged the site to a secure site (HTTPS) - now it seems that I cannot use window. anumore in code.
    >
    > Does anyone know who I can overcome this issue?
    >
    > Thanks
    > Tersia Ehlert
    >
    > function window_onload()
    >
    > ' Sets variable equal to obj - worklist.aspx
    >
    > dim workspacePage
    >
    > dim itemClosedPage
    >
    >
    > workspacePage = "k2v3/workspace/worklist.aspx"
    >
    > itemClosedPage = "k2v3/workspace/worklist/itemclosed.aspx"
    >
    >
    > '// Find where the parent application (K2.net Workspace) was installed and
    >
    > '// and get the ItemClosed.aspx location
    >
    > dim loc
    >
    > on error resume next
    >
    > loc = LCase(window.parent.location.toString())
    >
    > if err.number > 0 then
    >
    > '// Cannot continue
    >
    > loc = "ERROR"
    >
    > end if
    >
    >
    > 'Check if this pages is housed inside the K2.net workspace
    >
    > if instr(1, loc, workspacePage) > 0 then
    >
    > dim newloc
    >
    > newloc = Replace(loc, workspacePage, itemClosedPage)
    >
    >
    > '// Display the ItemClosed.aspx page
    >
    > window.location = newloc
    >
    > '// Refresh the WorkList frame in the K2.net Workspace
    >
    > dim itmFrame
    >
    > set itmFrame = window.parent.frames("ItemsFrame")
    >
    > itmFrame.location.reload
    >
    > else
    >
    > window.close
    >
    > end if
    >
    >
    >
    > End Function
    >
     
    Brad Roberts, Jan 10, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Tersia Ehlert

    HTTPS - Window. code not working anymore

    Tersia Ehlert, Jan 10, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    463
    =?Utf-8?B?QnJhZCBSb2JlcnRz?=
    Jan 10, 2005
  2. Dhruba Bandopadhyay

    ASP VIRTUAL keyword not working in ASP.NET anymore :S

    Dhruba Bandopadhyay, Mar 22, 2006, in forum: ASP .Net
    Replies:
    4
    Views:
    4,919
    Dhruba Bandopadhyay
    Mar 22, 2006
  3. Eric Lilja
    Replies:
    4
    Views:
    485
  4. Jeppe Jespersen

    (2.0) Membership not working anymore after deployment

    Jeppe Jespersen, Aug 2, 2006, in forum: ASP .Net Security
    Replies:
    0
    Views:
    112
    Jeppe Jespersen
    Aug 2, 2006
  5. Axel
    Replies:
    8
    Views:
    1,100
    Adrienne Boswell
    Apr 27, 2009
Loading...

Share This Page