I cannot install CDT under eclipse

Discussion in 'Java' started by fl, Nov 14, 2010.

  1. fl

    fl Guest

    Hi,
    My computer has installed eclipse under Linux SUSE. It only has Java.
    Now I want to add CDT for C++ programming. The problem is there is
    only Software Updates, no "Install New Software". So, I cannot install
    CDT for eclipse. How can I install CDT eclipse? SUSE is 11.3. The
    present eclipse for Java is 3.4.0 installed from RPM.
    Thanks.
    fl, Nov 14, 2010
    #1
    1. Advertising

  2. fl

    Nigel Wade Guest

    On 14/11/10 16:49, fl wrote:
    > Hi,
    > My computer has installed eclipse under Linux SUSE. It only has Java.
    > Now I want to add CDT for C++ programming. The problem is there is
    > only Software Updates, no "Install New Software". So, I cannot install
    > CDT for eclipse. How can I install CDT eclipse? SUSE is 11.3. The
    > present eclipse for Java is 3.4.0 installed from RPM.
    > Thanks.



    The simplest way to install the CDT to an existing Eclipse is to
    download the CDT ZIP and install from that. The ZIP for Ganymede (the
    version supplied with OpenSUSE 11.3) can be found here:
    http://download.eclipse.org/tools/cdt/releases/ganymede/
    Follow the link for 5.0.2 to go to the download page for the latest release.

    After downloading the ZIP open the Software Updates dialog. and select
    the Available Software tab and click on Add Site. Click on the Archive
    button and navigate to the downloaded ZIP file. This should add the ZIP
    as an installation source.

    If anything fails during the installation process you may be left with a
    borked Eclipse, unable to run it at all or you get NPE when you try to
    re-install CDT. Un-installing and re-installing Eclipse may be your only
    option.

    Alternatively, you can download the Eclipse IDE for C/C++ at
    http://www.eclipse.org/downloads/ and unpack that. It's not an RPM
    package, and it won't fit nicely with the system software management
    tools. You won't be able to use YaST/zypper to manage it, it won't
    integrate with your desktop applications menu. OTOH it will work.

    --
    Nigel Wade
    Nigel Wade, Nov 15, 2010
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ann

    Eclipse CDT and JNI

    Ann, Oct 24, 2004, in forum: Java
    Replies:
    1
    Views:
    1,565
    IchBin
    Oct 25, 2004
  2. peter
    Replies:
    0
    Views:
    679
    peter
    May 12, 2005
  3. -saarland.de

    Xerces usage under Eclipse CDT..

    -saarland.de, Sep 18, 2006, in forum: XML
    Replies:
    0
    Views:
    777
    -saarland.de
    Sep 18, 2006
  4. Replies:
    2
    Views:
    550
    =?ISO-8859-1?Q?Arne_Vajh=F8j?=
    Oct 5, 2006
  5. fl
    Replies:
    0
    Views:
    255
Loading...

Share This Page