I hate IIS - "Server Application Unavailable" error message

Discussion in 'ASP .Net' started by Kevin Liebowicz, Jul 3, 2007.

  1. Yes, I wasted the past two days trying to fix this.
    Yes, this is on a Win2003 Server.
    Yes, this machine is a domain controller.

    Yes, I seen the dozens of KB articles like this one:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    But the problem is that 99% of these are for ASP .NET 1.x and this
    is .NET 2.x which I just installed to try and get .net working for the
    first time ever. I've see all the HACKS to get .net 1.x working... but
    this is for .net 2.x so these worthless KB articles do nothing for me.

    Example -
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    RESOLUTION
    To work around this problem, use one of the following methods: ·
    Create a weak account that has the correct permissions, and then
    configure the <processModel> section of the Machine.config file to use
    that account.
    · Set the userName attribute to SYSTEM in the <processModel> section
    of the Machine.config file.
    · Configure the <processModel> section of the Machine.config file to
    use an administrator account.


    THIS IS USELESS !!!!! There is no "userName" attribute in the
    Machine.config file in .net 2.x. And if this is a known problem then
    why doesn't the installer warn me or fix it automatically. Sorry, but
    your software sucks lately.!!!!!!!

    The event log is filled with messages like:

    <quote>
    aspnet_wp.exe could not be started. The error code for the failure is
    800700CB. This error can be caused when the worker process account has
    insufficient rights to read the .NET Framework files. Please ensure
    that the .NET Framework is correctly installed and that the ACLs on
    the installation directory allow access to the configured account.
    </quote>


    Sorry Microsoft - But you are getting WORSE and WORSE. How about
    software that simply works????

    It's no wonder that Linux is kicking your butt and I'm about 30
    seconds away from saying goodbye to your over-complicated bug ridden
    crap and making the transition to linux myself.
    Kevin Liebowicz, Jul 3, 2007
    #1
    1. Advertising

  2. Kevin Liebowicz

    Otavio Decio Guest

    Framework versions mixup maybe? Did you check the ASP.NET tab page on the
    site properties and made sure it is set to the right version? Did you go to
    the Web Service Extensions and made sure the proper extensions are enabled?
    If nothing else works, try re-registering 2.0 for asp.net
    (aspnet_regiis.exe)

    Calm down, 2.0 is way better than 1.1 and it is worth the trouble.

    Otavio


    "Kevin Liebowicz" <> wrote in message
    news:...
    Yes, I wasted the past two days trying to fix this.
    Yes, this is on a Win2003 Server.
    Yes, this machine is a domain controller.

    Yes, I seen the dozens of KB articles like this one:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    But the problem is that 99% of these are for ASP .NET 1.x and this
    is .NET 2.x which I just installed to try and get .net working for the
    first time ever. I've see all the HACKS to get .net 1.x working... but
    this is for .net 2.x so these worthless KB articles do nothing for me.

    Example -
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    RESOLUTION
    To work around this problem, use one of the following methods: ·
    Create a weak account that has the correct permissions, and then
    configure the <processModel> section of the Machine.config file to use
    that account.
    · Set the userName attribute to SYSTEM in the <processModel> section
    of the Machine.config file.
    · Configure the <processModel> section of the Machine.config file to
    use an administrator account.


    THIS IS USELESS !!!!! There is no "userName" attribute in the
    Machine.config file in .net 2.x. And if this is a known problem then
    why doesn't the installer warn me or fix it automatically. Sorry, but
    your software sucks lately.!!!!!!!

    The event log is filled with messages like:

    <quote>
    aspnet_wp.exe could not be started. The error code for the failure is
    800700CB. This error can be caused when the worker process account has
    insufficient rights to read the .NET Framework files. Please ensure
    that the .NET Framework is correctly installed and that the ACLs on
    the installation directory allow access to the configured account.
    </quote>


    Sorry Microsoft - But you are getting WORSE and WORSE. How about
    software that simply works????

    It's no wonder that Linux is kicking your butt and I'm about 30
    seconds away from saying goodbye to your over-complicated bug ridden
    crap and making the transition to linux myself.
    Otavio Decio, Jul 3, 2007
    #2
    1. Advertising

  3. On Jul 2, 9:20 pm, "Otavio Decio" <> wrote:

    > Framework versions mixup maybe?

    Or maybe Microsoft needs to get their house in order.


    > Did you check the ASP.NET tab page on the site
    > properties and made sure it is set to the right version?

    Version 2.0.50727

    > Did you go to the Web Service Extensions and
    > made sure the proper extensions are enabled?

    I have no idea where this is. Default doc types include .asp (which
    works great) and .aspx. This is my first time every trying to get a
    simple HelloWorld.aspx page to load and the experience simply SUCKS.
    Sorry, but there's no other way to describe this fiasco.

    > If nothing else works, try re-registering 2.0 for asp.net
    > (aspnet_regiis.exe)

    Been there, done that. Found this and a bunch of other "re-register"
    tips all over the web. None work.


    > Calm down, 2.0 is way better than 1.1 and it is worth the trouble.

    I'm starting to have my doubts about this. Microsoft can't be bothered
    to write software that works (ex: this and Vista) so I'm really
    starting to think that I need to look at FREE alternatives.

    I paid good money for Server 2003 and it ought to at least work as
    advertised.



    >
    > Otavio
    >
    > "Kevin Liebowicz" <> wrote in message
    >
    > news:...
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.
    >
    > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > But the problem is that 99% of these are for ASP .NET 1.x and this
    > is .NET 2.x which I just installed to try and get .net working for the
    > first time ever. I've see all the HACKS to get .net 1.x working... but
    > this is for .net 2.x so these worthless KB articles do nothing for me.
    >
    > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > RESOLUTION
    > To work around this problem, use one of the following methods: ·
    > Create a weak account that has the correct permissions, and then
    > configure the <processModel> section of the Machine.config file to use
    > that account.
    > · Set the userName attribute to SYSTEM in the <processModel> section
    > of the Machine.config file.
    > · Configure the <processModel> section of the Machine.config file to
    > use an administrator account.
    >
    > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > Machine.config file in .net 2.x. And if this is a known problem then
    > why doesn't the installer warn me or fix it automatically. Sorry, but
    > your software sucks lately.!!!!!!!
    >
    > The event log is filled with messages like:
    >
    > <quote>
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 800700CB. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the .NET Framework is correctly installed and that the ACLs on
    > the installation directory allow access to the configured account.
    > </quote>
    >
    > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > software that simply works????
    >
    > It's no wonder that Linux is kicking your butt and I'm about 30
    > seconds away from saying goodbye to your over-complicated bug ridden
    > crap and making the transition to linux myself.
    Kevin Liebowicz, Jul 3, 2007
    #3
  4. re:
    !> Yes, this is on a Win2003 Server.
    !> Yes, this machine is a domain controller.

    Bad idea.

    In general, it's not advisable to run your Web server on a domain controller,
    because a compromise of the machine is a compromise of the domain.

    But, if you *really* need to do that...

    re:
    !> There is no "userName" attribute in the Machine.config file in .net 2.x.

    Yes, there is.

    <processModel enable="true" userName="SYSTEM" password="AutoGenerate" />

    ....ought to cover it for you, if you *really* want to run ASP.NET
    as the SYSTEM account on a domain controller, although I would encrypt the section.

    Even better, I would NOT run ASP.NET as the System account. See below...

    re:
    !> The event log is filled with messages like:

    It's no wonder that is happening.

    re:
    !> How about software that simply works????

    If you deliberately run ASP.NET on a domain controller,
    something which is not recommended, don't blame Microsoft
    if you can't RTFM to implement the workaround.

    http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx

    Even better than using the System account would be specifing an explicit account.

    That works around the security problems which
    running ASP.NET on a domain controller exposes you to.

    To do that, follow the instructions in this article...

    How To: Create a Service Account for an ASP.NET 2.0 Application:
    http://msdn2.microsoft.com/en-us/library/ms998297.aspx

    Try it. It's really easy to do.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Kevin Liebowicz" <> wrote in message news:...
    Yes, I wasted the past two days trying to fix this.
    Yes, this is on a Win2003 Server.
    Yes, this machine is a domain controller.

    Yes, I seen the dozens of KB articles like this one:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    But the problem is that 99% of these are for ASP .NET 1.x and this
    is .NET 2.x which I just installed to try and get .net working for the
    first time ever. I've see all the HACKS to get .net 1.x working... but
    this is for .net 2.x so these worthless KB articles do nothing for me.

    Example -
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    RESOLUTION
    To work around this problem, use one of the following methods: ·
    Create a weak account that has the correct permissions, and then
    configure the <processModel> section of the Machine.config file to use
    that account.
    · Set the userName attribute to SYSTEM in the <processModel> section
    of the Machine.config file.
    · Configure the <processModel> section of the Machine.config file to
    use an administrator account.


    THIS IS USELESS !!!!! There is no "userName" attribute in the
    Machine.config file in .net 2.x. And if this is a known problem then
    why doesn't the installer warn me or fix it automatically. Sorry, but
    your software sucks lately.!!!!!!!

    The event log is filled with messages like:

    <quote>
    aspnet_wp.exe could not be started. The error code for the failure is
    800700CB. This error can be caused when the worker process account has
    insufficient rights to read the .NET Framework files. Please ensure
    that the .NET Framework is correctly installed and that the ACLs on
    the installation directory allow access to the configured account.
    </quote>


    Sorry Microsoft - But you are getting WORSE and WORSE. How about
    software that simply works????

    It's no wonder that Linux is kicking your butt and I'm about 30
    seconds away from saying goodbye to your over-complicated bug ridden
    crap and making the transition to linux myself.
    Juan T. Llibre, Jul 3, 2007
    #4
  5. Kevin Liebowicz

    Otavio Decio Guest

    > Did you go to the Web Service Extensions and
    > made sure the proper extensions are enabled?

    I have no idea where this is.

    It can be accessed in IIS Manager at the same level as Web Sites and
    Application Pools. One of the items is ASP.NET v2.0.50727, must be set to
    "Allowed". I believe they are locked down by default.

    One thing I would do is launch Filemon and observe if there are files that
    can't be found or opened.

    If you are looking for free alternatives, JBoss or Tomcat are good places to
    start. Java is not a bad environment, really. But believe me, I developed
    quite a bit of web apps and have few complaints about Server 2003.

    Otavio



    "Kevin Liebowicz" <> wrote in message
    news:...
    On Jul 2, 9:20 pm, "Otavio Decio" <> wrote:

    > Framework versions mixup maybe?

    Or maybe Microsoft needs to get their house in order.


    > Did you check the ASP.NET tab page on the site
    > properties and made sure it is set to the right version?

    Version 2.0.50727

    > Did you go to the Web Service Extensions and
    > made sure the proper extensions are enabled?

    I have no idea where this is. Default doc types include .asp (which
    works great) and .aspx. This is my first time every trying to get a
    simple HelloWorld.aspx page to load and the experience simply SUCKS.
    Sorry, but there's no other way to describe this fiasco.

    > If nothing else works, try re-registering 2.0 for asp.net
    > (aspnet_regiis.exe)

    Been there, done that. Found this and a bunch of other "re-register"
    tips all over the web. None work.


    > Calm down, 2.0 is way better than 1.1 and it is worth the trouble.

    I'm starting to have my doubts about this. Microsoft can't be bothered
    to write software that works (ex: this and Vista) so I'm really
    starting to think that I need to look at FREE alternatives.

    I paid good money for Server 2003 and it ought to at least work as
    advertised.



    >
    > Otavio
    >
    > "Kevin Liebowicz" <> wrote in message
    >
    > news:...
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.
    >
    > Yes, I seen the dozens of KB articles like this
    > one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > But the problem is that 99% of these are for ASP .NET 1.x and this
    > is .NET 2.x which I just installed to try and get .net working for the
    > first time ever. I've see all the HACKS to get .net 1.x working... but
    > this is for .net 2.x so these worthless KB articles do nothing for me.
    >
    > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > RESOLUTION
    > To work around this problem, use one of the following methods: ·
    > Create a weak account that has the correct permissions, and then
    > configure the <processModel> section of the Machine.config file to use
    > that account.
    > · Set the userName attribute to SYSTEM in the <processModel> section
    > of the Machine.config file.
    > · Configure the <processModel> section of the Machine.config file to
    > use an administrator account.
    >
    > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > Machine.config file in .net 2.x. And if this is a known problem then
    > why doesn't the installer warn me or fix it automatically. Sorry, but
    > your software sucks lately.!!!!!!!
    >
    > The event log is filled with messages like:
    >
    > <quote>
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 800700CB. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the .NET Framework is correctly installed and that the ACLs on
    > the installation directory allow access to the configured account.
    > </quote>
    >
    > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > software that simply works????
    >
    > It's no wonder that Linux is kicking your butt and I'm about 30
    > seconds away from saying goodbye to your over-complicated bug ridden
    > crap and making the transition to linux myself.
    Otavio Decio, Jul 3, 2007
    #5
  6. Ouch Juan. I am praying for this guy's funeral. :)

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA
    http://gregorybeamer.spaces.live.com
    Co-author: Microsoft Expression Web Bible (upcoming)

    ************************************************
    Think outside the box!
    ************************************************
    "Juan T. Llibre" <> wrote in message
    news:...
    > re:
    > !> Yes, this is on a Win2003 Server.
    > !> Yes, this machine is a domain controller.
    >
    > Bad idea.
    >
    > In general, it's not advisable to run your Web server on a domain
    > controller,
    > because a compromise of the machine is a compromise of the domain.
    >
    > But, if you *really* need to do that...
    >
    > re:
    > !> There is no "userName" attribute in the Machine.config file in .net
    > 2.x.
    >
    > Yes, there is.
    >
    > <processModel enable="true" userName="SYSTEM" password="AutoGenerate" />
    >
    > ...ought to cover it for you, if you *really* want to run ASP.NET
    > as the SYSTEM account on a domain controller, although I would encrypt the
    > section.
    >
    > Even better, I would NOT run ASP.NET as the System account. See below...
    >
    > re:
    > !> The event log is filled with messages like:
    >
    > It's no wonder that is happening.
    >
    > re:
    > !> How about software that simply works????
    >
    > If you deliberately run ASP.NET on a domain controller,
    > something which is not recommended, don't blame Microsoft
    > if you can't RTFM to implement the workaround.
    >
    > http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx
    >
    > Even better than using the System account would be specifing an explicit
    > account.
    >
    > That works around the security problems which
    > running ASP.NET on a domain controller exposes you to.
    >
    > To do that, follow the instructions in this article...
    >
    > How To: Create a Service Account for an ASP.NET 2.0 Application:
    > http://msdn2.microsoft.com/en-us/library/ms998297.aspx
    >
    > Try it. It's really easy to do.
    >
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Kevin Liebowicz" <> wrote in message
    > news:...
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.
    >
    > Yes, I seen the dozens of KB articles like this one:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > But the problem is that 99% of these are for ASP .NET 1.x and this
    > is .NET 2.x which I just installed to try and get .net working for the
    > first time ever. I've see all the HACKS to get .net 1.x working... but
    > this is for .net 2.x so these worthless KB articles do nothing for me.
    >
    > Example -
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > RESOLUTION
    > To work around this problem, use one of the following methods: ·
    > Create a weak account that has the correct permissions, and then
    > configure the <processModel> section of the Machine.config file to use
    > that account.
    > · Set the userName attribute to SYSTEM in the <processModel> section
    > of the Machine.config file.
    > · Configure the <processModel> section of the Machine.config file to
    > use an administrator account.
    >
    >
    > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > Machine.config file in .net 2.x. And if this is a known problem then
    > why doesn't the installer warn me or fix it automatically. Sorry, but
    > your software sucks lately.!!!!!!!
    >
    > The event log is filled with messages like:
    >
    > <quote>
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 800700CB. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the .NET Framework is correctly installed and that the ACLs on
    > the installation directory allow access to the configured account.
    > </quote>
    >
    >
    > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > software that simply works????
    >
    > It's no wonder that Linux is kicking your butt and I'm about 30
    > seconds away from saying goodbye to your over-complicated bug ridden
    > crap and making the transition to linux myself.
    >
    >
    >
    Cowboy \(Gregory A. Beamer\), Jul 3, 2007
    #6
  7. Juan has given you the hangman's noose. Now I am going to inform you why
    Juan told you not to do this.

    You can get it running on a domain controller by altering this account. The
    problem is you now leave a big hole into your domain controller.

    Why is this a problem? Well, once someone has control of your domain
    controller, they have control of your domain.

    And, why is that dangerous? Do you hold ANY secrets. You know, things like
    customer's credit cards, you own employee's social security numbers?
    Anything like that? Well, you have the potential of leaving it all open for
    someone.

    Can this really happen? Well, the likelihood is fairly low. It is almost
    impossible on a NORMAL web server, but it is a bit more of a risk on web
    server that happens to sit on a DC.

    Can you mitigate this. Certainly. Buy a web server.

    Here is the bottom line. Is it less risky to tell the person forcing you to
    do this to buy a web server or to have your customer's data stolen (and
    perhaps your own) or to risk you job telling your boss he needs to spend a
    few thousand on a web server? If the later, then find a better job. And, if
    it is you that is the boss deciding you need to risk your whole business
    over a couple of thosand dollars, then I am wating my time.

    Don't put your web server on a DC ... EVER.

    Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    --
    Gregory A. Beamer
    MVP; MCP: +I, SE, SD, DBA
    http://gregorybeamer.spaces.live.com
    Co-author: Microsoft Expression Web Bible (upcoming)

    ************************************************
    Think outside the box!
    ************************************************
    "Kevin Liebowicz" <> wrote in message
    news:...
    Yes, I wasted the past two days trying to fix this.
    Yes, this is on a Win2003 Server.
    Yes, this machine is a domain controller.

    Yes, I seen the dozens of KB articles like this one:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    But the problem is that 99% of these are for ASP .NET 1.x and this
    is .NET 2.x which I just installed to try and get .net working for the
    first time ever. I've see all the HACKS to get .net 1.x working... but
    this is for .net 2.x so these worthless KB articles do nothing for me.

    Example -
    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    RESOLUTION
    To work around this problem, use one of the following methods: ·
    Create a weak account that has the correct permissions, and then
    configure the <processModel> section of the Machine.config file to use
    that account.
    · Set the userName attribute to SYSTEM in the <processModel> section
    of the Machine.config file.
    · Configure the <processModel> section of the Machine.config file to
    use an administrator account.


    THIS IS USELESS !!!!! There is no "userName" attribute in the
    Machine.config file in .net 2.x. And if this is a known problem then
    why doesn't the installer warn me or fix it automatically. Sorry, but
    your software sucks lately.!!!!!!!

    The event log is filled with messages like:

    <quote>
    aspnet_wp.exe could not be started. The error code for the failure is
    800700CB. This error can be caused when the worker process account has
    insufficient rights to read the .NET Framework files. Please ensure
    that the .NET Framework is correctly installed and that the ACLs on
    the installation directory allow access to the configured account.
    </quote>


    Sorry Microsoft - But you are getting WORSE and WORSE. How about
    software that simply works????

    It's no wonder that Linux is kicking your butt and I'm about 30
    seconds away from saying goodbye to your over-complicated bug ridden
    crap and making the transition to linux myself.
    Cowboy \(Gregory A. Beamer\), Jul 3, 2007
    #7
  8. re:
    !> Ouch Juan. I am praying for this guy's funeral. :)

    heh...

    The problem is that some people like going to funerals
    so much that they are willing to die so they get to go to one.

    ;-)

    What gets me most, though, is the tendency to blame Microsoft, instead of taking advantage
    of the immense technical knowledge of the regulars who come here quite willing to help anybody
    who asks nicely, at the cheapest price possible : free.

    There's all kinds of specialists who frequent here.

    You are one of the best architecture guys there is; I'm more of a setup, optimization and troubleshooting
    specialist; there's programming whizzes like Bruce Barker, Kevin Spencer and Mark Rae here, and
    creative application specialists like Peter Bromberg, and that's just the tip of the iceberg.

    There's many more whom it would be exhausting to mention
    ....and our collective knowledge can be had just for the asking.

    Why someone would rant against Microsoft when just asking nicely,
    right here, would get him on the road to solving his problems is beyond me.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Cowboy (Gregory A. Beamer)" <> wrote in message
    news:%...

    > Ouch Juan. I am praying for this guy's funeral. :)
    > Gregory A. Beamer
    > MVP; MCP: +I, SE, SD, DBA
    > http://gregorybeamer.spaces.live.com
    > Co-author: Microsoft Expression Web Bible (upcoming)



    > "Juan T. Llibre" <> wrote in message news:...
    >> re:
    >> !> Yes, this is on a Win2003 Server.
    >> !> Yes, this machine is a domain controller.
    >>
    >> Bad idea.
    >>
    >> In general, it's not advisable to run your Web server on a domain controller, because a compromise of the machine is
    >> a compromise of the domain.
    >>
    >> But, if you *really* need to do that...
    >>
    >> re:
    >> !> There is no "userName" attribute in the Machine.config file in .net 2.x.
    >>
    >> Yes, there is.
    >>
    >> <processModel enable="true" userName="SYSTEM" password="AutoGenerate" />
    >>
    >> ...ought to cover it for you, if you *really* want to run ASP.NET
    >> as the SYSTEM account on a domain controller, although I would encrypt the section.
    >>
    >> Even better, I would NOT run ASP.NET as the System account. See below...
    >>
    >> re:
    >> !> The event log is filled with messages like:
    >>
    >> It's no wonder that is happening.
    >>
    >> re:
    >> !> How about software that simply works????
    >>
    >> If you deliberately run ASP.NET on a domain controller,
    >> something which is not recommended, don't blame Microsoft
    >> if you can't RTFM to implement the workaround.
    >>
    >> http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx
    >>
    >> Even better than using the System account would be specifying an explicit account.
    >>
    >> That works around the security problems which
    >> running ASP.NET on a domain controller exposes you to.
    >>
    >> To do that, follow the instructions in this article...
    >>
    >> How To: Create a Service Account for an ASP.NET 2.0 Application:
    >> http://msdn2.microsoft.com/en-us/library/ms998297.aspx
    >>
    >> Try it. It's really easy to do.
    >>
    >>
    >>
    >>
    >> Juan T. Llibre, asp.net MVP
    >> asp.net faq : http://asp.net.do/faq/
    >> foros de asp.net, en español : http://asp.net.do/foros/
    >> ======================================
    >> "Kevin Liebowicz" <> wrote in message news:...
    >> Yes, I wasted the past two days trying to fix this.
    >> Yes, this is on a Win2003 Server.
    >> Yes, this machine is a domain controller.
    >>
    >> Yes, I seen the dozens of KB articles like this one:
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >>
    >> But the problem is that 99% of these are for ASP .NET 1.x and this
    >> is .NET 2.x which I just installed to try and get .net working for the
    >> first time ever. I've see all the HACKS to get .net 1.x working... but
    >> this is for .net 2.x so these worthless KB articles do nothing for me.
    >>
    >> Example -
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >>
    >> RESOLUTION
    >> To work around this problem, use one of the following methods: ·
    >> Create a weak account that has the correct permissions, and then
    >> configure the <processModel> section of the Machine.config file to use
    >> that account.
    >> · Set the userName attribute to SYSTEM in the <processModel> section
    >> of the Machine.config file.
    >> · Configure the <processModel> section of the Machine.config file to
    >> use an administrator account.
    >>
    >>
    >> THIS IS USELESS !!!!! There is no "userName" attribute in the
    >> Machine.config file in .net 2.x. And if this is a known problem then
    >> why doesn't the installer warn me or fix it automatically. Sorry, but
    >> your software sucks lately.!!!!!!!
    >>
    >> The event log is filled with messages like:
    >>
    >> <quote>
    >> aspnet_wp.exe could not be started. The error code for the failure is
    >> 800700CB. This error can be caused when the worker process account has
    >> insufficient rights to read the .NET Framework files. Please ensure
    >> that the .NET Framework is correctly installed and that the ACLs on
    >> the installation directory allow access to the configured account.
    >> </quote>
    >>
    >>
    >> Sorry Microsoft - But you are getting WORSE and WORSE. How about
    >> software that simply works????
    >>
    >> It's no wonder that Linux is kicking your butt and I'm about 30
    >> seconds away from saying goodbye to your over-complicated bug ridden
    >> crap and making the transition to linux myself.
    Juan T. Llibre, Jul 3, 2007
    #8
  9. On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
    <> wrote:
    > Juan has given you the hangman's noose. Now I am going to inform you why
    > Juan told you not to do this.
    >
    > You can get it running on a domain controller by altering this account. The
    > problem is you now leave a big hole into your domain controller.
    >
    > Why is this a problem? Well, once someone has control of your domain
    > controller, they have control of your domain.
    >
    > And, why is that dangerous? Do you hold ANY secrets. You know, things like
    > customer's credit cards, you own employee's social security numbers?
    > Anything like that? Well, you have the potential of leaving it all open for
    > someone.


    Not at all. This domain controller is in the basement of my house
    where it sits behind a firewall. There is no external access to the
    network and the domain controller simply provides me with centralized
    management for my computers and those that my kids use. I run a web
    server on the same machine to serve mp3s, photos and videos.



    > Can this really happen? Well, the likelihood is fairly low. It is almost
    > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > server that happens to sit on a DC.


    Not a problem for me unless my wife plans on hacking into the server.
    Don't think that you and/or Microsoft understand every customer
    scenario because you don't.


    > Can you mitigate this. Certainly. Buy a web server.

    I don't need yet another machine. The one I currently have is more
    than capable.


    > Here is the bottom line. Is it less risky to tell the person forcing you to
    > do this to buy a web server or to have your customer's data stolen (and
    > perhaps your own) or to risk you job telling your boss

    There is no customer data. I don't need another computer. And there is
    no boss.

    > he needs to spend a
    > few thousand on a web server? If the later, then find a better job. And, if
    > it is you that is the boss deciding you need to risk your whole business
    > over a couple of thosand dollars, then I am wating my time.

    Yeah, yeah, yeah. Once again... one size does NOT fit all.

    > Don't put your web server on a DC ... EVER.

    EVER? Then do explain why my family intranet needs a 2nd machine to
    server web pages.

    > Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    Ignored because you believe that you understand my situation better
    than I do. You do not.


    > --
    > Gregory A. Beamer
    > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > Co-author: Microsoft Expression Web Bible (upcoming)
    >
    > ************************************************
    > Think outside the box!
    > ************************************************"Kevin Liebowicz" <> wrote in message
    >
    > news:...
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.
    >
    > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > But the problem is that 99% of these are for ASP .NET 1.x and this
    > is .NET 2.x which I just installed to try and get .net working for the
    > first time ever. I've see all the HACKS to get .net 1.x working... but
    > this is for .net 2.x so these worthless KB articles do nothing for me.
    >
    > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > RESOLUTION
    > To work around this problem, use one of the following methods: ·
    > Create a weak account that has the correct permissions, and then
    > configure the <processModel> section of the Machine.config file to use
    > that account.
    > · Set the userName attribute to SYSTEM in the <processModel> section
    > of the Machine.config file.
    > · Configure the <processModel> section of the Machine.config file to
    > use an administrator account.
    >
    > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > Machine.config file in .net 2.x. And if this is a known problem then
    > why doesn't the installer warn me or fix it automatically. Sorry, but
    > your software sucks lately.!!!!!!!
    >
    > The event log is filled with messages like:
    >
    > <quote>
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 800700CB. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the .NET Framework is correctly installed and that the ACLs on
    > the installation directory allow access to the configured account.
    > </quote>
    >
    > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > software that simply works????
    >
    > It's no wonder that Linux is kicking your butt and I'm about 30
    > seconds away from saying goodbye to your over-complicated bug ridden
    > crap and making the transition to linux myself.
    Kevin Liebowicz, Jul 3, 2007
    #9
  10. Kevin,

    in your case all you have to do is set up an ad-hoc service account,
    as indicated in the link I sent you :

    How To: Create a Service Account for an ASP.NET 2.0 Application:
    http://msdn2.microsoft.com/en-us/library/ms998297.aspx

    You really shouldn't run ASP.NET as the System account,
    just in case something goes wrong with the boxes' security



    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Kevin Liebowicz" <> wrote in message news:...
    On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
    <> wrote:
    > Juan has given you the hangman's noose. Now I am going to inform you why
    > Juan told you not to do this.
    >
    > You can get it running on a domain controller by altering this account. The
    > problem is you now leave a big hole into your domain controller.
    >
    > Why is this a problem? Well, once someone has control of your domain
    > controller, they have control of your domain.
    >
    > And, why is that dangerous? Do you hold ANY secrets. You know, things like
    > customer's credit cards, you own employee's social security numbers?
    > Anything like that? Well, you have the potential of leaving it all open for
    > someone.


    Not at all. This domain controller is in the basement of my house
    where it sits behind a firewall. There is no external access to the
    network and the domain controller simply provides me with centralized
    management for my computers and those that my kids use. I run a web
    server on the same machine to serve mp3s, photos and videos.



    > Can this really happen? Well, the likelihood is fairly low. It is almost
    > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > server that happens to sit on a DC.


    Not a problem for me unless my wife plans on hacking into the server.
    Don't think that you and/or Microsoft understand every customer
    scenario because you don't.


    > Can you mitigate this. Certainly. Buy a web server.

    I don't need yet another machine. The one I currently have is more
    than capable.


    > Here is the bottom line. Is it less risky to tell the person forcing you to
    > do this to buy a web server or to have your customer's data stolen (and
    > perhaps your own) or to risk you job telling your boss

    There is no customer data. I don't need another computer. And there is
    no boss.

    > he needs to spend a
    > few thousand on a web server? If the later, then find a better job. And, if
    > it is you that is the boss deciding you need to risk your whole business
    > over a couple of thosand dollars, then I am wating my time.

    Yeah, yeah, yeah. Once again... one size does NOT fit all.

    > Don't put your web server on a DC ... EVER.

    EVER? Then do explain why my family intranet needs a 2nd machine to
    server web pages.

    > Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    Ignored because you believe that you understand my situation better
    than I do. You do not.


    > --
    > Gregory A. Beamer
    > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > Co-author: Microsoft Expression Web Bible (upcoming)
    >
    > ************************************************
    > Think outside the box!
    > ************************************************"Kevin Liebowicz" <> wrote in message
    >
    > news:...
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.
    >
    > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > But the problem is that 99% of these are for ASP .NET 1.x and this
    > is .NET 2.x which I just installed to try and get .net working for the
    > first time ever. I've see all the HACKS to get .net 1.x working... but
    > this is for .net 2.x so these worthless KB articles do nothing for me.
    >
    > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > RESOLUTION
    > To work around this problem, use one of the following methods: ·
    > Create a weak account that has the correct permissions, and then
    > configure the <processModel> section of the Machine.config file to use
    > that account.
    > · Set the userName attribute to SYSTEM in the <processModel> section
    > of the Machine.config file.
    > · Configure the <processModel> section of the Machine.config file to
    > use an administrator account.
    >
    > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > Machine.config file in .net 2.x. And if this is a known problem then
    > why doesn't the installer warn me or fix it automatically. Sorry, but
    > your software sucks lately.!!!!!!!
    >
    > The event log is filled with messages like:
    >
    > <quote>
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 800700CB. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the .NET Framework is correctly installed and that the ACLs on
    > the installation directory allow access to the configured account.
    > </quote>
    >
    > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > software that simply works????
    >
    > It's no wonder that Linux is kicking your butt and I'm about 30
    > seconds away from saying goodbye to your over-complicated bug ridden
    > crap and making the transition to linux myself.
    Juan T. Llibre, Jul 3, 2007
    #10
  11. On Jul 2, 10:05 pm, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> Yes, this is on a Win2003 Server.
    > !> Yes, this machine is a domain controller.


    First of all thank you for the help. And I do mean it.


    > Bad idea.

    Let me be the judge of that.


    > In general, it's not advisable to run your Web server on a domain controller,
    > because a compromise of the machine is a compromise of the domain.

    Funny because when I first installed Win2003 server it had no
    problems, complaints or warnings installing IIS for me. I've been
    using IIS to serve web-pages for several years now without a single
    problem. It seems that things only "half-work" because .ASP pages get
    served but I need to screw around and tweak the daylights out of the
    machine to get the other half (.ASPX) pages working.

    > But, if you *really* need to do that...

    I *really* do need to do that.

    > re:
    > !> There is no "userName" attribute in the Machine.config file in .net 2.x.
    >
    > Yes, there is.
    >
    > <processModel enable="true" userName="SYSTEM" password="AutoGenerate" />


    Not on my machine there isn't.
    bubba:CONFIG>pwd
    /cygdrive/c/WINNT/Microsoft.NET/Framework/v2.0.50727/CONFIG
    bubba:CONFIG>grep -i username machine.config
    bubba:CONFIG>


    C:\WINNT\Microsoft.NET\Framework\v2.0.50727\CONFIG\machine.config

    <system.web>
    <processModel autoConfig="true"/>
    <httpHandlers />

    <membership>
    <providers>
    *** snip ***
    </providers>
    </membership>



    > ...ought to cover it for you, if you *really* want to run ASP.NET
    > as the SYSTEM account on a domain controller, although I would encrypt the section.


    I just want the damn thing to work. IIS is able to run and server ASP
    pages for several years now. Why is it that ASPX is completely borked?
    And NO... this is not some "feature" where Microsoft is protecting me
    from myself. It's simply hosed.

    > Even better, I would NOT run ASP.NET as the System account. See below...

    I believe that IIS normally serves ASP pages under an account named
    IUSR_<machine-name> - Why can't ASPX pages run under the same account?
    Nah... that would be too easy.



    > re:
    > !> The event log is filled with messages like:
    >
    > It's no wonder that is happening.
    >
    > re:
    > !> How about software that simply works????
    >
    > If you deliberately run ASP.NET on a domain controller,
    > something which is not recommended, don't blame Microsoft
    > if you can't RTFM to implement the workaround.


    What do you mean RTFM??? There is NO "Manual" to read, no USEFUL error
    messages. Searching the web proves this problem has been around
    since .net 1.0 and it still doesn't work right.


    > http://msdn2.microsoft.com/en-us/library/7w2sway1.aspx


    Excellent. (And thanks). What's the magic search words that one must
    use in order to search and find this link.


    > Even better than using the System account would be specifing an explicit account.
    >
    > That works around the security problems which
    > running ASP.NET on a domain controller exposes you to.
    >
    > To do that, follow the instructions in this article...
    >
    > How To: Create a Service Account for an ASP.NET 2.0 Application:http://msdn2.microsoft.com/en-us/library/ms998297.aspx
    >
    > Try it. It's really easy to do.


    I'm sure it is... once the server finishes printing all 6 pages of
    these "easy" instructions.


    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Kevin Liebowicz" <> wrote in messagenews:...
    >
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.
    >
    > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > But the problem is that 99% of these are for ASP .NET 1.x and this
    > is .NET 2.x which I just installed to try and get .net working for the
    > first time ever. I've see all the HACKS to get .net 1.x working... but
    > this is for .net 2.x so these worthless KB articles do nothing for me.
    >
    > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158
    >
    > RESOLUTION
    > To work around this problem, use one of the following methods: ·
    > Create a weak account that has the correct permissions, and then
    > configure the <processModel> section of the Machine.config file to use
    > that account.
    > · Set the userName attribute to SYSTEM in the <processModel> section
    > of the Machine.config file.
    > · Configure the <processModel> section of the Machine.config file to
    > use an administrator account.
    >
    > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > Machine.config file in .net 2.x. And if this is a known problem then
    > why doesn't the installer warn me or fix it automatically. Sorry, but
    > your software sucks lately.!!!!!!!
    >
    > The event log is filled with messages like:
    >
    > <quote>
    > aspnet_wp.exe could not be started. The error code for the failure is
    > 800700CB. This error can be caused when the worker process account has
    > insufficient rights to read the .NET Framework files. Please ensure
    > that the .NET Framework is correctly installed and that the ACLs on
    > the installation directory allow access to the configured account.
    > </quote>
    >
    > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > software that simply works????
    >
    > It's no wonder that Linux is kicking your butt and I'm about 30
    > seconds away from saying goodbye to your over-complicated bug ridden
    > crap and making the transition to linux myself.
    Kevin Liebowicz, Jul 3, 2007
    #11
  12. On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    > Kevin,
    >
    > in your case all you have to do is set up an ad-hoc service account,
    > as indicated in the link I sent you :
    >
    > How To: Create a Service Account for an ASP.NET 2.0 Application:http://msdn2.microsoft.com/en-us/library/ms998297.aspx


    Except that it still does not work.

    I followed the directions -

    #1 - I created a new account (in the User group) named
    aspxuseraccount.
    [Works]

    #2 - Assign ASP.NET permissions to the new account
    (FAMILY is the domain name since it's the home/family domain
    controller)

    C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -ga
    FAMILY\aspxuseraccount

    Start granting FAMILY\aspxuseraccount access to the IIS metabase and
    other directories used by ASP.NET.
    Finished granting FAMILY\aspxuseraccount access to the IIS metabase
    and other directories used by ASP.NET.
    [Works]


    #3 - Create a Test ASP.NET Application
    WRONG! This is a server that sits in the basement. I don't have visual
    studio .net installed on this machine nor do I intend on buying it
    just to "enable" my machine to serve a simple .aspx page.

    So I create a small file named Default.aspx and I paste the text from
    the article into it. Without VS.net I can't compile or run the app but
    I ought to at least be able to serve this page. Nope... still can't do
    that:

    http://bubba/default.aspx

    <quote>
    Server Application Unavailable
    The web application you are attempting to access on this web server is
    currently unavailable. Please hit the "Refresh" button in your web
    browser to retry your request.

    Administrator Note: An error message detailing the cause of this
    specific request failure can be found in the application event log of
    the web server. Please review this log entry to discover what caused
    this error to occur.
    </quote>



    > You really shouldn't run ASP.NET as the System account,
    > just in case something goes wrong with the boxes' security
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Kevin Liebowicz" <> wrote in messagenews:...
    >
    > On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
    >
    > <> wrote:
    > > Juan has given you the hangman's noose. Now I am going to inform you why
    > > Juan told you not to do this.

    >
    > > You can get it running on a domain controller by altering this account. The
    > > problem is you now leave a big hole into your domain controller.

    >
    > > Why is this a problem? Well, once someone has control of your domain
    > > controller, they have control of your domain.

    >
    > > And, why is that dangerous? Do you hold ANY secrets. You know, things like
    > > customer's credit cards, you own employee's social security numbers?
    > > Anything like that? Well, you have the potential of leaving it all open for
    > > someone.

    >
    > Not at all. This domain controller is in the basement of my house
    > where it sits behind a firewall. There is no external access to the
    > network and the domain controller simply provides me with centralized
    > management for my computers and those that my kids use. I run a web
    > server on the same machine to serve mp3s, photos and videos.
    >
    > > Can this really happen? Well, the likelihood is fairly low. It is almost
    > > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > > server that happens to sit on a DC.

    >
    > Not a problem for me unless my wife plans on hacking into the server.
    > Don't think that you and/or Microsoft understand every customer
    > scenario because you don't.
    >
    > > Can you mitigate this. Certainly. Buy a web server.

    >
    > I don't need yet another machine. The one I currently have is more
    > than capable.
    >
    > > Here is the bottom line. Is it less risky to tell the person forcing you to
    > > do this to buy a web server or to have your customer's data stolen (and
    > > perhaps your own) or to risk you job telling your boss

    >
    > There is no customer data. I don't need another computer. And there is
    > no boss.
    >
    > > he needs to spend a
    > > few thousand on a web server? If the later, then find a better job. And, if
    > > it is you that is the boss deciding you need to risk your whole business
    > > over a couple of thosand dollars, then I am wating my time.

    >
    > Yeah, yeah, yeah. Once again... one size does NOT fit all.
    >
    > > Don't put your web server on a DC ... EVER.

    >
    > EVER? Then do explain why my family intranet needs a 2nd machine to
    > server web pages.
    >
    > > Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    >
    > Ignored because you believe that you understand my situation better
    > than I do. You do not.
    >
    >
    >
    > > --
    > > Gregory A. Beamer
    > > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > > Co-author: Microsoft Expression Web Bible (upcoming)

    >
    > > ************************************************
    > > Think outside the box!
    > > ************************************************"Kevin Liebowicz" <> wrote in message

    >
    > >news:...
    > > Yes, I wasted the past two days trying to fix this.
    > > Yes, this is on a Win2003 Server.
    > > Yes, this machine is a domain controller.

    >
    > > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > But the problem is that 99% of these are for ASP .NET 1.x and this
    > > is .NET 2.x which I just installed to try and get .net working for the
    > > first time ever. I've see all the HACKS to get .net 1.x working... but
    > > this is for .net 2.x so these worthless KB articles do nothing for me.

    >
    > > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > RESOLUTION
    > > To work around this problem, use one of the following methods: ·
    > > Create a weak account that has the correct permissions, and then
    > > configure the <processModel> section of the Machine.config file to use
    > > that account.
    > > · Set the userName attribute to SYSTEM in the <processModel> section
    > > of the Machine.config file.
    > > · Configure the <processModel> section of the Machine.config file to
    > > use an administrator account.

    >
    > > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > > Machine.config file in .net 2.x. And if this is a known problem then
    > > why doesn't the installer warn me or fix it automatically. Sorry, but
    > > your software sucks lately.!!!!!!!

    >
    > > The event log is filled with messages like:

    >
    > > <quote>
    > > aspnet_wp.exe could not be started. The error code for the failure is
    > > 800700CB. This error can be caused when the worker process account has
    > > insufficient rights to read the .NET Framework files. Please ensure
    > > that the .NET Framework is correctly installed and that the ACLs on
    > > the installation directory allow access to the configured account.
    > > </quote>

    >
    > > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > > software that simply works????

    >
    > > It's no wonder that Linux is kicking your butt and I'm about 30
    > > seconds away from saying goodbye to your over-complicated bug ridden
    > > crap and making the transition to linux myself.- Hide quoted text -

    >
    > - Show quoted text -
    Kevin Liebowicz, Jul 3, 2007
    #12
  13. re:
    !> Server Application Unavailable
    !> The web application you are attempting to access on this web server is currently unavailable.

    In Windows 2003, you have to specifically enable ASP.NET.
    The default, for security reasons, is that ASP.NET is not enabled.

    Open the IIS Manager, scroll on the left to "Web Service Extensions", then select
    the ASP.NET version you want to allow on the right pane, and click the "Allow" button.

    You can also run:

    aspnet_regiis -enable

    Both procedures do the same thing : enable ASP.NET to run on W2K3.




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Kevin Liebowicz" <> wrote in message news:...
    On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    > Kevin,
    >
    > in your case all you have to do is set up an ad-hoc service account,
    > as indicated in the link I sent you :
    >
    > How To: Create a Service Account for an ASP.NET 2.0 Application:

    http://msdn2.microsoft.com/en-us/library/ms998297.aspx

    Except that it still does not work.

    I followed the directions -

    #1 - I created a new account (in the User group) named
    aspxuseraccount.
    [Works]

    #2 - Assign ASP.NET permissions to the new account
    (FAMILY is the domain name since it's the home/family domain
    controller)

    C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -ga
    FAMILY\aspxuseraccount

    Start granting FAMILY\aspxuseraccount access to the IIS metabase and
    other directories used by ASP.NET.
    Finished granting FAMILY\aspxuseraccount access to the IIS metabase
    and other directories used by ASP.NET.
    [Works]


    #3 - Create a Test ASP.NET Application
    WRONG! This is a server that sits in the basement. I don't have visual
    studio .net installed on this machine nor do I intend on buying it
    just to "enable" my machine to serve a simple .aspx page.

    So I create a small file named Default.aspx and I paste the text from
    the article into it. Without VS.net I can't compile or run the app but
    I ought to at least be able to serve this page. Nope... still can't do
    that:

    http://bubba/default.aspx

    <quote>
    Server Application Unavailable
    The web application you are attempting to access on this web server is
    currently unavailable. Please hit the "Refresh" button in your web
    browser to retry your request.

    Administrator Note: An error message detailing the cause of this
    specific request failure can be found in the application event log of
    the web server. Please review this log entry to discover what caused
    this error to occur.
    </quote>
    Juan T. Llibre, Jul 3, 2007
    #13
  14. Three more things...

    1. Did you setup the root site to run against ASP.NET 2.0 ?

    http://bubba/default.aspx will need to run using the .Net Framework 2.0

    Open the IIS Manager and, in the properties for the "Default Web Site"
    ( right-click it and select "Properties" ), select the ASP.NET tab,
    and make sure that 2.0.50727 is selected... )

    2. Did you create the Application Pool for ASP.NET 2.0 ?
    ( as detailed in the same article : http://msdn2.microsoft.com/en-us/library/ms998297.aspx )

    3. Make sure the root application is running in the Application Pool you just created.
    ( Again...in the Default Web Sites' properties in the IIS Manager )




    Juan T. Llibre, asp.net MVP
    asp.net faq : http://asp.net.do/faq/
    foros de asp.net, en español : http://asp.net.do/foros/
    ======================================
    "Kevin Liebowicz" <> wrote in message news:...
    On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    > Kevin,
    >
    > in your case all you have to do is set up an ad-hoc service account,
    > as indicated in the link I sent you :
    >
    > How To: Create a Service Account for an ASP.NET 2.0 Application:
    > http://msdn2.microsoft.com/en-us/library/ms998297.aspx


    Except that it still does not work.

    I followed the directions -

    #1 - I created a new account (in the User group) named
    aspxuseraccount.
    [Works]

    #2 - Assign ASP.NET permissions to the new account
    (FAMILY is the domain name since it's the home/family domain
    controller)

    C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -ga
    FAMILY\aspxuseraccount

    Start granting FAMILY\aspxuseraccount access to the IIS metabase and
    other directories used by ASP.NET.
    Finished granting FAMILY\aspxuseraccount access to the IIS metabase
    and other directories used by ASP.NET.
    [Works]


    #3 - Create a Test ASP.NET Application
    WRONG! This is a server that sits in the basement. I don't have visual
    studio .net installed on this machine nor do I intend on buying it
    just to "enable" my machine to serve a simple .aspx page.

    So I create a small file named Default.aspx and I paste the text from
    the article into it. Without VS.net I can't compile or run the app but
    I ought to at least be able to serve this page. Nope... still can't do
    that:

    http://bubba/default.aspx

    <quote>
    Server Application Unavailable
    The web application you are attempting to access on this web server is
    currently unavailable. Please hit the "Refresh" button in your web
    browser to retry your request.

    Administrator Note: An error message detailing the cause of this
    specific request failure can be found in the application event log of
    the web server. Please review this log entry to discover what caused
    this error to occur.
    </quote>



    > You really shouldn't run ASP.NET as the System account,
    > just in case something goes wrong with the boxes' security
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Kevin Liebowicz" <> wrote in
    > messagenews:...
    >
    > On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
    >
    > <> wrote:
    > > Juan has given you the hangman's noose. Now I am going to inform you why
    > > Juan told you not to do this.

    >
    > > You can get it running on a domain controller by altering this account. The
    > > problem is you now leave a big hole into your domain controller.

    >
    > > Why is this a problem? Well, once someone has control of your domain
    > > controller, they have control of your domain.

    >
    > > And, why is that dangerous? Do you hold ANY secrets. You know, things like
    > > customer's credit cards, you own employee's social security numbers?
    > > Anything like that? Well, you have the potential of leaving it all open for
    > > someone.

    >
    > Not at all. This domain controller is in the basement of my house
    > where it sits behind a firewall. There is no external access to the
    > network and the domain controller simply provides me with centralized
    > management for my computers and those that my kids use. I run a web
    > server on the same machine to serve mp3s, photos and videos.
    >
    > > Can this really happen? Well, the likelihood is fairly low. It is almost
    > > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > > server that happens to sit on a DC.

    >
    > Not a problem for me unless my wife plans on hacking into the server.
    > Don't think that you and/or Microsoft understand every customer
    > scenario because you don't.
    >
    > > Can you mitigate this. Certainly. Buy a web server.

    >
    > I don't need yet another machine. The one I currently have is more
    > than capable.
    >
    > > Here is the bottom line. Is it less risky to tell the person forcing you to
    > > do this to buy a web server or to have your customer's data stolen (and
    > > perhaps your own) or to risk you job telling your boss

    >
    > There is no customer data. I don't need another computer. And there is
    > no boss.
    >
    > > he needs to spend a
    > > few thousand on a web server? If the later, then find a better job. And, if
    > > it is you that is the boss deciding you need to risk your whole business
    > > over a couple of thosand dollars, then I am wating my time.

    >
    > Yeah, yeah, yeah. Once again... one size does NOT fit all.
    >
    > > Don't put your web server on a DC ... EVER.

    >
    > EVER? Then do explain why my family intranet needs a 2nd machine to
    > server web pages.
    >
    > > Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    >
    > Ignored because you believe that you understand my situation better
    > than I do. You do not.
    >
    >
    >
    > > --
    > > Gregory A. Beamer
    > > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > > Co-author: Microsoft Expression Web Bible (upcoming)

    >
    > > ************************************************
    > > Think outside the box!
    > > ************************************************"Kevin Liebowicz" <> wrote in message

    >
    > >news:...
    > > Yes, I wasted the past two days trying to fix this.
    > > Yes, this is on a Win2003 Server.
    > > Yes, this machine is a domain controller.

    >
    > > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > But the problem is that 99% of these are for ASP .NET 1.x and this
    > > is .NET 2.x which I just installed to try and get .net working for the
    > > first time ever. I've see all the HACKS to get .net 1.x working... but
    > > this is for .net 2.x so these worthless KB articles do nothing for me.

    >
    > > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > RESOLUTION
    > > To work around this problem, use one of the following methods: ·
    > > Create a weak account that has the correct permissions, and then
    > > configure the <processModel> section of the Machine.config file to use
    > > that account.
    > > · Set the userName attribute to SYSTEM in the <processModel> section
    > > of the Machine.config file.
    > > · Configure the <processModel> section of the Machine.config file to
    > > use an administrator account.

    >
    > > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > > Machine.config file in .net 2.x. And if this is a known problem then
    > > why doesn't the installer warn me or fix it automatically. Sorry, but
    > > your software sucks lately.!!!!!!!

    >
    > > The event log is filled with messages like:

    >
    > > <quote>
    > > aspnet_wp.exe could not be started. The error code for the failure is
    > > 800700CB. This error can be caused when the worker process account has
    > > insufficient rights to read the .NET Framework files. Please ensure
    > > that the .NET Framework is correctly installed and that the ACLs on
    > > the installation directory allow access to the configured account.
    > > </quote>

    >
    > > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > > software that simply works????

    >
    > > It's no wonder that Linux is kicking your butt and I'm about 30
    > > seconds away from saying goodbye to your over-complicated bug ridden
    > > crap and making the transition to linux myself.- Hide quoted text -

    >
    > - Show quoted text -
    Juan T. Llibre, Jul 3, 2007
    #14
  15. On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    > Kevin,
    >
    > in your case all you have to do is set up an ad-hoc service account,
    > as indicated in the link I sent you :
    >
    > How To: Create a Service Account for an ASP.NET 2.0 Application:http://msdn2.microsoft.com/en-us/library/ms998297.aspx




    And by the way... other than step #3 not working (because it seems
    that one needs to buy a $800 compiler in order to convince a licensed
    Win2003 server to serve one simple .aspx page) the other steps are not
    even close to working...

    <quote>
    Step 4. Create an Application Pool with a Custom Identity
    To create an application pool that runs using a custom service
    account

    Start Internet Information Services (IIS) Manager.
    In the left pane, expand the local computer and then expand
    Application Pools.
    </quote>

    I would but there is not "Application Pools" underneath the local
    computer or anywhere else in IIS Manager.


    <quote>
    Step 5. Configure Your Application to Run in the New Application Pool

    In this step, you configure your test ASP.NET application to run in
    the new application pool. This ensures that it runs using the custom
    service account identity.
    </quote>

    Except that there is NO application pool.


    WHY IS THIS SO COMPLICATED????? The normal IIS/ASP combination works
    fine. Buy Microsoft really screwed the pooch on this .aspx/.net
    blunder. It ought to just work "out of the box." When I installed 2003
    Server it I selected to install IIS. It ought to "just work" and
    people should NOT have to create custom accounts, run scripts,
    configure custom pools, buy VS.net and sacrifice goats to the gods in
    order for this to work.

    This is not rocket science - it's one simple web page. I have WASTED
    sooooo much time just trying to get this junk to work. And I'm no
    closer today then I was this weekend when I started and who the hell
    knows what sort of state my server is now after installing various
    junk and running all sorts of incarnations of aspnet_xxxxx.exe apps.

    Note to Microsoft - Unlike Vista and this debacle... try shipping
    software that SIMPLY WORKS. Ever hear of KISS - Keep It Simple
    Stupid????? This is way, way, way more complicated than it needs to
    be or ought to be.

    Sorry for the rant but I am sick and tired of spending the last 3-4
    days trying to get my web server to serve one simple .aspx page. What
    sort of idiot would create a product that is so damn complicated that
    it requires all of these ridiculous fixes, hacks and work arounds in
    order to run.



    > You really shouldn't run ASP.NET as the System account,
    > just in case something goes wrong with the boxes' security
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Kevin Liebowicz" <> wrote in messagenews:...
    >
    > On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
    >
    > <> wrote:
    > > Juan has given you the hangman's noose. Now I am going to inform you why
    > > Juan told you not to do this.

    >
    > > You can get it running on a domain controller by altering this account. The
    > > problem is you now leave a big hole into your domain controller.

    >
    > > Why is this a problem? Well, once someone has control of your domain
    > > controller, they have control of your domain.

    >
    > > And, why is that dangerous? Do you hold ANY secrets. You know, things like
    > > customer's credit cards, you own employee's social security numbers?
    > > Anything like that? Well, you have the potential of leaving it all open for
    > > someone.

    >
    > Not at all. This domain controller is in the basement of my house
    > where it sits behind a firewall. There is no external access to the
    > network and the domain controller simply provides me with centralized
    > management for my computers and those that my kids use. I run a web
    > server on the same machine to serve mp3s, photos and videos.
    >
    > > Can this really happen? Well, the likelihood is fairly low. It is almost
    > > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > > server that happens to sit on a DC.

    >
    > Not a problem for me unless my wife plans on hacking into the server.
    > Don't think that you and/or Microsoft understand every customer
    > scenario because you don't.
    >
    > > Can you mitigate this. Certainly. Buy a web server.

    >
    > I don't need yet another machine. The one I currently have is more
    > than capable.
    >
    > > Here is the bottom line. Is it less risky to tell the person forcing you to
    > > do this to buy a web server or to have your customer's data stolen (and
    > > perhaps your own) or to risk you job telling your boss

    >
    > There is no customer data. I don't need another computer. And there is
    > no boss.
    >
    > > he needs to spend a
    > > few thousand on a web server? If the later, then find a better job. And, if
    > > it is you that is the boss deciding you need to risk your whole business
    > > over a couple of thosand dollars, then I am wating my time.

    >
    > Yeah, yeah, yeah. Once again... one size does NOT fit all.
    >
    > > Don't put your web server on a DC ... EVER.

    >
    > EVER? Then do explain why my family intranet needs a 2nd machine to
    > server web pages.
    >
    > > Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    >
    > Ignored because you believe that you understand my situation better
    > than I do. You do not.
    >
    >
    >
    > > --
    > > Gregory A. Beamer
    > > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > > Co-author: Microsoft Expression Web Bible (upcoming)

    >
    > > ************************************************
    > > Think outside the box!
    > > ************************************************"Kevin Liebowicz" <> wrote in message

    >
    > >news:...
    > > Yes, I wasted the past two days trying to fix this.
    > > Yes, this is on a Win2003 Server.
    > > Yes, this machine is a domain controller.

    >
    > > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > But the problem is that 99% of these are for ASP .NET 1.x and this
    > > is .NET 2.x which I just installed to try and get .net working for the
    > > first time ever. I've see all the HACKS to get .net 1.x working... but
    > > this is for .net 2.x so these worthless KB articles do nothing for me.

    >
    > > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > RESOLUTION
    > > To work around this problem, use one of the following methods: ·
    > > Create a weak account that has the correct permissions, and then
    > > configure the <processModel> section of the Machine.config file to use
    > > that account.
    > > · Set the userName attribute to SYSTEM in the <processModel> section
    > > of the Machine.config file.
    > > · Configure the <processModel> section of the Machine.config file to
    > > use an administrator account.

    >
    > > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > > Machine.config file in .net 2.x. And if this is a known problem then
    > > why doesn't the installer warn me or fix it automatically. Sorry, but
    > > your software sucks lately.!!!!!!!

    >
    > > The event log is filled with messages like:

    >
    > > <quote>
    > > aspnet_wp.exe could not be started. The error code for the failure is
    > > 800700CB. This error can be caused when the worker process account has
    > > insufficient rights to read the .NET Framework files. Please ensure
    > > that the .NET Framework is correctly installed and that the ACLs on
    > > the installation directory allow access to the configured account.
    > > </quote>

    >
    > > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > > software that simply works????

    >
    > > It's no wonder that Linux is kicking your butt and I'm about 30
    > > seconds away from saying goodbye to your over-complicated bug ridden
    > > crap and making the transition to linux myself.- Hide quoted text -

    >
    > - Show quoted text -
    Kevin Liebowicz, Jul 3, 2007
    #15
  16. On Jul 3, 10:40 am, "Juan T. Llibre" <>
    wrote:
    > re:
    > !> Server Application Unavailable
    > !> The web application you are attempting to access on this web server is currently unavailable.
    >
    > In Windows 2003, you have to specifically enable ASP.NET.
    > The default, for security reasons, is that ASP.NET is not enabled.
    >
    > Open the IIS Manager, scroll on the left to "Web Service Extensions", then select
    > the ASP.NET version you want to allow on the right pane, and click the "Allow" button.



    Yes - I did this yesterday.



    > You can also run:
    >
    > aspnet_regiis -enable
    >
    > Both procedures do the same thing : enable ASP.NET to run on W2K3.


    I did this too. I didn't realize they did the same thing.
    Kevin Liebowicz, Jul 3, 2007
    #16
  17. On Jul 3, 10:45 am, "Juan T. Llibre" <>
    wrote:
    > Three more things...
    >
    > 1. Did you setup the root site to run against ASP.NET 2.0 ?
    >
    > http://bubba/default.aspxwill need to run using the .Net Framework 2.0
    >
    > Open the IIS Manager and, in the properties for the "Default Web Site"
    > ( right-click it and select "Properties" ), select the ASP.NET tab,
    > and make sure that 2.0.50727 is selected... )


    It is selected and it is the only option that's available.

    On this tab there's an entry for "File location" which is c:\inetpub
    \wwwroot\web.config. - There is no such file. Should there be? Where
    does this file come from?

    Since there is no web.config file both entries for "File creation
    date" and "File last mod" read "Date not available."

    But if I go up one level (Web Sites - which is at the same level as
    FTP Sites) and I go to the same dialog tab it has this which does
    exist:

    C:\WINNT\Microsoft.NET\Framework\v2.0.50727\config\web.config




    > 2. Did you create the Application Pool for ASP.NET 2.0 ?
    > ( as detailed in the same article :http://msdn2.microsoft.com/en-us/library/ms998297.aspx)


    NO - Because the instructions say to expand the "Application Pools"
    item in IIS manager. This does NOT exist on my computer. Without
    Application Pools there's simply nothing to configure.


    > 3. Make sure the root application is running in the Application Pool you just created.
    > ( Again...in the Default Web Sites' properties in the IIS Manager )


    My configuration doesn't have any Application Pools. And I have no
    idea where I would set this if I did have an application pool. I right
    click on the web-site and select properties. But I don't see anything
    anywhere that lets me select an application pool. What tab is this on?



    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Kevin Liebowicz" <> wrote in messagenews:...
    >
    > On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    >
    > > Kevin,

    >
    > > in your case all you have to do is set up an ad-hoc service account,
    > > as indicated in the link I sent you :

    >
    > > How To: Create a Service Account for an ASP.NET 2.0 Application:
    > >http://msdn2.microsoft.com/en-us/library/ms998297.aspx

    >
    > Except that it still does not work.
    >
    > I followed the directions -
    >
    > #1 - I created a new account (in the User group) named
    > aspxuseraccount.
    > [Works]
    >
    > #2 - Assign ASP.NET permissions to the new account
    > (FAMILY is the domain name since it's the home/family domain
    > controller)
    >
    > C:\WINNT\Microsoft.NET\Framework\v2.0.50727>aspnet_regiis.exe -ga
    > FAMILY\aspxuseraccount
    >
    > Start granting FAMILY\aspxuseraccount access to the IIS metabase and
    > other directories used by ASP.NET.
    > Finished granting FAMILY\aspxuseraccount access to the IIS metabase
    > and other directories used by ASP.NET.
    > [Works]
    >
    > #3 - Create a Test ASP.NET Application
    > WRONG! This is a server that sits in the basement. I don't have visual
    > studio .net installed on this machine nor do I intend on buying it
    > just to "enable" my machine to serve a simple .aspx page.
    >
    > So I create a small file named Default.aspx and I paste the text from
    > the article into it. Without VS.net I can't compile or run the app but
    > I ought to at least be able to serve this page. Nope... still can't do
    > that:
    >
    > http://bubba/default.aspx
    >
    > <quote>
    > Server Application Unavailable
    > The web application you are attempting to access on this web server is
    > currently unavailable. Please hit the "Refresh" button in your web
    > browser to retry your request.
    >
    > Administrator Note: An error message detailing the cause of this
    > specific request failure can be found in the application event log of
    > the web server. Please review this log entry to discover what caused
    > this error to occur.
    > </quote>
    >
    >
    >
    > > You really shouldn't run ASP.NET as the System account,
    > > just in case something goes wrong with the boxes' security

    >
    > > Juan T. Llibre, asp.net MVP
    > > asp.net faq :http://asp.net.do/faq/
    > > foros de asp.net, en español :http://asp.net.do/foros/
    > > ======================================"Kevin Liebowicz" <> wrote in
    > > messagenews:...

    >
    > > On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"

    >
    > > <> wrote:
    > > > Juan has given you the hangman's noose. Now I am going to inform you why
    > > > Juan told you not to do this.

    >
    > > > You can get it running on a domain controller by altering this account. The
    > > > problem is you now leave a big hole into your domain controller.

    >
    > > > Why is this a problem? Well, once someone has control of your domain
    > > > controller, they have control of your domain.

    >
    > > > And, why is that dangerous? Do you hold ANY secrets. You know, things like
    > > > customer's credit cards, you own employee's social security numbers?
    > > > Anything like that? Well, you have the potential of leaving it all open for
    > > > someone.

    >
    > > Not at all. This domain controller is in the basement of my house
    > > where it sits behind a firewall. There is no external access to the
    > > network and the domain controller simply provides me with centralized
    > > management for my computers and those that my kids use. I run a web
    > > server on the same machine to serve mp3s, photos and videos.

    >
    > > > Can this really happen? Well, the likelihood is fairly low. It is almost
    > > > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > > > server that happens to sit on a DC.

    >
    > > Not a problem for me unless my wife plans on hacking into the server.
    > > Don't think that you and/or Microsoft understand every customer
    > > scenario because you don't.

    >
    > > > Can you mitigate this. Certainly. Buy a web server.

    >
    > > I don't need yet another machine. The one I currently have is more
    > > than capable.

    >
    > > > Here is the bottom line. Is it less risky to tell the person forcing you to
    > > > do this to buy a web server or to have your customer's data stolen (and
    > > > perhaps your own) or to risk you job telling your boss

    >
    > > There is no customer data. I don't need another computer. And there is
    > > no boss.

    >
    > > > he needs to spend a
    > > > few thousand on a web server? If the later, then find a better job. And, if
    > > > it is you that is the boss deciding you need to risk your whole business
    > > > over a couple of thosand dollars, then I am wating my time.

    >
    > > Yeah, yeah, yeah. Once again... one size does NOT fit all.

    >
    > > > Don't put your web server on a DC ... EVER.

    >
    > > EVER? Then do explain why my family intranet needs a 2nd machine to
    > > server web pages.

    >
    > > > Nuff said. If you ignore this, you can take Juan's "fix" and hang yourself.

    >
    > > Ignored because you believe that you understand my situation better
    > > than I do. You do not.

    >
    > > > --
    > > > Gregory A. Beamer
    > > > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > > > Co-author: Microsoft Expression Web Bible (upcoming)

    >
    > > > ************************************************
    > > > Think outside the box!
    > > > ************************************************"Kevin Liebowicz" <> wrote in message

    >
    > > >news:...
    > > > Yes, I wasted the past two days trying to fix this.
    > > > Yes, this is on a Win2003 Server.
    > > > Yes, this machine is a domain controller.

    >
    > > > Yes, I seen the dozens of KB articles like this one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > > But the problem is that 99% of these are for ASP .NET 1.x and this
    > > > is .NET 2.x which I just installed to try and get .net working for the
    > > > first time ever. I've see all the HACKS to get .net 1.x working... but
    > > > this is for .net 2.x so these worthless KB articles do nothing for me.

    >
    > > > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > > RESOLUTION
    > > > To work around this problem, use one of the following methods: ·
    > > > Create a weak account that has the correct permissions, and then
    > > > configure the <processModel> section of the Machine.config file to use
    > > > that account.
    > > > · Set the userName attribute to SYSTEM in the <processModel> section
    > > > of the Machine.config file.
    > > > · Configure the <processModel> section of the Machine.config file to
    > > > use an administrator account.

    >
    > > > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > > > Machine.config file in .net 2.x. And if this is a known problem then
    > > > why doesn't the installer warn me or fix it automatically. Sorry, but
    > > > your software sucks lately.!!!!!!!

    >
    > > > The event log is filled with messages like:

    >
    > > > <quote>
    > > > aspnet_wp.exe could not be started. The error code for the failure is
    > > > 800700CB. This error can be caused when the worker process account has
    > > > insufficient rights to read the .NET Framework files. Please ensure
    > > > that the .NET Framework is correctly installed and that the ACLs on
    > > > the installation directory allow access to the configured account.
    > > > </quote>

    >
    > > > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > > > software that simply works????

    >
    > > > It's no wonder that Linux is kicking your butt and I'm about 30
    > > > seconds away from saying goodbye to your over-complicated bug ridden
    > > > crap and making the transition to linux myself.- Hide quoted text -

    >
    > > - Show quoted text -- Hide quoted text -

    >
    > - Show quoted text -
    Kevin Liebowicz, Jul 3, 2007
    #17
  18. "Juan T. Llibre" <> wrote in message
    news:...
    > re:
    > !> I would but there is not "Application Pools" underneath the local
    > !> computer or anywhere else in IIS Manager.
    >
    > Did you install, at least, the Web or Standard versions of Windows Server 2003 ?


    As far as I know it's the "Standard" version of 2003 server. The
    system properties reports "Windows Server 2003. Standard Edition.
    Version 5.2 Build 3790.srv03_sp2_gdr.070304-2240: Service Pack 2"



    > You should be seeing what is in the attached image
    > ( with your own computer's name on it, of course ).
    >
    > Do you see anything similar ?



    It's similar but not the same. I'm posting through Google groups so I
    can't attach a screen shot but here's a description of how mine looks.

    Top level - Internet Information Services... just like your screen
    shot.
    Next level - BUBBA (local computer)... just like yours but with my
    computer name.
    Below BUBBA (local computer) I have "FTP Sites" with a small red "X"
    because the FTP server isn't running.
    Followed by a folder for "Web Sites"... just like your screen shot.
    Followed by a folder for "Web Service Extensions"... just like your
    screen shot.

    I do NOT have a folder for "Application Pools" or a folder for
    "Default SMTP Virtual Server" - I don't ever recall seeing these
    folders.


    > re:
    > !> It ought to just work "out of the box."
    >
    > It normally does, except when you choose to install IIS on a domain controller.


    Why would this matter?? It's a server and it ought to be able to do
    more than one thing at a time. It's a completely artificial limitation
    not to be able to run a web server and a Active Directory on the same
    machine. Because I want a small web-site in my house shouldn't force
    me to buy another computer. This one is already sitting idle 99.99% of
    the time.


    > re:
    > !> When I installed 2003 Server it I selected to install IIS. It ought to "just work"
    > !> and people should NOT have to create custom accounts, run scripts, configure custom pools
    >
    > People normally don't have to do that...because they don't install IIS on domain controllers.
    > Sorry, Kevin, but you have brought this on yourself.


    I disagree. It's not like I did anything non-standard or out of the
    ordinary. The official Microsoft install CD that I have includes both
    the Active Directory and IIS components on the same physical CD. There
    is no reason (other than selling another license) why one server can't
    do more than one thing. It handles a household of 5 people. I'm not
    going to buy another box, and another license just so that I can put
    the web-server on a different machine. That's crazy. A "server" can
    and should be able to do more than one thing at once. You know, like
    "multi-tasking".


    > If you don't have the need for a domain controller ( and, since you are only running
    > a standalone server you don't), I'd install W2K3 in a different partition, as a standalone server,
    > and not as a domain controller, and install IIS.


    I DO have a need for a domain controller. I want a central place to
    manage all of my computers including the computers that my wife and
    kids use. I want a single place that manages all passwords and
    authentication. I want a single place that all computers "login" to
    where I can push service packes, security updates and other things to
    all of the machines automatically without having to run around the
    house and update each machine manually. I want to be able to centrally
    control how much time my kids spend on the computer on school nights.

    I use folder redirection so that when I log into any machine in the
    house my desktop, "My Documents" and everything else that I care about
    is right there for me. Everyones "My Documents" is redirected to the
    server to make backing up data easy.

    So I don't understand your statement of "since I'm only running a
    standalone server I don't have the need for a domain controller." Is
    there any way to do all of the above without a domain controller?



    > It *will* work "out of the box", as soon as you enable ASP.NET.
    >
    >
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq : http://asp.net.do/faq/
    > foros de asp.net, en español : http://asp.net.do/foros/
    > ======================================
    > "Kevin Liebowicz" <> wrote in message news:...
    > On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    >
    > <quote>
    > Step 4. Create an Application Pool with a Custom Identity
    > To create an application pool that runs using a custom service
    > account
    >
    > Start Internet Information Services (IIS) Manager.
    > In the left pane, expand the local computer and then expand
    > Application Pools.
    > </quote>
    >
    > I would but there is not "Application Pools" underneath the local
    > computer or anywhere else in IIS Manager.
    >
    >
    >
    Kevin Liebowicz, Jul 3, 2007
    #18
  19. Kevin Liebowicz

    Dev Null Guest

    "Kevin Liebowicz" <> wrote in message
    news:...
    > Yes, I wasted the past two days trying to fix this.
    > Yes, this is on a Win2003 Server.
    > Yes, this machine is a domain controller.


    I had the same problem late last year and never got anywhere with it.
    Microsoft wants to sell you another software license to run everything.
    Seems that one Linux server is more than capable of running Apache, LDAP,
    MySQL, SendMail and a slew of other software. Microsoft servers on the other
    hand can only run two apps at once, a virus checker and an application of
    your choice.

    I'll bet you dollars to donuts that if you want to run a web server,
    database, active directory, mail server, etc. then the answer will be that
    you need to buy a dedicated machine for each task. Mark my words. Each
    Mickeysoft "server" can barely function as a single-purpose dedicated
    server. It's a joke.







    --
    Posted via a free Usenet account from http://www.teranews.com
    Dev Null, Jul 3, 2007
    #19
  20. Kevin Liebowicz

    Dev Null Guest

    "Kevin Liebowicz" <> wrote in message
    news:...
    On Jul 3, 9:57 am, "Juan T. Llibre" <> wrote:
    > Kevin,
    >
    > in your case all you have to do is set up an ad-hoc service account,
    > as indicated in the link I sent you :
    >
    > How To: Create a Service Account for an ASP.NET 2.0
    > Application:http://msdn2.microsoft.com/en-us/library/ms998297.aspx




    And by the way... other than step #3 not working (because it seems
    that one needs to buy a $800 compiler in order to convince a licensed
    Win2003 server to serve one simple .aspx page) the other steps are not
    even close to working...

    <quote>
    Step 4. Create an Application Pool with a Custom Identity
    To create an application pool that runs using a custom service
    account

    Start Internet Information Services (IIS) Manager.
    In the left pane, expand the local computer and then expand
    Application Pools.
    </quote>

    I would but there is not "Application Pools" underneath the local
    computer or anywhere else in IIS Manager.


    <quote>
    Step 5. Configure Your Application to Run in the New Application Pool

    In this step, you configure your test ASP.NET application to run in
    the new application pool. This ensures that it runs using the custom
    service account identity.
    </quote>

    Except that there is NO application pool.


    WHY IS THIS SO COMPLICATED????? The normal IIS/ASP combination works
    fine. Buy Microsoft really screwed the pooch on this .aspx/.net
    blunder. It ought to just work "out of the box." When I installed 2003
    Server it I selected to install IIS. It ought to "just work" and
    people should NOT have to create custom accounts, run scripts,
    configure custom pools, buy VS.net and sacrifice goats to the gods in
    order for this to work.

    This is not rocket science - it's one simple web page. I have WASTED
    sooooo much time just trying to get this junk to work. And I'm no
    closer today then I was this weekend when I started and who the hell
    knows what sort of state my server is now after installing various
    junk and running all sorts of incarnations of aspnet_xxxxx.exe apps.

    Note to Microsoft - Unlike Vista and this debacle... try shipping
    software that SIMPLY WORKS. Ever hear of KISS - Keep It Simple
    Stupid????? This is way, way, way more complicated than it needs to
    be or ought to be.

    Sorry for the rant but I am sick and tired of spending the last 3-4
    days trying to get my web server to serve one simple .aspx page. What
    sort of idiot would create a product that is so damn complicated that
    it requires all of these ridiculous fixes, hacks and work arounds in
    order to run.



    > You really shouldn't run ASP.NET as the System account,
    > just in case something goes wrong with the boxes' security
    >
    > Juan T. Llibre, asp.net MVP
    > asp.net faq :http://asp.net.do/faq/
    > foros de asp.net, en español :http://asp.net.do/foros/
    > ======================================"Kevin Liebowicz"
    > <> wrote in
    > messagenews:...
    >
    > On Jul 2, 10:38 pm, "Cowboy \(Gregory A. Beamer\)"
    >
    > <> wrote:
    > > Juan has given you the hangman's noose. Now I am going to inform you why
    > > Juan told you not to do this.

    >
    > > You can get it running on a domain controller by altering this account.
    > > The
    > > problem is you now leave a big hole into your domain controller.

    >
    > > Why is this a problem? Well, once someone has control of your domain
    > > controller, they have control of your domain.

    >
    > > And, why is that dangerous? Do you hold ANY secrets. You know, things
    > > like
    > > customer's credit cards, you own employee's social security numbers?
    > > Anything like that? Well, you have the potential of leaving it all open
    > > for
    > > someone.

    >
    > Not at all. This domain controller is in the basement of my house
    > where it sits behind a firewall. There is no external access to the
    > network and the domain controller simply provides me with centralized
    > management for my computers and those that my kids use. I run a web
    > server on the same machine to serve mp3s, photos and videos.
    >
    > > Can this really happen? Well, the likelihood is fairly low. It is almost
    > > impossible on a NORMAL web server, but it is a bit more of a risk on web
    > > server that happens to sit on a DC.

    >
    > Not a problem for me unless my wife plans on hacking into the server.
    > Don't think that you and/or Microsoft understand every customer
    > scenario because you don't.
    >
    > > Can you mitigate this. Certainly. Buy a web server.

    >
    > I don't need yet another machine. The one I currently have is more
    > than capable.
    >
    > > Here is the bottom line. Is it less risky to tell the person forcing you
    > > to
    > > do this to buy a web server or to have your customer's data stolen (and
    > > perhaps your own) or to risk you job telling your boss

    >
    > There is no customer data. I don't need another computer. And there is
    > no boss.
    >
    > > he needs to spend a
    > > few thousand on a web server? If the later, then find a better job. And,
    > > if
    > > it is you that is the boss deciding you need to risk your whole business
    > > over a couple of thosand dollars, then I am wating my time.

    >
    > Yeah, yeah, yeah. Once again... one size does NOT fit all.
    >
    > > Don't put your web server on a DC ... EVER.

    >
    > EVER? Then do explain why my family intranet needs a 2nd machine to
    > server web pages.
    >
    > > Nuff said. If you ignore this, you can take Juan's "fix" and hang
    > > yourself.

    >
    > Ignored because you believe that you understand my situation better
    > than I do. You do not.
    >
    >
    >
    > > --
    > > Gregory A. Beamer
    > > MVP; MCP: +I, SE, SD, DBAhttp://gregorybeamer.spaces.live.com
    > > Co-author: Microsoft Expression Web Bible (upcoming)

    >
    > > ************************************************
    > > Think outside the box!
    > > ************************************************"Kevin Liebowicz"
    > > <> wrote in message

    >
    > >news:...
    > > Yes, I wasted the past two days trying to fix this.
    > > Yes, this is on a Win2003 Server.
    > > Yes, this machine is a domain controller.

    >
    > > Yes, I seen the dozens of KB articles like this
    > > one:http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > But the problem is that 99% of these are for ASP .NET 1.x and this
    > > is .NET 2.x which I just installed to try and get .net working for the
    > > first time ever. I've see all the HACKS to get .net 1.x working... but
    > > this is for .net 2.x so these worthless KB articles do nothing for me.

    >
    > > Example -http://support.microsoft.com/default.aspx?scid=kb;en-us;Q315158

    >
    > > RESOLUTION
    > > To work around this problem, use one of the following methods: ·
    > > Create a weak account that has the correct permissions, and then
    > > configure the <processModel> section of the Machine.config file to use
    > > that account.
    > > · Set the userName attribute to SYSTEM in the <processModel> section
    > > of the Machine.config file.
    > > · Configure the <processModel> section of the Machine.config file to
    > > use an administrator account.

    >
    > > THIS IS USELESS !!!!! There is no "userName" attribute in the
    > > Machine.config file in .net 2.x. And if this is a known problem then
    > > why doesn't the installer warn me or fix it automatically. Sorry, but
    > > your software sucks lately.!!!!!!!

    >
    > > The event log is filled with messages like:

    >
    > > <quote>
    > > aspnet_wp.exe could not be started. The error code for the failure is
    > > 800700CB. This error can be caused when the worker process account has
    > > insufficient rights to read the .NET Framework files. Please ensure
    > > that the .NET Framework is correctly installed and that the ACLs on
    > > the installation directory allow access to the configured account.
    > > </quote>

    >
    > > Sorry Microsoft - But you are getting WORSE and WORSE. How about
    > > software that simply works????

    >
    > > It's no wonder that Linux is kicking your butt and I'm about 30
    > > seconds away from saying goodbye to your over-complicated bug ridden
    > > crap and making the transition to linux myself.- Hide quoted text -

    >
    > - Show quoted text -





    Obviously what they're telling you is that IIS is not compatible with
    Microsoft's own server product. Dump IIS and install Apache. It's faster,
    uses less resources and can do everything that IIS does using standard (not
    propreitary) open source technologies. Check out ruby on rails. It's great
    technology that's easy to configure and use. By the time you get IIS working
    on Windows you could have written your entire app using Apache and ruby on
    rails. http://www.rubyonrails.org/

    Most importantly, unlike Microsoft's own products, both Apache and Ruby on
    Rails *IS* compatible with Windows 2003 server. Although eventually you'll
    probably want to dump that server too and get something that can run more
    than one task + a virus checker at a time.





    --
    Posted via a free Usenet account from http://www.teranews.com
    Dev Null, Jul 3, 2007
    #20
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Simon Devlin
    Replies:
    1
    Views:
    478
    Jim Cheshire [MSFT]
    Jul 12, 2004
  2. =?Utf-8?B?dmljdG9y?=

    "Server Application Unavailable " error message

    =?Utf-8?B?dmljdG9y?=, Feb 1, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    585
    =?Utf-8?B?dmljdG9y?=
    Feb 1, 2005
  3. Robert Halford
    Replies:
    1
    Views:
    4,629
    David Lloyd
    May 13, 2005
  4. =?Utf-8?B?RGFtb24gUm9iZXJ0cw==?=

    Win 2003 Server / IIS6 / Server Application Unavailable

    =?Utf-8?B?RGFtb24gUm9iZXJ0cw==?=, May 17, 2005, in forum: ASP .Net
    Replies:
    6
    Views:
    7,378
    =?Utf-8?B?Y21zMTIz?=
    Jun 23, 2005
  5. hutty
    Replies:
    1
    Views:
    602
    hutty
    Sep 11, 2006
Loading...

Share This Page