IE8 and UTF-8

Discussion in 'HTML' started by Andrew Poulos, Apr 7, 2009.

  1. I've been working on a site that requires the display of Japanese ideograms.

    I set the page's charset to utf-8 and directly inputed the ideograms.

    They appear as expected in all the browsers I've tested except for IE 8.
    In IE 8 I need to turn on compatibility mode to get them to display
    correctly.

    What do I need to do for IE 8 to display the ideograms correctly without
    going to compatibility or quirks mode?

    Andrew Poulos
    Andrew Poulos, Apr 7, 2009
    #1
    1. Advertising

  2. Andrew Poulos wrote:
    > I've been working on a site that requires the display of Japanese
    > ideograms.
    >
    > I set the page's charset to utf-8 and directly inputed the ideograms.
    >
    > They appear as expected in all the browsers I've tested except for IE 8.
    > In IE 8 I need to turn on compatibility mode to get them to display
    > correctly.
    >
    > What do I need to do for IE 8 to display the ideograms correctly without
    > going to compatibility or quirks mode?


    "I set the page's charset to utf-8" doesn't tell us what you actually
    did that you are interpreting in this manner. It's hard to tell what
    part of code we can't see is the cause of a problem. Preferably a URL,
    so we can see what the server is telling the browser.
    Harlan Messinger, Apr 8, 2009
    #2
    1. Advertising

  3. Harlan Messinger wrote:
    > Andrew Poulos wrote:
    >> I've been working on a site that requires the display of Japanese
    >> ideograms.
    >>
    >> I set the page's charset to utf-8 and directly inputed the ideograms.
    >>
    >> They appear as expected in all the browsers I've tested except for IE
    >> 8. In IE 8 I need to turn on compatibility mode to get them to display
    >> correctly.
    >>
    >> What do I need to do for IE 8 to display the ideograms correctly
    >> without going to compatibility or quirks mode?

    >
    > "I set the page's charset to utf-8" doesn't tell us what you actually
    > did that you are interpreting in this manner. It's hard to tell what
    > part of code we can't see is the cause of a problem. Preferably a URL,
    > so we can see what the server is telling the browser.


    Here's the complete HTML for the sample page I'm testing in IE 8.

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
    "http://www.w3.org/TR/html4/strict.dtd">
    <html>
    <head>
    <title>ブランム- Contact</title>
    <meta http-equiv="Content-Type" content="text/html;charset=utf-8">
    <meta http-equiv="Content-Style-Type" content="text/css">
    <meta name="description" content="セーラ ブランãƒã€€ã‚ªãƒ•ã‚£ã‚·">
    <meta name="keywords" content="オーストラリ">
    </head>
    <body>
    <p>Manager: Kimi Funasaka<br>船å‚ 公紀</p>
    </body>
    </html>

    Also when I checked www.sony.jp in IE 8 it again failed to display the
    ideograms correctly. Is IE 8 is "broken"?


    Andrew Poulos
    Andrew Poulos, Apr 9, 2009
    #3
  4. Andrew Poulos

    rf Guest

    Andrew Poulos wrote:
    > Harlan Messinger wrote:
    >> Andrew Poulos wrote:
    >>> I've been working on a site that requires the display of Japanese
    >>> ideograms.
    >>>
    >>> I set the page's charset to utf-8 and directly inputed the
    >>> ideograms. They appear as expected in all the browsers I've tested
    >>> except for
    >>> IE 8. In IE 8 I need to turn on compatibility mode to get them to
    >>> display correctly.
    >>>
    >>> What do I need to do for IE 8 to display the ideograms correctly
    >>> without going to compatibility or quirks mode?

    >>
    >> "I set the page's charset to utf-8" doesn't tell us what you actually
    >> did that you are interpreting in this manner. It's hard to tell what
    >> part of code we can't see is the cause of a problem. Preferably a
    >> URL, so we can see what the server is telling the browser.

    >
    > Here's the complete HTML for the sample page I'm testing in IE 8.


    No, not the HTML, a URL to the page on your server "so we can see what the
    server is telling the browser". Hint: If the server is setting a charset
    then your HTML will not override it.
    rf, Apr 9, 2009
    #4
  5. rf wrote:
    > Andrew Poulos wrote:
    >> Harlan Messinger wrote:
    >>> Andrew Poulos wrote:
    >>>> I've been working on a site that requires the display of Japanese
    >>>> ideograms.
    >>>>
    >>>> I set the page's charset to utf-8 and directly inputed the
    >>>> ideograms. They appear as expected in all the browsers I've tested
    >>>> except for
    >>>> IE 8. In IE 8 I need to turn on compatibility mode to get them to
    >>>> display correctly.
    >>>>
    >>>> What do I need to do for IE 8 to display the ideograms correctly
    >>>> without going to compatibility or quirks mode?
    >>> "I set the page's charset to utf-8" doesn't tell us what you actually
    >>> did that you are interpreting in this manner. It's hard to tell what
    >>> part of code we can't see is the cause of a problem. Preferably a
    >>> URL, so we can see what the server is telling the browser.

    >> Here's the complete HTML for the sample page I'm testing in IE 8.

    >
    > No, not the HTML, a URL to the page on your server "so we can see what the
    > server is telling the browser". Hint: If the server is setting a charset
    > then your HTML will not override it.
    >

    Here's the URL
    <url: http://members.iinet.net.au/~apoulos/unicode.htm >
    It will popup the HTTP Content-Type header when it loads.

    Andrew Poulos
    Andrew Poulos, Apr 9, 2009
    #5
  6. Andrew Poulos

    rf Guest

    Andrew Poulos wrote:
    > rf wrote:
    >> Andrew Poulos wrote:
    >>> Harlan Messinger wrote:
    >>>> Andrew Poulos wrote:
    >>>>> I've been working on a site that requires the display of Japanese
    >>>>> ideograms.
    >>>>>
    >>>>> I set the page's charset to utf-8 and directly inputed the
    >>>>> ideograms. They appear as expected in all the browsers I've tested
    >>>>> except for
    >>>>> IE 8. In IE 8 I need to turn on compatibility mode to get them to
    >>>>> display correctly.
    >>>>>
    >>>>> What do I need to do for IE 8 to display the ideograms correctly
    >>>>> without going to compatibility or quirks mode?
    >>>> "I set the page's charset to utf-8" doesn't tell us what you
    >>>> actually did that you are interpreting in this manner. It's hard
    >>>> to tell what part of code we can't see is the cause of a problem.
    >>>> Preferably a URL, so we can see what the server is telling the
    >>>> browser.
    >>> Here's the complete HTML for the sample page I'm testing in IE 8.

    >>
    >> No, not the HTML, a URL to the page on your server "so we can see
    >> what the server is telling the browser". Hint: If the server is
    >> setting a charset then your HTML will not override it.
    >>

    > Here's the URL
    > <url: http://members.iinet.net.au/~apoulos/unicode.htm >
    > It will popup the HTTP Content-Type header when it loads.


    Your server headers indicate content-type text/html, without any charset
    info. So the meta element in your page should, and in fact is, taking
    effect, as per the page info displayed by firefox.

    If it is not working in IE8 then I suggest you file a bug report, or ask
    over in the relevant microsoft group.
    rf, Apr 9, 2009
    #6
  7. Andrew Poulos

    BootNic Guest

    On Thu, 09 Apr 2009 15:10:34 +1000
    Andrew Poulos <> wrote in:
    <49dd8377$0$29845$>

    >>>> Andrew Poulos wrote:
    >>>>> I've been working on a site that requires the display of
    >>>>> Japanese ideograms.
    >>>>>
    >>>>> I set the page's charset to utf-8 and directly inputed the
    >>>>> ideograms. They appear as expected in all the browsers I've
    >>>>> tested except for IE 8. In IE 8 I need to turn on
    >>>>> compatibility mode to get them to display correctly.
    >>>>>
    >>>>> What do I need to do for IE 8 to display the ideograms
    >>>>> correctly without going to compatibility or quirks mode?

    [snip]
    > Here's the URL <url:
    > http://members.iinet.net.au/~apoulos/unicode.htm > It will popup
    > the HTTP Content-Type header when it loads.


    In Vista Business sp1 IE 8 the url displays the Japanese just fine.

    In my xp pro IE 8, IE 8 compatibility mode does not affect the
    display, xp home IE 7, the Japanese does not display.

    --
    BootNic Thu Apr 9, 2009 02:59 am
    Facts do not cease to exist because they are ignored.
    *Aldous Huxley*

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.10 (GNU/Linux)

    iEYEARECAAYFAkndnOAACgkQylMUzZO6jeKTAACfUOdJWbS9z57akua5fR0cNrRd
    hrAAoLZTqCK4nqNib29NUWcek3mB0ymh
    =8oow
    -----END PGP SIGNATURE-----
    BootNic, Apr 9, 2009
    #7
  8. BootNic wrote:
    > On Thu, 09 Apr 2009 15:10:34 +1000
    > Andrew Poulos <> wrote in:
    > <49dd8377$0$29845$>
    >
    >>>>> Andrew Poulos wrote:
    >>>>>> I've been working on a site that requires the display of
    >>>>>> Japanese ideograms.
    >>>>>>
    >>>>>> I set the page's charset to utf-8 and directly inputed the
    >>>>>> ideograms. They appear as expected in all the browsers I've
    >>>>>> tested except for IE 8. In IE 8 I need to turn on
    >>>>>> compatibility mode to get them to display correctly.
    >>>>>>
    >>>>>> What do I need to do for IE 8 to display the ideograms
    >>>>>> correctly without going to compatibility or quirks mode?

    > [snip]
    >> Here's the URL <url:
    >> http://members.iinet.net.au/~apoulos/unicode.htm > It will popup
    >> the HTTP Content-Type header when it loads.

    >
    > In Vista Business sp1 IE 8 the url displays the Japanese just fine.
    >
    > In my xp pro IE 8, IE 8 compatibility mode does not affect the
    > display, xp home IE 7, the Japanese does not display.


    For me it displays fine on XP Pro IE 6 and IE 7, and Vista IE 7.

    On XP Pro with IE 8 I need to turn on compatibility view to get the
    ideograms to appear.

    Also I note that www.sony.jp does not display ideograms on XP Pro with IE 8.

    Do I need Vista to get IE 8 to work with unicode?

    Andrew Poulos
    Andrew Poulos, Apr 9, 2009
    #8
  9. Andrew Poulos

    rf Guest

    Andrew Poulos wrote:

    > Do I need Vista to get IE 8 to work with unicode?


    Now wouldn't that be a remarkable marketing ploy.

    Hey, I'm microsoft, download my latest and greatest *free* browser but you
    will need to spend hundreds of $s to upgrade your operating system to my
    latest and greatest and very broken version to make the browser usable if
    you don't live in the U S of A :)
    rf, Apr 9, 2009
    #9
  10. Andrew Poulos

    Bergamot Guest

    rf wrote:
    >
    > Hey, I'm microsoft, download my latest and greatest *free* browser but you
    > will need to spend hundreds of $s to upgrade your operating system to my
    > latest and greatest [...] to make the browser usable


    Strange how nobody seems to complain when Apple does the same thing...

    --
    Berg
    Bergamot, Apr 9, 2009
    #10
  11. Andrew Poulos

    BootNic Guest

    On Thu, 09 Apr 2009 19:12:47 +1000
    Andrew Poulos <> wrote in:
    <49ddbc3c$0$29856$>

    > BootNic wrote:
    >> On Thu, 09 Apr 2009 15:10:34 +1000
    >> Andrew Poulos <> wrote in:
    >> <49dd8377$0$29845$>
    >>
    >>>>>> Andrew Poulos wrote:
    >>>>>>> I've been working on a site that requires the display of
    >>>>>>> Japanese ideograms.
    >>>>>>>
    >>>>>>> I set the page's charset to utf-8 and directly inputed
    >>>>>>> the ideograms. They appear as expected in all the browsers
    >>>>>>> I've tested except for IE 8. In IE 8 I need to turn on
    >>>>>>> compatibility mode to get them to display correctly.
    >>>>>>>
    >>>>>>> What do I need to do for IE 8 to display the ideograms
    >>>>>>> correctly without going to compatibility or quirks mode?

    >> [snip]
    >>> Here's the URL <url:
    >>> http://members.iinet.net.au/~apoulos/unicode.htm > It will
    >>> popup the HTTP Content-Type header when it loads.

    >>
    >> In Vista Business sp1 IE 8 the url displays the Japanese just
    >> fine.
    >>
    >> In my xp pro IE 8, IE 8 compatibility mode does not affect
    >> the display, xp home IE 7, the Japanese does not display.

    >
    > For me it displays fine on XP Pro IE 6 and IE 7, and Vista IE
    > 7.
    >
    > On XP Pro with IE 8 I need to turn on compatibility view to
    > get the ideograms to appear.
    >
    > Also I note that www.sony.jp does not display ideograms on XP
    > Pro with IE 8.
    >
    > Do I need Vista to get IE 8 to work with unicode?


    I don't think that would be required.

    After a visit to the sony site with xp pro sp3 IE 8, it prompted
    me to install a language pack. I did try to install it from that
    prompted, however it failed to install.

    After a while I was able to install files for East Asian
    languages and gave it another go.

    xp pro sp3 IE 8 did display the ideograms, as I can not read
    Japanese I really do not know if it displayed correctly. It did
    display without the need for compatibility view.

    I can only assume that if I were to install the East Asian
    languages on the other xp systems it would produce the same results
    for IE 6 & 7.

    Perhaps try to reinstall/install the East Asian languages to see
    if that resolves the issue.

    --
    BootNic Thu Apr 9, 2009 03:41 pm
    "This is all very interesting, and I daresay you already see me
    frothing at the mouth in a fit; but no, I am not; I am just winking
    happy thoughts into a little tiddle cup."
    *Nabokov, Lolita*

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.10 (GNU/Linux)

    iEYEARECAAYFAkneT4oACgkQylMUzZO6jeKa4ACeKVONX0Jqp10RV+JAUOJNaE/L
    lCcAnjctqIFF0rkU9CCxnqmp7HUgMrm/
    =GIH1
    -----END PGP SIGNATURE-----
    BootNic, Apr 9, 2009
    #11
  12. BootNic wrote:
    > On Thu, 09 Apr 2009 19:12:47 +1000
    > Andrew Poulos <> wrote in:
    > <49ddbc3c$0$29856$>
    >
    >> BootNic wrote:
    >>> On Thu, 09 Apr 2009 15:10:34 +1000
    >>> Andrew Poulos <> wrote in:
    >>> <49dd8377$0$29845$>
    >>>
    >>>>>>> Andrew Poulos wrote:
    >>>>>>>> I've been working on a site that requires the display of
    >>>>>>>> Japanese ideograms.
    >>>>>>>>
    >>>>>>>> I set the page's charset to utf-8 and directly inputed
    >>>>>>>> the ideograms. They appear as expected in all the browsers
    >>>>>>>> I've tested except for IE 8. In IE 8 I need to turn on
    >>>>>>>> compatibility mode to get them to display correctly.
    >>>>>>>>
    >>>>>>>> What do I need to do for IE 8 to display the ideograms
    >>>>>>>> correctly without going to compatibility or quirks mode?
    >>> [snip]
    >>>> Here's the URL <url:
    >>>> http://members.iinet.net.au/~apoulos/unicode.htm > It will
    >>>> popup the HTTP Content-Type header when it loads.
    >>> In Vista Business sp1 IE 8 the url displays the Japanese just
    >>> fine.
    >>>
    >>> In my xp pro IE 8, IE 8 compatibility mode does not affect
    >>> the display, xp home IE 7, the Japanese does not display.

    >> For me it displays fine on XP Pro IE 6 and IE 7, and Vista IE
    >> 7.
    >>
    >> On XP Pro with IE 8 I need to turn on compatibility view to
    >> get the ideograms to appear.
    >>
    >> Also I note that www.sony.jp does not display ideograms on XP
    >> Pro with IE 8.
    >>
    >> Do I need Vista to get IE 8 to work with unicode?

    >
    > I don't think that would be required.


    I found a Vista box and IE 8 does display Unicode correctly without
    being in compatibility view.

    > After a visit to the sony site with xp pro sp3 IE 8, it prompted
    > me to install a language pack. I did try to install it from that
    > prompted, however it failed to install.
    >
    > After a while I was able to install files for East Asian
    > languages and gave it another go.
    >
    > xp pro sp3 IE 8 did display the ideograms, as I can not read
    > Japanese I really do not know if it displayed correctly. It did
    > display without the need for compatibility view.
    >
    > I can only assume that if I were to install the East Asian
    > languages on the other xp systems it would produce the same results
    > for IE 6 & 7.
    >
    > Perhaps try to reinstall/install the East Asian languages to see
    > if that resolves the issue.


    I've never installed East Asian languages. I have on the same XP SP3 box
    Opera, Firefox, Chrome and Safari and they all display the ideograms
    correctly. So it tends to make me believe that there's an issue with IE
    8 on XP.

    Andrew Poulos
    Andrew Poulos, Apr 9, 2009
    #12
  13. Andrew Poulos

    dorayme Guest

    In article <>,
    Bergamot <> wrote:

    > rf wrote:
    > >
    > > Hey, I'm microsoft, download my latest and greatest *free* browser but you
    > > will need to spend hundreds of $s to upgrade your operating system to my
    > > latest and greatest [...] to make the browser usable

    >
    > Strange how nobody seems to complain when Apple does the same thing...


    And Apple did this 'same thing' when?

    --
    dorayme
    dorayme, Apr 9, 2009
    #13
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. JJBW
    Replies:
    1
    Views:
    9,993
    Joerg Jooss
    Apr 24, 2004
  2. =?Utf-8?B?QXNoYQ==?=
    Replies:
    3
    Views:
    408
  3. jmfauth
    Replies:
    4
    Views:
    303
    jmfauth
    Oct 13, 2010
  4. Grzegorz ¦liwiñski
    Replies:
    2
    Views:
    928
    Grzegorz ¦liwiñski
    Jan 19, 2011
  5. cecile

    ie8!=ie8

    cecile, May 24, 2010, in forum: Javascript
    Replies:
    2
    Views:
    173
    David Mark
    May 24, 2010
Loading...

Share This Page