IE's default for Save As Type incorrect

Discussion in 'ASP General' started by nbaxley, Jul 6, 2004.

  1. nbaxley

    nbaxley Guest

    I'm using a binary stream to send down a file with ASP from the web
    server. I've been having trouble with IE and getting it to recognize
    my file. I've added the filename as a paramater(?filename=file.jpgw)
    to handle IE's mime type mangling, but I'm still having trouble with
    IE's default Save As Type being HTML. When we send down a jpgw
    (geo-jpeg) file IE wants to save it as an HTML file. I've got the
    correct filename showing in the Filename box, and if I choose the All
    Files option from the Save As Type drop down then the file is saved
    with the correct extension. I'd like to have the All Files option
    choosen by default. I know it's just a couple of clicks but we have
    some noivce users that can't seem to get that.

    Any ideas?
    Nate Baxley
     
    nbaxley, Jul 6, 2004
    #1
    1. Advertising

  2. Aaron [SQL Server MVP], Jul 6, 2004
    #2
    1. Advertising

  3. nbaxley

    nbaxley Guest

    Sorry about that I've added the filename as a parameter to the script
    (page.asp?file=image.jpgw) in order to get IE to look at the correct
    extension instead of just the mime-type. I looked at both of the
    articles you linked to and they don't address the main problem I'm
    having which is getting the "Save As Type" drop down in the "Save As"
    box to show the option that I want, which is All Types or anything
    that will keep IE from adding an extension to my filename.

    Thanks for the links,
    Nate Baxley

    "Aaron [SQL Server MVP]" <> wrote in message news:<>...
    > > I've added the filename as a paramater(?filename=file.jpgw)

    >
    > Added the filename as a parameter to what?
    >
    > http://www.aspfaq.com/2161
    > http://www.aspfaq.com/2129
     
    nbaxley, Jul 8, 2004
    #3
  4. > articles you linked to and they don't address the main problem I'm
    > having which is getting the "Save As Type" drop down in the "Save As"
    > box to show the option that I want, which is All Types or anything
    > that will keep IE from adding an extension to my filename.


    Sorry, you can't control this client-side behavior, and you certainly can't
    do it from ASP.
     
    Aaron [SQL Server MVP], Jul 8, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. user
    Replies:
    1
    Views:
    795
    Bruce Barker
    Apr 4, 2005
  2. JMUApache
    Replies:
    2
    Views:
    3,342
    Brendan Reynolds
    Sep 4, 2005
  3. CJ
    Replies:
    1
    Views:
    1,619
    Andrew Thompson
    Oct 29, 2004
  4. Ragnar
    Replies:
    2
    Views:
    495
    tom_usenet
    Sep 4, 2003
  5. Kit Truong

    Default Save as type and filename

    Kit Truong, May 26, 2004, in forum: ASP General
    Replies:
    2
    Views:
    205
    Varun
    May 26, 2004
Loading...

Share This Page