[IIS 7.0]Handler for asmx page ?

Discussion in 'ASP .Net' started by Oriane, Jun 18, 2007.

  1. Oriane

    Oriane Guest

    Hi there,

    When I try to access a Web service running on my default Web site, on Vista
    and IIS 7.0, I get an error message : "the MIME type is not recognized". So
    I guess that the asmx handler is not configured ???

    Regards
     
    Oriane, Jun 18, 2007
    #1
    1. Advertising

  2. Oriane

    Mr. Arnold Guest

    "Oriane" <> wrote in message
    news:...
    > Hi there,
    >
    > When I try to access a Web service running on my default Web site, on
    > Vista and IIS 7.0, I get an error message : "the MIME type is not
    > recognized". So I guess that the asmx handler is not configured ???
    >


    Well, go check the MIME types on the Web server and see if .asmx is in
    there.
     
    Mr. Arnold, Jun 18, 2007
    #2
    1. Advertising

  3. The .asmx extension is automatically recognized by the ASP.NET runtime. So I
    think what you really need to check is whether ASP.NET is "enabled". In IIS
    7.0, nothing is enabled by default - you have to "turn it on".
    Peter

    --
    Site: http://www.eggheadcafe.com
    UnBlog: http://petesbloggerama.blogspot.com
    Short urls & more: http://ittyurl.net




    "Oriane" wrote:

    > Hi there,
    >
    > When I try to access a Web service running on my default Web site, on Vista
    > and IIS 7.0, I get an error message : "the MIME type is not recognized". So
    > I guess that the asmx handler is not configured ???
    >
    > Regards
    >
    >
     
    =?Utf-8?B?UGV0ZXIgQnJvbWJlcmcgW0MjIE1WUF0=?=, Jun 18, 2007
    #3
  4. Oriane

    Guest

    Re: Handler for asmx page ?

    On Jun 18, 11:10 am, "Oriane" <> wrote:
    > Hi there,
    >
    > When I try to access a Web service running on my default Web site, on Vista
    > and IIS 7.0, I get an error message : "the MIME type is not recognized". So
    > I guess that the asmx handler is not configured ???
    >
    > Regards


    There is a chance that ASP.NET is not registered properly with IIS.
    This has happened to me and I had to run asp_regiis.exe to re-register
    it.

    1. Open a command prompt and go to the Microsoft.Net Framework version
    directory,
    e.g. cd C:\Winnt\Microsoft.net\Framework\v2.0.50727\

    2 Run the asp_regiis.exe program with -i
    e.g. asp_regiis -i

    Not sure if you have to restart IIS or not

    Another test is to create a simple aspx web page and see if you can
    access it. Possibly it will give you a better error message than a
    web service method does.

    Ron
     
    , Jun 18, 2007
    #4
  5. Oriane

    Oriane Guest

    Hi Peter,
    "Peter Bromberg [C# MVP]" <> a écrit dans
    le message de news: ...
    > The .asmx extension is automatically recognized by the ASP.NET runtime. So
    > I
    > think what you really need to check is whether ASP.NET is "enabled". In
    > IIS
    > 7.0, nothing is enabled by default - you have to "turn it on".

    So how do I do that ?

    Regards
     
    Oriane, Jun 18, 2007
    #5
  6. Oriane

    Mr. Arnold Guest

    "Oriane" <> wrote in message
    news:...
    > Hi Peter,
    > "Peter Bromberg [C# MVP]" <> a écrit dans
    > le message de news: ...
    >> The .asmx extension is automatically recognized by the ASP.NET runtime.
    >> So I
    >> think what you really need to check is whether ASP.NET is "enabled". In
    >> IIS
    >> 7.0, nothing is enabled by default - you have to "turn it on".

    > So how do I do that ?
    >


    Your friend is Google.
    http://intersoftpt.wordpress.com/2006/11/25/enabling-aspnet-20-in-vista-rtm/
     
    Mr. Arnold, Jun 19, 2007
    #6
  7. Oriane

    Oriane Guest

    Re: Handler for asmx page ?

    Hi Ron,
    <> a écrit dans le message de
    news:...
    > On Jun 18, 11:10 am, "Oriane" <> wrote:
    >> Hi there,
    >>
    >> When I try to access a Web service running on my default Web site, on
    >> Vista
    >> and IIS 7.0, I get an error message : "the MIME type is not recognized".
    >> So
    >> I guess that the asmx handler is not configured ???
    >>
    >> Regards

    >
    > There is a chance that ASP.NET is not registered properly with IIS.
    > This has happened to me and I had to run asp_regiis.exe to re-register
    > it.

    It would be a shame as Asp.Net is preinstalled on Vista !!!

    Oriane
     
    Oriane, Jun 19, 2007
    #7
  8. Oriane

    Oriane Guest

    Hi Mr Arnold,

    "Mr. Arnold" <MR. > a écrit dans le message de
    news:...
    >
    > "Oriane" <> wrote in message
    > news:...
    >> Hi Peter,
    >> "Peter Bromberg [C# MVP]" <> a écrit
    >> dans le message de news:
    >> ...
    >>> The .asmx extension is automatically recognized by the ASP.NET runtime.
    >>> So I
    >>> think what you really need to check is whether ASP.NET is "enabled". In
    >>> IIS
    >>> 7.0, nothing is enabled by default - you have to "turn it on".

    >> So how do I do that ?
    >>

    >
    > Your friend is Google.
    > http://intersoftpt.wordpress.com/2006/11/25/enabling-aspnet-20-in-vista-rtm/

    I don't understand why "IIS 7.0 help" is not my friend.
    Thanks for the link, it works now :))

    Oriane
     
    Oriane, Jun 19, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. asptodotnet
    Replies:
    1
    Views:
    426
    Daniel Fisher\(lennybacon\)
    Nov 18, 2004
  2. Craig G
    Replies:
    1
    Views:
    460
    William F. Robertson, Jr.
    Dec 6, 2004
  3. Nalaka

    configure IIS for .asmx

    Nalaka, Nov 23, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    9,320
    misternaveed
    Oct 22, 2008
  4. Bill Davidson
    Replies:
    5
    Views:
    690
    Bill Davidson
    Sep 12, 2006
  5. moondaddy

    Not debugging into asmx page

    moondaddy, Sep 20, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    1,581
    moondaddy
    Sep 20, 2006
Loading...

Share This Page