IIS Remote programming problem

Discussion in 'ASP .Net' started by gilberto ramirez, Jun 28, 2003.

  1. I want to create an ASP application in the following way:

    PC1 - Windows XP (SP1) with VS .NET (and everything
    needed) - im programming with C# .NET

    SRV1 - ISA SERVER - Windows 2000 (SP3)
    SRV2 - in a virtual server called xxAP.xxx.xxx.com
    it has:
    - Windows 2000 (SP3)
    - FPSE ver 2002 (correctly configured)
    - IE 6.0 (sp1)

    when i try to create a new web app on the SRV2 (remote
    server) i can by using FP extensions 2002 succesfully.

    but the problem starts when i try to compile and browse
    my curren aspx form, Default.aspx, the only things i
    added where: a label and a textBox, but it simply shows
    this msg:

    Server Error in '/' Application.
    Runtime Error
    An application error occurred on the server. The current
    custom error settings for this application prevent the
    details of the application error from being viewed
    remotely (for security reasons). It could, however, be
    viewed by browsers running on the local server machine.
    enable the details of this specific error message to be
    viewable on remote machines, please create a
    <customErrors> tag within a "web.config" configuration
    file located in the root directory of the current web
    application. This <customErrors> tag should then have
    its "mode" attribute set to "Off".


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="Off"/>
    </system.web>
    </configuration>

    Notes: The current error page you are seeing can be
    replaced by a custom error page by modifying
    the "defaultRedirect" attribute of the application's
    <customErrors> configuration tag to point to a custom
    error page URL.


    <!-- Web.Config Configuration File -->

    <configuration>
    <system.web>
    <customErrors mode="RemoteOnly"
    defaultRedirect="mycustompage.htm"/>
    </system.web>
    </configuration>

    i guess it is because the aspx is running on a remote IIS
    5.0, how can i solve this problem?
    so i can create a site in SRV2 using my XP client with
    VS .NET?
    gilberto ramirez, Jun 28, 2003
    #1
    1. Advertising

  2. Do this and post back the error message:

    This <customErrors> tag should then have
    > its "mode" attribute set to "Off".
    >
    >
    > <!-- Web.Config Configuration File -->
    >
    > <configuration>
    > <system.web>
    > <customErrors mode="Off"/>
    > </system.web>
    > </configuration>
    Chance Hopkins, Jun 28, 2003
    #2
    1. Advertising

  3. i managed to solve it, it took a while :) but it seems
    that it is working now
    if anyone else has this problem you can solve it in this
    way:
    follow the instructions in
    http://support.microsoft.com/default.aspx?scid=kb;EN-
    US;312779

    and get sure IIS and FPSE are correctly installed, i
    found after a lot of research that my FPSE where indeed
    misconfigured.


    >-----Original Message-----
    >Do this and post back the error message:
    >
    >This <customErrors> tag should then have
    >> its "mode" attribute set to "Off".
    >>
    >>
    >> <!-- Web.Config Configuration File -->
    >>
    >> <configuration>
    >> <system.web>
    >> <customErrors mode="Off"/>
    >> </system.web>
    >> </configuration>

    >
    >
    >
    >.
    >
    gilberto ramirez, Jun 28, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Matthew Louden
    Replies:
    3
    Views:
    5,898
    Sherif ElMetainy
    Nov 7, 2003
  2. davidj411
    Replies:
    7
    Views:
    3,262
    Tim Golden
    Oct 8, 2009
  3. Tim Chandler
    Replies:
    0
    Views:
    210
    Tim Chandler
    Oct 7, 2003
  4. Jeff Wood
    Replies:
    7
    Views:
    194
    Jeff Wood
    Oct 18, 2005
  5. Dayton Jones

    Remote.pm (File::Remote) problem

    Dayton Jones, Mar 1, 2006, in forum: Perl Misc
    Replies:
    9
    Views:
    186
    Dayton Jones
    Mar 3, 2006
Loading...

Share This Page