IIS5 and permissions

Discussion in 'ASP General' started by Hugh Welford, Jan 13, 2004.

  1. Hugh Welford

    Hugh Welford Guest

    Hi, I have installed IIS5 on my machine so that I can do offline asp web
    development. (using WIN XP PRO). My machine is called "development"

    I have published an on-line working web to
    http://development/websites/defaultwebsite/de-stress and copied on-line
    working data to c:\inetpub\wwwroot\de-stress\data\schooldata.mdb

    The database schooldata.mdb is in access97, and in its on-line existence
    accepts both read and write access OK.

    However, offline, I can only get it to run in read-only mode, any attempt to
    write to it results in "object read only" error.

    The DSN is set up without System Data Base. I have set read/write permission
    in IIS on all the path nodes websites, defaultwebsite, de-stress, data and
    schooldata.mdb and have set anonymous access/user name
    IUSR_DEVELOPMENT/allow IIS to control password wherever appropriate, and
    still I cannot write into the db from the site.

    I have only access 2000 installed on this machine, which will not let me
    write into an access97 db, but surely the write takes place server-side? I
    have converted the db to access2000 to see if that solved the problem, but
    makes it worse as the asp pages can neither read Nor write, saying I have no
    permission, even if the DSN is set up with system data base which allows me
    to change it. The db itself has user/group admin permissions on database and
    all tables. What else can I do to get at my own data??? Is there not an
    offline no-permissions mode to allow offline development without all this
    hassle?

    Sorry to be long-winded. Desperate for some help. Thanks Hugh
     
    Hugh Welford, Jan 13, 2004
    #1
    1. Advertising

  2. Hugh Welford

    Ray at Guest

    Make sure that your IUSR account has NTFS permissions to the \data
    directory. The IUSR account need to be able to modify files, create files,
    and delete files in that directory.

    Ray at work

    "Hugh Welford" <> wrote in message
    news:%...
    > Hi, I have installed IIS5 on my machine so that I can do offline asp web
    > development. (using WIN XP PRO). My machine is called "development"
    >
    > I have published an on-line working web to
    > http://development/websites/defaultwebsite/de-stress and copied on-line
    > working data to c:\inetpub\wwwroot\de-stress\data\schooldata.mdb
    >
    > The database schooldata.mdb is in access97, and in its on-line existence
    > accepts both read and write access OK.
    >
    > However, offline, I can only get it to run in read-only mode, any attempt

    to
    > write to it results in "object read only" error.
    >
    > The DSN is set up without System Data Base. I have set read/write

    permission
    > in IIS on all the path nodes websites, defaultwebsite, de-stress, data and
    > schooldata.mdb and have set anonymous access/user name
    > IUSR_DEVELOPMENT/allow IIS to control password wherever appropriate, and
    > still I cannot write into the db from the site.
    >
    > I have only access 2000 installed on this machine, which will not let me
    > write into an access97 db, but surely the write takes place server-side? I
    > have converted the db to access2000 to see if that solved the problem, but
    > makes it worse as the asp pages can neither read Nor write, saying I have

    no
    > permission, even if the DSN is set up with system data base which allows

    me
    > to change it. The db itself has user/group admin permissions on database

    and
    > all tables. What else can I do to get at my own data??? Is there not an
    > offline no-permissions mode to allow offline development without all this
    > hassle?
    >
    > Sorry to be long-winded. Desperate for some help. Thanks Hugh
    >
    >
     
    Ray at, Jan 13, 2004
    #2
    1. Advertising

  3. Hugh Welford

    Ray at Guest

    p.s. You should fix your clock. You're jumping to the ~end~ of the line.
    Apply the opposite logic that you read here, and you'll see you're being
    super-courteous. :] www.aspfaq.com/5005

    Ray at work

    "Hugh Welford" <> wrote in message
    news:%...
    > Hi, I have installed IIS5 on my machine so that I can do offline asp web
    > developme
     
    Ray at, Jan 13, 2004
    #3
  4. Hugh Welford

    Hugh Welford Guest

    Thanks for your help Ray. Since I am a newbie, and not familiar with IIS,
    could you tell me how to give IUSR account the NTFS permissions to the \data
    directory? In the IIS console tree, right clicking the data directory and
    selection properties shows that I have already checked read/write in the
    local path box on the Directory Tab, and on the Directory Security tab have
    checked anonymous access in the anonymous access and authentication methods
    box.

    If I have to do any more, I would be grateful for your further help, and
    some advice as to where I could get a manaul on IIS management. Thanks Hugh



    "Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
    news:...
    > Make sure that your IUSR account has NTFS permissions to the \data
    > directory. The IUSR account need to be able to modify files, create

    files,
    > and delete files in that directory.
    >
    > Ray at work
    >
    > "Hugh Welford" <> wrote in message
    > news:%...
    > > Hi, I have installed IIS5 on my machine so that I can do offline asp web
    > > development. (using WIN XP PRO). My machine is called "development"
    > >
    > > I have published an on-line working web to
    > > http://development/websites/defaultwebsite/de-stress and copied on-line
    > > working data to c:\inetpub\wwwroot\de-stress\data\schooldata.mdb
    > >
    > > The database schooldata.mdb is in access97, and in its on-line existence
    > > accepts both read and write access OK.
    > >
    > > However, offline, I can only get it to run in read-only mode, any

    attempt
    > to
    > > write to it results in "object read only" error.
    > >
    > > The DSN is set up without System Data Base. I have set read/write

    > permission
    > > in IIS on all the path nodes websites, defaultwebsite, de-stress, data

    and
    > > schooldata.mdb and have set anonymous access/user name
    > > IUSR_DEVELOPMENT/allow IIS to control password wherever appropriate, and
    > > still I cannot write into the db from the site.
    > >
    > > I have only access 2000 installed on this machine, which will not let me
    > > write into an access97 db, but surely the write takes place server-side?

    I
    > > have converted the db to access2000 to see if that solved the problem,

    but
    > > makes it worse as the asp pages can neither read Nor write, saying I

    have
    > no
    > > permission, even if the DSN is set up with system data base which allows

    > me
    > > to change it. The db itself has user/group admin permissions on database

    > and
    > > all tables. What else can I do to get at my own data??? Is there not an
    > > offline no-permissions mode to allow offline development without all

    this
    > > hassle?
    > >
    > > Sorry to be long-winded. Desperate for some help. Thanks Hugh
    > >
    > >

    >
    >
     
    Hugh Welford, Jan 14, 2004
    #4
  5. Hugh Welford

    Hugh Welford Guest

    HI Ray, as far as I can see my clock is set correctly in the GMT time
    zone - I am in UK.

    Regards Hugh



    "Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
    news:...
    > p.s. You should fix your clock. You're jumping to the ~end~ of the line.
    > Apply the opposite logic that you read here, and you'll see you're being
    > super-courteous. :] www.aspfaq.com/5005
    >
    > Ray at work
    >
    > "Hugh Welford" <> wrote in message
    > news:%...
    > > Hi, I have installed IIS5 on my machine so that I can do offline asp web
    > > developme

    >
    >
     
    Hugh Welford, Jan 14, 2004
    #5
  6. Hugh Welford

    Ray at Guest

    Looks good now!

    Ray at work

    "Hugh Welford" <> wrote in message
    news:...
    > HI Ray, as far as I can see my clock is set correctly in the GMT time
    > zone - I am in UK.
    >
    > Regards Hugh
    >
    >
    >
    > "Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
    > news:...
    > > p.s. You should fix your clock. You're jumping to the ~end~ of the

    line.
    > > Apply the opposite logic that you read here, and you'll see you're being
    > > super-courteous. :] www.aspfaq.com/5005
    > >
    > > Ray at work
    > >
    > > "Hugh Welford" <> wrote in message
    > > news:%...
    > > > Hi, I have installed IIS5 on my machine so that I can do offline asp

    web
    > > > developme

    > >
    > >

    >
    >
     
    Ray at, Jan 14, 2004
    #6
  7. Hugh Welford

    Ray at Guest

    NTFS file permissions are set at the file system level within Windows
    Explorer, for example, not IIS. So, open a Windows Explorer, right click
    the folder, click properties, go to the security tab, click Add..., type
    YOURCOMPUTERNAME\IUSR_YOURCOMPUTERNAME, press Enter, select read, write,
    modify (or just full control if you aren't the ultra-paranoid type) and
    click OK.

    If you do not see a security tab, either you don't have your drive formatted
    in NTFS and you're problem is something else entirely, or your XP OS is
    setup in that way that hides everything that is useful. If you don't see
    it, then do this:

    Start---run--CMD--Enter
    format c:
    [read the response]
    Press Ctrl+C to cancel out of this operation.

    If it said you have an NTFS drive (as opposed to FAT[32]), then enter this:

    cacls c:\inetpub\wwwroot\de-stress\data /E /G IUSR_YourComputerName:F

    Ray at work

    "Hugh Welford" <> wrote in message
    news:...
    > Thanks for your help Ray. Since I am a newbie, and not familiar with IIS,
    > could you tell me how to give IUSR account the NTFS permissions to the

    \data
    > directory? In the IIS console tree, right clicking the data directory and
    > selection properties shows that I have already checked read/write in the
    > local path box on the Directory Tab, and on the Directory Security tab

    have
    > checked anonymous access in the anonymous access and authentication

    methods
    > box.
    >
    > If I have to do any more, I would be grateful for your further help, and
    > some advice as to where I could get a manaul on IIS management. Thanks

    Hugh
    >
    >
     
    Ray at, Jan 14, 2004
    #7
  8. Hugh Welford

    hugh Welford Guest

    Thanks Ray for your advice. I do not see the Security tab, but do have NTFS,
    so followed your advice - but still no joy.

    Even after the recommended changes, when I go to the data directory in Win
    Explorer, and go to Properties the read-only attibute is set. It un-checks,
    but doesnt take - it is still checked if I go there again. Just drives you
    mad.

    Also, In Explorer, if I go to the db properties of the db in the data
    directory, it tells me the file will open with ACCESS for windows (does the
    IIS server side use the same ACCESS as client side in offline situation like
    this?). Anyway, the db which is working on-line in in ACCESS 97 format, so I
    upgraded the offline version to ACCESS 2000, and it will now neither read
    nor write...tells me I dont have permission, even tho the DSN is no system
    database. If I try to look at permissions on this 2000 db, ut tells me I
    have no permission - "records cannot be read: no read permission on
    Msysaccounts"

    It all drives you mad - never had these problems with win 98 and PWS - all I
    want to do is write to my own data.

    I quite understand if you dont wish to continue with this, but if you dont
    mind, any further advice would be gratefull accepted. What is the best
    resource to learn about WIN XP/IIS management?

    Regards and Thanks Hugh


    "Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
    news:...
    > NTFS file permissions are set at the file system level within Windows
    > Explorer, for example, not IIS. So, open a Windows Explorer, right click
    > the folder, click properties, go to the security tab, click Add..., type
    > YOURCOMPUTERNAME\IUSR_YOURCOMPUTERNAME, press Enter, select read, write,
    > modify (or just full control if you aren't the ultra-paranoid type) and
    > click OK.
    >
    > If you do not see a security tab, either you don't have your drive

    formatted
    > in NTFS and you're problem is something else entirely, or your XP OS is
    > setup in that way that hides everything that is useful. If you don't see
    > it, then do this:
    >
    > Start---run--CMD--Enter
    > format c:
    > [read the response]
    > Press Ctrl+C to cancel out of this operation.
    >
    > If it said you have an NTFS drive (as opposed to FAT[32]), then enter

    this:
    >
    > cacls c:\inetpub\wwwroot\de-stress\data /E /G IUSR_YourComputerName:F
    >
    > Ray at work
    >
    > "Hugh Welford" <> wrote in message
    > news:...
    > > Thanks for your help Ray. Since I am a newbie, and not familiar with

    IIS,
    > > could you tell me how to give IUSR account the NTFS permissions to the

    > \data
    > > directory? In the IIS console tree, right clicking the data directory

    and
    > > selection properties shows that I have already checked read/write in the
    > > local path box on the Directory Tab, and on the Directory Security tab

    > have
    > > checked anonymous access in the anonymous access and authentication

    > methods
    > > box.
    > >
    > > If I have to do any more, I would be grateful for your further help, and
    > > some advice as to where I could get a manaul on IIS management. Thanks

    > Hugh
    > >
    > >

    >
    >
     
    hugh Welford, Jan 15, 2004
    #8
  9. Hugh Welford

    Ray at Guest

    "hugh Welford" <> wrote in message
    news:%...
    > Thanks Ray for your advice. I do not see the Security tab, but do have

    NTFS,
    > so followed your advice - but still no joy.


    I think it may have something to do with the "use simple file sharing"
    option in Windows Explorer's tools--options, but I cannot say for sure. All
    the XP machines that I use are in domains, and when you join a domain when
    installing XP, it sets things up a bit more "professionaly." I suggest
    asking in an XP forum something along the lines of:

    I have XP Pro and my drive is formated in NTFS. But when I pull up the
    properties of a folder, the security tab is not displayed. How do I get it
    to display?


    >
    > Even after the recommended changes, when I go to the data directory in Win
    > Explorer, and go to Properties the read-only attibute is set. It

    un-checks,
    > but doesnt take - it is still checked if I go there again. Just drives you
    > mad.


    That's different.


    >
    > Also, In Explorer, if I go to the db properties of the db in the data
    > directory, it tells me the file will open with ACCESS for windows (does

    the
    > IIS server side use the same ACCESS as client side in offline situation

    like
    > this?).


    That just indicates what application is registered for the .mdb extension on
    your machine. On the IIS server, ADO is what is used to access the
    database.


    > Anyway, the db which is working on-line in in ACCESS 97 format, so I
    > upgraded the offline version to ACCESS 2000, and it will now neither read
    > nor write...tells me I dont have permission, even tho the DSN is no system
    > database. If I try to look at permissions on this 2000 db, ut tells me I
    > have no permission - "records cannot be read: no read permission on
    > Msysaccounts"



    I don't know what that's about... Are you using one of those "workgroup"
    databases or whatever? But also, drop the DSN and use an OLEDB connection
    string to connect to your Access DB. See the OLEDB strings for Access at
    www.connectionstrings.com.



    > It all drives you mad - never had these problems with win 98 and PWS - all

    I
    > want to do is write to my own data.


    The same thing that is causing these problems in XP is the same thing that
    makes XP (and NT lines) a far superior operating system. File permissions
    are crucial.


    > I quite understand if you dont wish to continue with this, but if you dont
    > mind, any further advice would be gratefull accepted. What is the best
    > resource to learn about WIN XP/IIS management?


    The Internet. :p
    www.iisfaq.com is a good site. Hopefully you've already discovered
    www.aspfaq.com. There are some XP newsgroups, but it's like the NYSE in
    there. There are sixteen million people all shouting at the same time
    hoping to be heard. It's insane. I'm more partial to
    .

    Ray at home
     
    Ray at, Jan 15, 2004
    #9
  10. Hugh Welford

    hugh Welford Guest

    Thanks a million, Ray...you are a star.

    Hugh




    "Ray at <%=sLocation%>" <myFirstNameATlane34dotKOMM> wrote in message
    news:#...
    >
    > "hugh Welford" <> wrote in message
    > news:%...
    > > Thanks Ray for your advice. I do not see the Security tab, but do have

    > NTFS,
    > > so followed your advice - but still no joy.

    >
    > I think it may have something to do with the "use simple file sharing"
    > option in Windows Explorer's tools--options, but I cannot say for sure.

    All
    > the XP machines that I use are in domains, and when you join a domain when
    > installing XP, it sets things up a bit more "professionaly." I suggest
    > asking in an XP forum something along the lines of:
    >
    > I have XP Pro and my drive is formated in NTFS. But when I pull up the
    > properties of a folder, the security tab is not displayed. How do I get

    it
    > to display?
    >
    >
    > >
    > > Even after the recommended changes, when I go to the data directory in

    Win
    > > Explorer, and go to Properties the read-only attibute is set. It

    > un-checks,
    > > but doesnt take - it is still checked if I go there again. Just drives

    you
    > > mad.

    >
    > That's different.
    >
    >
    > >
    > > Also, In Explorer, if I go to the db properties of the db in the data
    > > directory, it tells me the file will open with ACCESS for windows (does

    > the
    > > IIS server side use the same ACCESS as client side in offline situation

    > like
    > > this?).

    >
    > That just indicates what application is registered for the .mdb extension

    on
    > your machine. On the IIS server, ADO is what is used to access the
    > database.
    >
    >
    > > Anyway, the db which is working on-line in in ACCESS 97 format, so I
    > > upgraded the offline version to ACCESS 2000, and it will now neither

    read
    > > nor write...tells me I dont have permission, even tho the DSN is no

    system
    > > database. If I try to look at permissions on this 2000 db, ut tells me I
    > > have no permission - "records cannot be read: no read permission on
    > > Msysaccounts"

    >
    >
    > I don't know what that's about... Are you using one of those "workgroup"
    > databases or whatever? But also, drop the DSN and use an OLEDB connection
    > string to connect to your Access DB. See the OLEDB strings for Access at
    > www.connectionstrings.com.
    >
    >
    >
    > > It all drives you mad - never had these problems with win 98 and PWS -

    all
    > I
    > > want to do is write to my own data.

    >
    > The same thing that is causing these problems in XP is the same thing that
    > makes XP (and NT lines) a far superior operating system. File permissions
    > are crucial.
    >
    >
    > > I quite understand if you dont wish to continue with this, but if you

    dont
    > > mind, any further advice would be gratefull accepted. What is the best
    > > resource to learn about WIN XP/IIS management?

    >
    > The Internet. :p
    > www.iisfaq.com is a good site. Hopefully you've already discovered
    > www.aspfaq.com. There are some XP newsgroups, but it's like the NYSE in
    > there. There are sixteen million people all shouting at the same time
    > hoping to be heard. It's insane. I'm more partial to
    > .
    >
    > Ray at home
    >
    >
     
    hugh Welford, Jan 15, 2004
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Brian Henry
    Replies:
    1
    Views:
    1,041
    Kevin Spencer
    Jun 25, 2003
  2. Scott Allen
    Replies:
    0
    Views:
    440
    Scott Allen
    Jul 13, 2004
  3. Dariusz Tomon

    ASP and ASPNET on IIS5 and IIS6

    Dariusz Tomon, Mar 16, 2006, in forum: ASP .Net
    Replies:
    0
    Views:
    415
    Dariusz Tomon
    Mar 16, 2006
  4. Curt K
    Replies:
    0
    Views:
    565
    Curt K
    Nov 3, 2006
  5. Lars
    Replies:
    1
    Views:
    144
    Jeff Cochran
    Jan 8, 2005
Loading...

Share This Page