IIS6 Web Site deployment

Discussion in 'ASP .Net' started by Pete Griffiths`, Oct 22, 2004.

  1. Hi,

    I have been working on an asp.net (1.1) app - developing against a virtual
    folder in "personal web server". I have successfully deployed it to an IIS6
    virtual folder, but when I try and deploy to a web site in IIS6, I get "The
    page cannot be displayed" errors. Any ideas? And - am I correct in thinking
    that when I publish to my ISP, they will deploy it in a discrete web site,
    rather than a virtual folder? I guess I'm a little confused over what
    virtual folders are all about...

    Thanks,

    Pete Griffiths
    Pete Griffiths`, Oct 22, 2004
    #1
    1. Advertising

  2. Pete Griffiths`

    Tony Fonager Guest

    I am not 100% sure, but depending on how the IIS is configured, are you sure
    it is looking for "default.aspx" (or whatever is your default page) in the
    list of "documents" on the IIS website configuration page ?

    And have you added ASP.NET under "Web Server Extensions" in the IIS control
    panel ?


    Regards,
    Tony Fonager
    Tony Fonager, Oct 22, 2004
    #2
    1. Advertising

  3. Also, make sure that the directory/virtual folder is set as an "Application"
    in IIS.

    In IIS, right click the directory and click Properties. Under Application
    Settings on the Directory tab, there is a button to "Create" an application
    for that directory.

    HTH


    Dan

    "Tony Fonager" wrote:

    > I am not 100% sure, but depending on how the IIS is configured, are you sure
    > it is looking for "default.aspx" (or whatever is your default page) in the
    > list of "documents" on the IIS website configuration page ?
    >
    > And have you added ASP.NET under "Web Server Extensions" in the IIS control
    > panel ?
    >
    >
    > Regards,
    > Tony Fonager
    >
    >
    >
    =?Utf-8?B?RGFuIE5hc2g=?=, Oct 22, 2004
    #3
  4. Thanks guys,

    In the event it was an easy solution - there was a path problem in my code

    Pete

    "Dan Nash" <> wrote in message
    news:...
    > Also, make sure that the directory/virtual folder is set as an
    > "Application"
    > in IIS.
    >
    > In IIS, right click the directory and click Properties. Under Application
    > Settings on the Directory tab, there is a button to "Create" an
    > application
    > for that directory.
    >
    > HTH
    >
    >
    > Dan
    >
    > "Tony Fonager" wrote:
    >
    >> I am not 100% sure, but depending on how the IIS is configured, are you
    >> sure
    >> it is looking for "default.aspx" (or whatever is your default page) in
    >> the
    >> list of "documents" on the IIS website configuration page ?
    >>
    >> And have you added ASP.NET under "Web Server Extensions" in the IIS
    >> control
    >> panel ?
    >>
    >>
    >> Regards,
    >> Tony Fonager
    >>
    >>
    >>
    Pete Griffiths`, Oct 22, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark
    Replies:
    1
    Views:
    363
  2. sandeep pandit via .NET 247
    Replies:
    0
    Views:
    898
    sandeep pandit via .NET 247
    Apr 28, 2004
  3. Benny Ng
    Replies:
    0
    Views:
    4,409
    Benny Ng
    Oct 3, 2005
  4. Stuart Ferguson

    Web Site Deployment

    Stuart Ferguson, Oct 7, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    401
    S. Justin Gengo
    Oct 7, 2005
  5. Cirene
    Replies:
    4
    Views:
    958
    Cirene
    May 8, 2008
Loading...

Share This Page