IIS7: *.aspx = 404

Discussion in 'ASP .Net' started by Paul Prewett, Feb 28, 2008.

  1. Paul Prewett

    Paul Prewett Guest

    ============================
    Sorry for the double post - I was posting under the wrong alias on the
    previous post. Please reply to this one. Thanks.
    ============================


    ~~~Update - ISAPI and CGI Restrictions show ASP.NET v2 as "Allowed"


    I have a new machine with Vista Ultimate x64 installed. I'm coming from an
    XP Pro x86 and I'm trying to get my development websites running on the new
    machine.

    IIS7 installed with no errors including ASP.NET, Windows Authentication, and
    all of the IIS 6 Compat items. If I browse to http://localhost, I get the
    nice welcome message. If I drop an htm file on the root, I can browse it no
    problem. When I attempt to browse any aspx file, I get a 404. The 404 is
    coming from .NET (i.e. it's the "Server Error in '/' Application" error) so
    I know I'm getting at least as far as the framework.

    The application pool is set to run Classic Managed Pipeline Mode. Identity
    of the app pool is Network Service. Framework version 2.0.

    I have run aspnet_regiis -u, -i, etc... until I'm blue in the face. It
    seems that the only one that works well is the one in the Framework64
    folder, which I guess is to be expected. When I try to run the one in the
    regular Framework folder, I get a message that tells me that IIS is not
    installed.

    I have uninstalled IIS altogether, rebooted, reinstalled, rebooted, and then
    rerun the aspnet_regiis again... still no love. I get exactly the same
    behavior no matter what I do.

    I even tried reinstalling the .NET Framework 2.0 altogether, but Vista64
    disallowed that saying that it was already installed as part of the OS.

    What am I missing, folks? Thanks for any direction you can provide.


    --
    -Paul Prewett
     
    Paul Prewett, Feb 28, 2008
    #1
    1. Advertising

  2. Paul Prewett

    Scott M. Guest

    Re: *.aspx = 404

    Inline....

    "Paul Prewett" <> wrote in message
    news:...
    > ============================
    > Sorry for the double post - I was posting under the wrong alias on the
    > previous post. Please reply to this one. Thanks.
    > ============================
    >
    >
    > ~~~Update - ISAPI and CGI Restrictions show ASP.NET v2 as "Allowed"
    >
    >
    > I have a new machine with Vista Ultimate x64 installed. I'm coming from
    > an
    > XP Pro x86 and I'm trying to get my development websites running on the
    > new
    > machine.
    >
    > IIS7 installed with no errors including ASP.NET, Windows Authentication,
    > and
    > all of the IIS 6 Compat items. If I browse to http://localhost, I get the
    > nice welcome message. If I drop an htm file on the root, I can browse it
    > no
    > problem. When I attempt to browse any aspx file, I get a 404.
    > The 404 is coming from .NET


    The .NET Framework does not send http 400 level messages, this messge is
    from IIS.

    > (i.e. it's the "Server Error in '/' Application" error) so
    > I know I'm getting at least as far as the framework.


    If it's a "Server Error", then it's not a 404 error, it's a 500 level error,
    which indicate problems with your server code.

    >
    > The application pool is set to run Classic Managed Pipeline Mode.
    > Identity
    > of the app pool is Network Service. Framework version 2.0.
    >
    > I have run aspnet_regiis -u, -i, etc... until I'm blue in the face. It
    > seems that the only one that works well is the one in the Framework64
    > folder, which I guess is to be expected. When I try to run the one in the
    > regular Framework folder, I get a message that tells me that IIS is not
    > installed.
    >
    > I have uninstalled IIS altogether, rebooted, reinstalled, rebooted, and
    > then
    > rerun the aspnet_regiis again... still no love. I get exactly the same
    > behavior no matter what I do.
    >
    > I even tried reinstalling the .NET Framework 2.0 altogether, but Vista64
    > disallowed that saying that it was already installed as part of the OS.
    >
    > What am I missing, folks? Thanks for any direction you can provide.


    Check to make sure that the directory has a default document enabled and
    that "Default.aspx" is on the list of default documents.

    >
    >
    > --
    > -Paul Prewett
     
    Scott M., Feb 28, 2008
    #2
    1. Advertising

  3. Paul Prewett

    Paul Prewett Guest

    Re: *.aspx = 404

    --
    -Paul Prewett


    "Scott M." wrote:

    > Inline....
    >
    > "Paul Prewett" <> wrote in message
    > news:...
    > > ============================
    > > Sorry for the double post - I was posting under the wrong alias on the
    > > previous post. Please reply to this one. Thanks.
    > > ============================
    > >
    > >
    > > ~~~Update - ISAPI and CGI Restrictions show ASP.NET v2 as "Allowed"
    > >
    > >
    > > I have a new machine with Vista Ultimate x64 installed. I'm coming from
    > > an
    > > XP Pro x86 and I'm trying to get my development websites running on the
    > > new
    > > machine.
    > >
    > > IIS7 installed with no errors including ASP.NET, Windows Authentication,
    > > and
    > > all of the IIS 6 Compat items. If I browse to http://localhost, I get the
    > > nice welcome message. If I drop an htm file on the root, I can browse it
    > > no
    > > problem. When I attempt to browse any aspx file, I get a 404.
    > > The 404 is coming from .NET

    >
    > The .NET Framework does not send http 400 level messages, this messge is
    > from IIS.


    Here is a screenshot of the error:
    http://test.cmiresearch.com/paul/404error.jpg

    The description says HTTP 404.


    >
    > > (i.e. it's the "Server Error in '/' Application" error) so
    > > I know I'm getting at least as far as the framework.

    >
    > If it's a "Server Error", then it's not a 404 error, it's a 500 level error,
    > which indicate problems with your server code.


    This code runs fine under the IIS5 installation on the XP Pro machine. In
    fact, you can put a completely empty page, name it aspx, and the 404 will be
    returned. I'm sure that the problem here is some missing plumbing somewhere
    rather than the code.

    >
    > >
    > > The application pool is set to run Classic Managed Pipeline Mode.
    > > Identity
    > > of the app pool is Network Service. Framework version 2.0.
    > >
    > > I have run aspnet_regiis -u, -i, etc... until I'm blue in the face. It
    > > seems that the only one that works well is the one in the Framework64
    > > folder, which I guess is to be expected. When I try to run the one in the
    > > regular Framework folder, I get a message that tells me that IIS is not
    > > installed.
    > >
    > > I have uninstalled IIS altogether, rebooted, reinstalled, rebooted, and
    > > then
    > > rerun the aspnet_regiis again... still no love. I get exactly the same
    > > behavior no matter what I do.
    > >
    > > I even tried reinstalling the .NET Framework 2.0 altogether, but Vista64
    > > disallowed that saying that it was already installed as part of the OS.
    > >
    > > What am I missing, folks? Thanks for any direction you can provide.

    >
    > Check to make sure that the directory has a default document enabled and
    > that "Default.aspx" is on the list of default documents.


    Well, the default.aspx document is listed and enabled, but I'm not trying to
    access a directory or leaning on the default document in any way. I'm
    attempting direct access to the page. In the case of the screenshot, the url
    entered was:
    http://localhost/testemail.aspx


    >
    > >
    > >
    > > --
    > > -Paul Prewett

    >
    >


    Any other ideas?
     
    Paul Prewett, Feb 29, 2008
    #3
  4. Paul Prewett

    Paul Prewett Guest

    Re: *.aspx = 404

    Just got this sorted out.

    I run a separate program drive from my system drive. I added a ProgramDrive
    environment variable, and because the default location of the website was
    %SystemDrive%\Inetpub\wwwroot, I tried replacing that with
    %ProgramDrive%\Inetpub\wwwroot.

    That was what was causing me my issues. I changed it to D:\Inetpub\wwwroot,
    and all is now well. I can't say I understand why the %ProgramDrive% didn't
    work. If I type that into a Start->Run, it opens D:\ just as sure as
    %SystemDrive% opens C:\

    Oh well.



    --
    -Paul Prewett


    "Paul Prewett" wrote:

    >
    > --
    > -Paul Prewett
    >
    >
    > "Scott M." wrote:
    >
    > > Inline....
    > >
    > > "Paul Prewett" <> wrote in message
    > > news:...
    > > > ============================
    > > > Sorry for the double post - I was posting under the wrong alias on the
    > > > previous post. Please reply to this one. Thanks.
    > > > ============================
    > > >
    > > >
    > > > ~~~Update - ISAPI and CGI Restrictions show ASP.NET v2 as "Allowed"
    > > >
    > > >
    > > > I have a new machine with Vista Ultimate x64 installed. I'm coming from
    > > > an
    > > > XP Pro x86 and I'm trying to get my development websites running on the
    > > > new
    > > > machine.
    > > >
    > > > IIS7 installed with no errors including ASP.NET, Windows Authentication,
    > > > and
    > > > all of the IIS 6 Compat items. If I browse to http://localhost, I get the
    > > > nice welcome message. If I drop an htm file on the root, I can browse it
    > > > no
    > > > problem. When I attempt to browse any aspx file, I get a 404.
    > > > The 404 is coming from .NET

    > >
    > > The .NET Framework does not send http 400 level messages, this messge is
    > > from IIS.

    >
    > Here is a screenshot of the error:
    > http://test.cmiresearch.com/paul/404error.jpg
    >
    > The description says HTTP 404.
    >
    >
    > >
    > > > (i.e. it's the "Server Error in '/' Application" error) so
    > > > I know I'm getting at least as far as the framework.

    > >
    > > If it's a "Server Error", then it's not a 404 error, it's a 500 level error,
    > > which indicate problems with your server code.

    >
    > This code runs fine under the IIS5 installation on the XP Pro machine. In
    > fact, you can put a completely empty page, name it aspx, and the 404 will be
    > returned. I'm sure that the problem here is some missing plumbing somewhere
    > rather than the code.
    >
    > >
    > > >
    > > > The application pool is set to run Classic Managed Pipeline Mode.
    > > > Identity
    > > > of the app pool is Network Service. Framework version 2.0.
    > > >
    > > > I have run aspnet_regiis -u, -i, etc... until I'm blue in the face. It
    > > > seems that the only one that works well is the one in the Framework64
    > > > folder, which I guess is to be expected. When I try to run the one in the
    > > > regular Framework folder, I get a message that tells me that IIS is not
    > > > installed.
    > > >
    > > > I have uninstalled IIS altogether, rebooted, reinstalled, rebooted, and
    > > > then
    > > > rerun the aspnet_regiis again... still no love. I get exactly the same
    > > > behavior no matter what I do.
    > > >
    > > > I even tried reinstalling the .NET Framework 2.0 altogether, but Vista64
    > > > disallowed that saying that it was already installed as part of the OS.
    > > >
    > > > What am I missing, folks? Thanks for any direction you can provide.

    > >
    > > Check to make sure that the directory has a default document enabled and
    > > that "Default.aspx" is on the list of default documents.

    >
    > Well, the default.aspx document is listed and enabled, but I'm not trying to
    > access a directory or leaning on the default document in any way. I'm
    > attempting direct access to the page. In the case of the screenshot, the url
    > entered was:
    > http://localhost/testemail.aspx
    >
    >
    > >
    > > >
    > > >
    > > > --
    > > > -Paul Prewett

    > >
    > >

    >
    > Any other ideas?
     
    Paul Prewett, Feb 29, 2008
    #4
  5. On Oct 3, 6:04 pm, bhuvi<> wrote:
    > sir.... iam having the same problem of http 404 server not found error... while running the asp
    >
    > what i can do
    >
    > please reply me sir...
    >
    > Fromhttp://www.developmentnow.com/g/8_2008_2_0_0_1049109/IIS7-aspx-404.htm
    >
    > Posted via DevelopmentNow.com Groupshttp://www.developmentnow.com/g/


    To install classic ASP go to Control Panel/Programs/Windows Features/
    Internet Information Services/Www services/Application Development
    Features/ASP
     
    Alexey Smirnov, Oct 5, 2009
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jonathan Folland
    Replies:
    2
    Views:
    1,697
    Jonathan Folland
    Mar 17, 2005
  2. John M
    Replies:
    1
    Views:
    1,301
    Kumar Reddi
    May 29, 2005
  3. frekster
    Replies:
    1
    Views:
    987
    frekster
    Sep 14, 2005
  4. Paul Prewett

    IIS7: *.asp = 404

    Paul Prewett, Feb 28, 2008, in forum: ASP .Net
    Replies:
    1
    Views:
    528
    Paul Prewett
    Feb 28, 2008
  5. Juan Marcial
    Replies:
    5
    Views:
    2,251
    Juan T. Llibre
    Dec 13, 2008
Loading...

Share This Page