ImageUrlEditor - why can't i find it?

Discussion in 'ASP .Net' started by SilentCry, May 1, 2009.

  1. SilentCry

    SilentCry Guest

    i have this attribute assigned to the default property of my custom
    control..

    [UrlProperty("*.xml"),
    EditorAttribute(typeof(ImageUrlEditor),typeof(UITypeEditor))]

    got a compile error on ImageUrlEditor saying i may be missing a reference.
    when i go into help, the documentation says ImageUrlEditor is part of the
    System.Web.UI.Design namespace. i add that in a using stmt but now the
    namespace isn't found either. ok, fine i'm missing a reference/dll. i go
    into the object browser and do a search on System.Web.UI.Design where i find
    it in System.Web.Extensions.Design.dll. i then add that guy as a reference
    but i'm still getting errors on ImageUrlEditor (and UITypeEditor). what's
    going on here? i got everything i need included either as a reference or a
    using but still getting the errors.

    i'm using VS 2008 and have the 3.5 framework.
    SilentCry, May 1, 2009
    #1
    1. Advertising

  2. SilentCry

    dan Guest

    Maybe because you are too busy cross-posting?

    "SilentCry" <> wrote in message
    news:...
    >i have this attribute assigned to the default property of my custom
    >control..
    >
    > [UrlProperty("*.xml"),
    > EditorAttribute(typeof(ImageUrlEditor),typeof(UITypeEditor))]
    >
    > got a compile error on ImageUrlEditor saying i may be missing a reference.
    > when i go into help, the documentation says ImageUrlEditor is part of the
    > System.Web.UI.Design namespace. i add that in a using stmt but now the
    > namespace isn't found either. ok, fine i'm missing a reference/dll. i go
    > into the object browser and do a search on System.Web.UI.Design where i
    > find it in System.Web.Extensions.Design.dll. i then add that guy as a
    > reference but i'm still getting errors on ImageUrlEditor (and
    > UITypeEditor). what's going on here? i got everything i need included
    > either as a reference or a using but still getting the errors.
    >
    > i'm using VS 2008 and have the 3.5 framework.
    dan, May 1, 2009
    #2
    1. Advertising

  3. SilentCry

    dan Guest

    Replied in microsoft.public.dotnet.framework.aspnet

    "SilentCry" <> wrote in message
    news:...
    >i have this attribute assigned to the default property of my custom
    >control..
    >
    > [UrlProperty("*.xml"),
    > EditorAttribute(typeof(ImageUrlEditor),typeof(UITypeEditor))]
    >
    > got a compile error on ImageUrlEditor saying i may be missing a reference.
    > when i go into help, the documentation says ImageUrlEditor is part of the
    > System.Web.UI.Design namespace. i add that in a using stmt but now the
    > namespace isn't found either. ok, fine i'm missing a reference/dll. i go
    > into the object browser and do a search on System.Web.UI.Design where i
    > find it in System.Web.Extensions.Design.dll. i then add that guy as a
    > reference but i'm still getting errors on ImageUrlEditor (and
    > UITypeEditor). what's going on here? i got everything i need included
    > either as a reference or a using but still getting the errors.
    >
    > i'm using VS 2008 and have the 3.5 framework.
    dan, May 1, 2009
    #3
  4. SilentCry

    SilentCry Guest

    so i guess you don't know the answer then eh? maybe you're too busy being a
    jerk. in case you didn't notice, i refered to both namespaces and references
    in the question - both of which are related to asp.net specifically. and
    btw, you're reply went to all 3 ng's as well.

    "dan" <> wrote in message
    news:%...
    > Replied in microsoft.public.dotnet.framework.aspnet
    >
    > "SilentCry" <> wrote in message
    > news:...
    >>i have this attribute assigned to the default property of my custom
    >>control..
    >>
    >> [UrlProperty("*.xml"),
    >> EditorAttribute(typeof(ImageUrlEditor),typeof(UITypeEditor))]
    >>
    >> got a compile error on ImageUrlEditor saying i may be missing a
    >> reference. when i go into help, the documentation says ImageUrlEditor is
    >> part of the System.Web.UI.Design namespace. i add that in a using stmt
    >> but now the namespace isn't found either. ok, fine i'm missing a
    >> reference/dll. i go into the object browser and do a search on
    >> System.Web.UI.Design where i find it in System.Web.Extensions.Design.dll.
    >> i then add that guy as a reference but i'm still getting errors on
    >> ImageUrlEditor (and UITypeEditor). what's going on here? i got everything
    >> i need included either as a reference or a using but still getting the
    >> errors.
    >>
    >> i'm using VS 2008 and have the 3.5 framework.

    >
    >
    SilentCry, May 1, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?c2FyYQ==?=

    ImageUrlEditor

    =?Utf-8?B?c2FyYQ==?=, Dec 5, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    408
    =?Utf-8?B?c2FyYQ==?=
    Dec 5, 2004
  2. =?Utf-8?B?c2FyYQ==?=

    ImageUrlEditor

    =?Utf-8?B?c2FyYQ==?=, Dec 7, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    377
    =?Utf-8?B?VGFtcGEgLk5FVCBLb2Rlcg==?=
    Dec 7, 2004
  3. =?Utf-8?B?c2FyYQ==?=

    ImageUrlEditor

    =?Utf-8?B?c2FyYQ==?=, Dec 9, 2004, in forum: ASP .Net
    Replies:
    0
    Views:
    494
    =?Utf-8?B?c2FyYQ==?=
    Dec 9, 2004
  4. Mr. SweatyFinger
    Replies:
    2
    Views:
    1,756
    Smokey Grindel
    Dec 2, 2006
  5. SilentCry

    ImageUrlEditor - why can't i find it?

    SilentCry, May 1, 2009, in forum: ASP .Net Web Controls
    Replies:
    5
    Views:
    681
    SilentCry
    May 23, 2009
Loading...

Share This Page