Installation of Perl/Tk under Solaris 5.8

Discussion in 'Perl Misc' started by Jamie, Feb 23, 2005.

  1. Jamie

    Jamie Guest

    I tried installing the latest version, but the installation does not
    seem to be correct. We have perl 5.8.5 (recently installed) on the
    system.

    I installed Perl/Tk in my directory /home/jritter/mypm/Tk-804.027.
    Then I did
    a cd to that directory and performed the following steps:
    ===================================================================
    perl Makefile.PL PREFIX=/home/jritter/mypm/myTk <=== Succeeded
    make <=== Succeeded

    make test

    o
    o
    o

    t/Require....................ok 84/94
    Tk/JPEG.pm: Can't load
    '/home/jritter/mypm/Tk-804.027/blib/arch/auto/Tk/JPEG/JPEG.so' for
    module Tk::JPEG: ld.so.1: /usr/local/bin/perl: fatal: relocation error:
    file /home/jritter/mypm/Tk-804.027/blib/arch/auto/Tk/JPEG/JPEG.so:
    symbol jpeg_write_raw_data: referenced symbol not found at
    /usr/local/lib/perl5/5.8.5/sun4-solaris/DynaLoader.pm line 230.
    at t/Require.t line 20
    at /usr/local/lib/perl5/5.8.5/sun4-solaris/DynaLoader.pm line 118
    DynaLoader::croak('Can\'t load
    \'/home/jritter/mypm/Tk-804.027/blib/arch/auto/Tk...') called at
    /usr/local/lib/perl5/5.8.5/sun4-solaris/DynaLoader.pm line 230
    DynaLoader::bootstrap('Tk::JPEG') called at
    /home/jritter/mypm/Tk-804.027/blib/lib/Tk/JPEG.pm line 16
    require Tk/JPEG.pm called at t/Require.t line 20
    eval {...} called at t/Require.t line 20
    Compilation failed in require at t/Require.t line 20.
    at t/Require.t line 20
    eval {...} called at t/Require.t line 20
    t/Require....................FAILED test 85

    Failed 1/94 tests, 98.94% okay

    o
    o
    o

    (3 subtests UNEXPECTEDLY SUCCEEDED), 2 tests and 23 subtests skipped.
    Failed 1/47 test scripts, 97.87% okay. 1/2040 subtests failed, 99.95%
    okay.
    *** Error code 29
    make: Fatal error: Command failed for target `test_dynamic'
    ===================================================================

    When I tried to run my own Perl/Tk script, runMemMap (which ran fine
    with the older version of Perl/Tk), I got the following results:

    osumi:/home/jritter/ssp/build/build4/test [ 88 ] ~/scripts2/runMemMap &
    [1] 16009
    osumi:/home/jritter/ssp/build/build4/test [ 89 ] Can't locate loadable
    object for module Tk::Event in @INC
    (@INC contains: /home/jritter/scripts2
    /home/jritter/mypm/Tk-804.027
    /usr/local/lib/perl5/5.8.5/sun4-solaris
    /usr/local/lib/perl5/5.8.5
    /usr/local/lib/perl5/site_perl/5.8.5/sun4-solaris
    /usr/local/lib/perl5/site_perl/5.8.5
    /usr/local/lib/perl5/site_perl .)
    at /home/jritter/scripts2/Tk.pm line 13
    Compilation failed in require at /home/jritter/scripts2/Tk.pm line 13.
    BEGIN failed--compilation aborted at /home/jritter/scripts2/Tk.pm line
    13.
    Compilation failed in require at /home/jritter/scripts2/runMemMap line
    53.
    BEGIN failed--compilation aborted at /home/jritter/scripts2/runMemMap
    line 53.
    Undefined subroutine &Tk::Event::CleanupGlue called at
    /home/jritter/scripts2/Tk/Event.pm line 3.
    END failed--call queue aborted at /home/jritter/scripts2/runMemMap line
    53.



    I then tried to run the basic_demo against the Sas installation as
    follows:

    basic_demo
    Can't locate Tk/Event.pm in @INC
    (@INC contains: /usr/local/lib/perl5/5.8.5/sun4-solaris
    /usr/local/lib/perl5/5.8.5
    /usr/local/lib/perl5/site_perl/5.8.5/sun4-solaris
    /usr/local/lib/perl5/site_perl/5.8.5
    /usr/local/lib/perl5/site_perl .)
    at Tk.pm line 13.
    BEGIN failed--compilation aborted at Tk.pm line 13.
    Compilation failed in require at basic_demo line 12.
    BEGIN failed--compilation aborted at basic_demo line 12.


    Can you help???

    Thanx,

    Jamie

    James W Ritter
     
    Jamie, Feb 23, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Madhu R. Vajrala

    Python Installation error on Solaris-9-SPARC

    Madhu R. Vajrala, Jul 14, 2005, in forum: Python
    Replies:
    5
    Views:
    1,888
    Madhu R. Vajrala
    Jul 14, 2005
  2. Venkat
    Replies:
    0
    Views:
    274
    Venkat
    Mar 2, 2007
  3. Replies:
    6
    Views:
    254
    Gerardo Santana Gómez Garrido
    Oct 13, 2007
  4. daveo
    Replies:
    0
    Views:
    155
    daveo
    Mar 21, 2005
  5. kumar
    Replies:
    0
    Views:
    91
    kumar
    Mar 20, 2007
Loading...

Share This Page