Installing arch-specific PM without shell access

Discussion in 'Perl Misc' started by Travis Spencer, May 9, 2008.

  1. Good Morning All,

    I am hosting my Web site with Yahoo! small business services. I need
    to get a few Perl modules installed that use compiled C code. I don't
    have shell access, however, so I'm having a real hard time. I tried
    the suggestion at [1]. The problem is that Yahoo! has done things to
    cripple Perl-based CGI scripts, preventing that tact from working.

    Since that didn't work, I tried to figure out what OS and hardware
    architecture the Web server is running with the hopes that I could
    find a pre-compiled binary version of the Perl modules I need. To
    this end, I ran this script on the server:

    #!/usr/bin/perl -w

    use POSIX "uname";
    use strict;

    my ($sysname, $nodename, $release, $version, $machine ) = uname;

    print "Content-type: text/plain\n\n";

    print "System = $sysname\n";
    print "Hostname = $nodename\n";
    print "OS Release = $release\n";
    print "OS Version = $version\n";
    print "Machine Type = $machine\n";

    (Using `uname -a` didn't work for similar reasons as above.) This
    produced the following output:

    System = FreeBSD
    Hostname = travisspencer.com
    OS Release = 4.11-YAHOO-20061130
    OS Version = FreeBSD 4.11-YAHOO-20061130 #0:
    Machine Type = i386

    From this, I figured that Yahoo! was running FreeBSD 4.11 on an i386
    machine. So, I went to http://ftp2.tsinghua.edu.cn/pub/mirror/FreeBSD/ports/i386/packages-4.11-release/Latest/
    and downloaded the necessary modules. I unpacked and uploaded the
    contents, but when I tried to import the module, I got this error:

    Can't load '/blog-mt/extlib/auto/Digest/SHA1/SHA1.so' for module
    Digest::SHA1: Cannot execute objects on /p12/m/b28
    at /foo/test.cgi line 5
    Compilation failed in require at /foo/test.cgi line 5.

    So, the dynamically loaded library can't be imported it seems but the
    Perl module I uploaded is found in my search path.

    Any ideas on how I might get this working?

    --

    Regards,

    Travis Spencer

    [1] http://www.perlmonks.org/?node_id=422458
    Travis Spencer, May 9, 2008
    #1
    1. Advertising

  2. On May 9, 11:39 am, smallpond <> wrote:
    > Travis Spencer wrote:
    > > I am hosting my Web site with Yahoo! small business services.

    >
    > I think I found your problem.


    Not helpful.

    --

    Regards,

    Travis Spencer
    Travis Spencer, May 10, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RHIuIFBhdWwgQ2Flc2FyIC0gQ291bGxCeXRlIChV

    ASP.NET 1.1 VERSION ON WIN SERVER 2003 SP1 & VS 2003 Arch.

    =?Utf-8?B?RHIuIFBhdWwgQ2Flc2FyIC0gQ291bGxCeXRlIChV, Apr 30, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    581
    Aquila Deus
    Apr 30, 2005
  2. =?ISO-8859-1?Q?Gustavo_C=F3rdova_Avila?=

    Anybody using Arch?

    =?ISO-8859-1?Q?Gustavo_C=F3rdova_Avila?=, Nov 29, 2004, in forum: Python
    Replies:
    0
    Views:
    279
    =?ISO-8859-1?Q?Gustavo_C=F3rdova_Avila?=
    Nov 29, 2004
  3. Christopher Taylor

    Python RPM package arch compatability

    Christopher Taylor, Oct 18, 2006, in forum: Python
    Replies:
    0
    Views:
    228
    Christopher Taylor
    Oct 18, 2006
  4. Replies:
    1
    Views:
    551
    Paul Rubin
    Oct 23, 2006
  5. The Duke of Dunstable

    Installing a cgi script without shell access

    The Duke of Dunstable, Feb 14, 2005, in forum: Perl Misc
    Replies:
    1
    Views:
    167
    Tintin
    Feb 14, 2005
Loading...

Share This Page