Integrated Windows authentiation does not working

Discussion in 'ASP .Net Security' started by WiZARD, Feb 4, 2006.

  1. WiZARD

    WiZARD Guest

    content of web.config file(briefly) -------
    <Admins>
    <add key="EXPLORER\Administrator" value=""/>
    <add key="EXPLORER\Administrators" value=""/>
    <add key="EXPLORER\Debugger Users" value=""/>
    </Admins>
    ......
    <authentication mode="Windows" />
    <authorization>
    <allow users="*" />
    </authorization>
    --------------------------------------------------------------

    Web Application used Integrated Windows authentiation.

    In debug (VisualStudio 2003) I see next:
    ------------------------------------------
    AuthenticationType ""
    IsAuthenticated false
    Name ""
    HttpContext.Current.User.Identity.IsAuthenticated false

    AuthenticationType "" string
    IsAnonymous true bool
    IsAuthenticated false bool
    IsGuest false bool
    IsSystem false bool
    m_acctType Anonymous System.Security.Principal.WindowsAccountType
    m_isAuthenticated false bool
    --------------------------------------------------
    Seems what Integrated Windows authentiation does not working.
    QUESTION:
    How can I solve this problem?
    Thanks in advice.
    WiZARD, Feb 4, 2006
    #1
    1. Advertising

  2. hi,

    have you disabled anonymous authentication in IIS?

    ---------------------------------------
    Dominick Baier - DevelopMentor
    http://www.leastprivilege.com

    > content of web.config file(briefly) -------
    > <Admins>
    > <add key="EXPLORER\Administrator" value=""/>
    > <add key="EXPLORER\Administrators" value=""/>
    > <add key="EXPLORER\Debugger Users" value=""/>
    > </Admins>
    > .....
    > <authentication mode="Windows" />
    > <authorization>
    > <allow users="*" />
    > </authorization>
    > --------------------------------------------------------------
    >
    > Web Application used Integrated Windows authentiation.
    >
    > In debug (VisualStudio 2003) I see next:
    > ------------------------------------------
    > AuthenticationType ""
    > IsAuthenticated false
    > Name ""
    > HttpContext.Current.User.Identity.IsAuthenticated false
    > AuthenticationType "" string
    > IsAnonymous true bool
    > IsAuthenticated false bool
    > IsGuest false bool
    > IsSystem false bool
    > m_acctType Anonymous
    > System.Security.Principal.WindowsAccountType
    > m_isAuthenticated false bool
    > --------------------------------------------------
    > Seems what Integrated Windows authentiation does not working.
    > QUESTION:
    > How can I solve this problem?
    > Thanks in advice.
    Dominick Baier [DevelopMentor], Feb 4, 2006
    #2
    1. Advertising

  3. To add to Dominicks advice
    You will need to disble anonymous in IIS to get things started.
    Patrick

    "Dominick Baier [DevelopMentor]" <>
    wrote in message news:...
    > hi,
    > have you disabled anonymous authentication in IIS?
    >
    > ---------------------------------------
    > Dominick Baier - DevelopMentor
    > http://www.leastprivilege.com
    >
    >> content of web.config file(briefly) -------
    >> <Admins>
    >> <add key="EXPLORER\Administrator" value=""/>
    >> <add key="EXPLORER\Administrators" value=""/>
    >> <add key="EXPLORER\Debugger Users" value=""/>
    >> </Admins>
    >> .....
    >> <authentication mode="Windows" />
    >> <authorization>
    >> <allow users="*" />
    >> </authorization>
    >> --------------------------------------------------------------
    >>
    >> Web Application used Integrated Windows authentiation.
    >>
    >> In debug (VisualStudio 2003) I see next:
    >> ------------------------------------------
    >> AuthenticationType ""
    >> IsAuthenticated false
    >> Name ""
    >> HttpContext.Current.User.Identity.IsAuthenticated false
    >> AuthenticationType "" string
    >> IsAnonymous true bool
    >> IsAuthenticated false bool
    >> IsGuest false bool
    >> IsSystem false bool
    >> m_acctType Anonymous
    >> System.Security.Principal.WindowsAccountType
    >> m_isAuthenticated false bool
    >> --------------------------------------------------
    >> Seems what Integrated Windows authentiation does not working.
    >> QUESTION:
    >> How can I solve this problem?
    >> Thanks in advice.

    >
    >
    Patrick.O.Ige, Feb 11, 2006
    #3
  4. WiZARD

    WiZARD Guest

    Thenks for advice.....
    problem solved.
    WiZARD, Feb 12, 2006
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SklNLkgu?=

    Q: integrated windows does not work

    =?Utf-8?B?SklNLkgu?=, Jun 24, 2005, in forum: ASP .Net
    Replies:
    0
    Views:
    321
    =?Utf-8?B?SklNLkgu?=
    Jun 24, 2005
  2. =?Utf-8?B?bnBidWdnaWE=?=

    no timeout in form authentiation

    =?Utf-8?B?bnBidWdnaWE=?=, Feb 16, 2006, in forum: ASP .Net
    Replies:
    3
    Views:
    1,860
    Saber
    Feb 17, 2006
  3. Dariusz Tomon
    Replies:
    3
    Views:
    52,653
    muralikrishna
    Oct 24, 2010
  4. Ken Cooper
    Replies:
    0
    Views:
    309
    Ken Cooper
    Oct 12, 2006
  5. Stephane
    Replies:
    1
    Views:
    1,275
    Stephane
    Oct 10, 2008
Loading...

Share This Page