International character dissapears from FORM

Discussion in 'ASP General' started by royend@gmail.com, Jun 21, 2006.

  1. Guest

    Hi.
    I am having problems sending values from a simple FORM to a database.
    All is written in ASP, and I am doing some validations before it is
    actually saved in my database.

    It worked for several years, but now it won't accept international
    characters. This means that the Norwegian word for boat "BÅT" ends up
    like "BT" since the "Å" isn't sent.

    I have done several testings, and it actually looks like the error
    occurs immidiately after I hit the submit-button.

    Does anybody know why this problem has occured?
    Looking forward to your answers.
    royend...
     
    , Jun 21, 2006
    #1
    1. Advertising

  2. James Jones Guest

    use the character codes, not the actual letter. so when the character is
    posted.....try to convert it......

    <%
    varItsStoredIn = Replace(varItsStoredIn, "Å", "")
    %>


    hope this helps ya.









    <> wrote in message
    news:...
    Hi.
    I am having problems sending values from a simple FORM to a database.
    All is written in ASP, and I am doing some validations before it is
    actually saved in my database.

    It worked for several years, but now it won't accept international
    characters. This means that the Norwegian word for boat "BÅT" ends up
    like "BT" since the "Å" isn't sent.

    I have done several testings, and it actually looks like the error
    occurs immidiately after I hit the submit-button.

    Does anybody know why this problem has occured?
    Looking forward to your answers.
    royend...
     
    James Jones, Jun 21, 2006
    #2
    1. Advertising

  3. Guest

    I have actually tried converting the letters with ASP, but the problem
    is that the string is transformed before it reaches the ASP.

    In my .asp-file I have
    Response.Write(Request.Form("text"))
    as my first line, and it still don't contain the international
    letters....

    I really don't get this one, as I have multiple forms that actually
    does send everything perfect.

    royend :|


    James Jones wrote:
    > use the character codes, not the actual letter. so when the character is
    > posted.....try to convert it......
    >
    > <%
    > varItsStoredIn = Replace(varItsStoredIn, "Å", "")
    > %>
    >
    >
    > hope this helps ya.
    >
     
    , Jun 21, 2006
    #3
  4. Evertjan. Guest

    wrote on 21 jun 2006 in microsoft.public.inetserver.asp.general:

    > James Jones wrote:
    >> use the character codes, not the actual letter. so when the character
    >> is posted.....try to convert it......
    >>
    >> <%
    >> varItsStoredIn = Replace(varItsStoredIn, "Å", "")
    >> %>
    >>

    > I have actually tried converting the letters with ASP, but the problem
    > is that the string is transformed before it reaches the ASP.
    >
    > In my .asp-file I have
    > Response.Write(Request.Form("text"))
    > as my first line, and it still don't contain the international
    > letters....
    >
    > I really don't get this one, as I have multiple forms that actually
    > does send everything perfect.


    I strongly suspect it has to do with the character set used by your
    browser. Try rightclicking on the page in IE and try different
    "encoding"s.

    ASP can set these for you in the header.

    Under ASP try different "code-pages":

    How?
    <http://www.html.dk/dokumentation/objects/asp/iiapmls.htm>

    Baltic:
    <http://www.microsoft.com/globaldev/reference/iso/28594.mspx>

    More:
    <http://www.microsoft.com/globaldev/reference/wincp.mspx>


    --
    Evertjan.
    The Netherlands.
    (Please change the x'es to dots in my emailaddress)
     
    Evertjan., Jun 21, 2006
    #4
  5. Guest

    Thanks for the advice, but still it didn't work. This is a real
    challenge as I need this to get working.

    Another tips for those looking for their LCID-code:
    http://www.microsoft.com/globaldev/reference/lcid-all.mspx

    Still looking for the correct answer to my problem though.
    Thanks for all your tips so far.
    royend:)
     
    , Jun 21, 2006
    #5
  6. Evertjan. Guest

    wrote on 21 jun 2006 in microsoft.public.inetserver.asp.general:

    > Thanks for the advice, but still it didn't work. This is a real
    > challenge as I need this to get working.
    >


    Please quote what you are replying to.

    If you want to post a followup via groups.google.com, don't use the
    "Reply" link at the bottom of the article. Click on "show options" at the
    top of the article, then click on the "Reply" at the bottom of the article
    headers.

    <http://www.safalra.com/special/googlegroupsreply/>

    --
    Evertjan.
    The Netherlands.
    (Please change the x'es to dots in my emailaddress)
     
    Evertjan., Jun 21, 2006
    #6
  7. Guest

    Thanks for your tip!

    Evertjan. wrote:
    > Please quote what you are replying to.
    >
    > If you want to post a followup via groups.google.com, don't use the
    > "Reply" link at the bottom of the article. Click on "show options" at the
    > top of the article, then click on the "Reply" at the bottom of the article
    > headers.
    >
    > <http://www.safalra.com/special/googlegroupsreply/>


    I will use this technique from now on.
    Still, no solution to the problem though...
    royend
     
    , Jun 22, 2006
    #7
  8. Evertjan. Guest

    wrote on 22 jun 2006 in microsoft.public.inetserver.asp.general:

    > Thanks for your tip!
    >
    > Evertjan. wrote:
    >> Please quote what you are replying to.
    >>
    >> If you want to post a followup via groups.google.com, don't use the
    >> "Reply" link at the bottom of the article. Click on "show options" at
    >> the top of the article, then click on the "Reply" at the bottom of
    >> the article headers.
    >>
    >> <http://www.safalra.com/special/googlegroupsreply/>

    >
    > I will use this technique from now on.
    > Still, no solution to the problem though...
    > royend
    >


    What problem? ;-)

    --
    Evertjan.
    The Netherlands.
    (Please change the x'es to dots in my emailaddress)
     
    Evertjan., Jun 22, 2006
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. sy

    international character

    sy, Oct 15, 2003, in forum: ASP .Net
    Replies:
    0
    Views:
    311
  2. =?Utf-8?B?VHJveQ==?=

    user control dissapears from panel on post back

    =?Utf-8?B?VHJveQ==?=, Jan 23, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    485
    Marina
    Jan 23, 2004
  3. Replies:
    1
    Views:
    305
    Jukka K. Korpela
    Jul 4, 2006
  4. Timasmith
    Replies:
    4
    Views:
    655
    Oliver Wong
    Mar 15, 2007
  5. thomas
    Replies:
    2
    Views:
    229
    Ken Cox [Microsoft MVP]
    Mar 7, 2005
Loading...

Share This Page