Internet Explorer waits to render problem

Discussion in 'Javascript' started by Roman, Mar 30, 2007.

  1. Roman

    Roman Guest

    I have been trying to battle a problem for quite some time now:
    The website I am working on: http://www.ipromo.com loads VERY slowly
    on IE 6 and 7.

    To be more precise, the pages load just as fast as they do in Firefox
    or Opera - but they wait until the last image is loaded before
    rendering. This is obviously a major problem because users sit there
    for anywhere from 3-15 seconds staring at a white screen instead of a
    web page that's mostly loaded.

    However: if I disable javascript in my IE, the page start rendering
    immediately and the images fill out as they load.
    I have no idea what in my javascript is making IE misbehave so
    violently - any advice would be appreciated.
     
    Roman, Mar 30, 2007
    #1
    1. Advertisements

  2. Roman

    Roman Guest

    Thanks for your attention :)
    It looks like I've traced it down to csshover.htc - which seems
    necessary for the menu on the left.

    If anybody knows a fix that will not involve a completely rewrite of
    the menu, it would be very appreciated.

    Thanks in advance,
    Roman

    On Mar 30, 11:03 am, "Roman" <> wrote:
    > I have been trying to battle a problem for quite some time now:
    > The website I am working on:http://www.ipromo.comloads VERY slowly
    > on IE 6 and 7.
    >
    > To be more precise, the pages load just as fast as they do in Firefox
    > or Opera - but they wait until the last image is loaded before
    > rendering. This is obviously a major problem because users sit there
    > for anywhere from 3-15 seconds staring at a white screen instead of a
    > web page that's mostly loaded.
    >
    > However: if I disable javascript in my IE, the page start rendering
    > immediately and the images fill out as they load.
    > I have no idea what in my javascript is making IE misbehave so
    > violently - any advice would be appreciated.
     
    Roman, Mar 30, 2007
    #2
    1. Advertisements

  3. Roman

    Roman Guest

    On Mar 30, 12:10 pm, "Roman" <> wrote:
    > Thanks for your attention :)
    > It looks like I've traced it down to csshover.htc - which seems
    > necessary for the menu on the left.
    >
    > If anybody knows a fix that will not involve a completely rewrite of
    > the menu, it would be very appreciated.
    >
    > Thanks in advance,
    > Roman
    >
    > On Mar 30, 11:03 am, "Roman" <> wrote:
    >
    >
    >
    > > I have been trying to battle a problem for quite some time now:
    > > The website I am working on:http://www.ipromo.comloadsVERY slowly
    > > on IE 6 and 7.

    >
    > > To be more precise, the pages load just as fast as they do in Firefox
    > > or Opera - but they wait until the last image is loaded before
    > > rendering. This is obviously a major problem because users sit there
    > > for anywhere from 3-15 seconds staring at a white screen instead of a
    > > web page that's mostly loaded.

    >
    > > However: if I disable javascript in my IE, the page start rendering
    > > immediately and the images fill out as they load.
    > > I have no idea what in my javascript is making IE misbehave so
    > > violently - any advice would be appreciated.- Hide quoted text -

    >
    > - Show quoted text -


    Problem is now fixed - sorry to bother you all. Used the method
    described in http://www.alistapart.com/articles/dropdowns/ to get IE
    to work with the menu.
     
    Roman, Mar 30, 2007
    #3
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lau Lei Cheong

    Page.Render do not render complete page

    Lau Lei Cheong, May 15, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    2,348
    Lau Lei Cheong
    May 15, 2004
  2. GrantMagic

    Timer while user waits

    GrantMagic, Sep 9, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    440
    Rutger Smit
    Sep 9, 2004
  3. cmay
    Replies:
    0
    Views:
    1,401
  4. Mythran

    Internet Explorer Render Problem

    Mythran, Sep 15, 2005, in forum: ASP .Net
    Replies:
    1
    Views:
    684
    Bruce Barker
    Sep 15, 2005
  5. Replies:
    2
    Views:
    9,006
    Sebastian Scheid
    Aug 25, 2005
  6. Ed Hauptman
    Replies:
    7
    Views:
    1,329
    Ed Hauptman
    Aug 7, 2009
  7. Glenn Gillen
    Replies:
    0
    Views:
    500
    Glenn Gillen
    Nov 17, 2006
  8. John Smith
    Replies:
    1
    Views:
    363
    Evertjan.
    Mar 12, 2005
Loading...