Invalidated fields fail to show their errors in wizard step?

Discussion in 'ASP .Net' started by Andy B., Jun 12, 2009.

  1. Andy B.

    Andy B. Guest

    I have a TextBox in a wizard step. I put a requiredFieldValidator next to it
    and connected them together. I put a validationSummary at the top of the
    wizardStep and set the validationSummary and the RequiredFieldValidator to
    disable client script (for mobile devices). When I run the page and click
    next, the wizard doesn't move up a step as expected, but the
    validationSummary doesn't show any errors. When I type something into the
    box and click next, the wizard advances to the next step as expected. What
    could be going wrong here? I have the ErrorMessage set to "Something is
    required" and DisplayType is set to none. I tried all of the DisplayTypes,
    but nothing helps. How would I fix this?
    Andy B., Jun 12, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    9
    Views:
    11,114
    Silvio Bierman
    Dec 6, 2004
  2. Replies:
    1
    Views:
    1,140
    William Brogden
    Dec 6, 2004
  3. Boltar
    Replies:
    10
    Views:
    2,062
    Daniel T.
    Jan 22, 2007
  4. Replies:
    1
    Views:
    478
  5. David Thielen

    3 step wizard - ignore last step

    David Thielen, Oct 23, 2006, in forum: ASP .Net Web Controls
    Replies:
    3
    Views:
    225
    Steven Cheng[MSFT]
    Oct 24, 2006
Loading...

Share This Page