Is it necessary to install VS 2005 to server machine to run awebsite?

Discussion in 'ASP .Net Web Services' started by chandan, Jan 15, 2008.

  1. chandan

    chandan Guest

    I have IIS server 6.0 and dotnet framwork 2.0 on my server machine. I
    intall the setup of my application to server machine Now I try to run
    my website from server machine then its shows the html content (text
    file) on the browser.

    Why browser doesnot reder this Html? please tell me where is poblem?

    Thanks,
    Chandan
    chandan, Jan 15, 2008
    #1
    1. Advertising

  2. chandan

    Scott M. Guest

    Re: Is it necessary to install VS 2005 to server machine to run a website?

    Please explain what you mean by: "I intall the setup of my application to
    server machine."

    What exactly did you do?

    You do not need (and should not have) Visual Studio installed on your
    production server. You just need to create a new application folder in IIS
    for your web site to reside and then you just publish (copy) your files to
    that folder.

    Of course, you'll need to configure that IIS application with appropriate
    permissions, etc. but those are IIS issues, not .NET issues.

    -Scott


    "chandan" <> wrote in message
    news:...
    >I have IIS server 6.0 and dotnet framwork 2.0 on my server machine. I
    > intall the setup of my application to server machine Now I try to run
    > my website from server machine then its shows the html content (text
    > file) on the browser.
    >
    > Why browser doesnot reder this Html? please tell me where is poblem?
    >
    > Thanks,
    > Chandan
    Scott M., Jan 15, 2008
    #2
    1. Advertising

  3. chandan

    Guest

    On 15 Jan, 09:14, chandan <> wrote:
    > I have IIS server 6.0  and dotnet framwork 2.0 on my server machine. I
    > intall the setup of my application to server machine Now I try to run
    > my website from server machine then its shows the html content (text
    > file) on the browser.
    >
    > Why browser doesnot reder this Html? please tell me where is poblem?
    >
    > Thanks,
    > Chandan


    I am not so clear on what you mean here, Its shows the HTML page but
    not the .aspx page???

    If that is the case, I would make sure in the Web Service Extentions
    of IIS 6.0 that
    ASPNET v2.0.0.50727 is set to ALLOWED
    , Jan 16, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page