IWAM_machinename account registry hive remains loaded evan after IISReset

Discussion in 'ASP .Net' started by \Rob\, May 10, 2004.

  1. \Rob\

    \Rob\ Guest

    On a Win2000 domain controller, the ASPNET (v1.1) worker process
    (aspnet_wp.exe) runs under the IWAM_machinename (IIS 5) account NOT the
    ASPNET account.

    (I know domain controllers shouldn't run in this config - it is only a test
    machine)

    Why does the IWAM_machinename registry hive remain loaded evan after
    IISReset (which kills aspnet_wp.exe)?

    I have to manually unload it with regedt32.exe.

    Is this normal behavior?

    Thanks

    P.S. IWAM_machinename has the following ASPNET required rights:
    a.. Access this computer from the network.
    a.. Logon as a batch job.
    a.. Logon as a service.
    a.. Deny logon locally.
    a.. Impersonate a client after authentication
     
    \Rob\, May 10, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. \Rob\
    Replies:
    4
    Views:
    3,528
    \Rob\
    May 12, 2004
  2. =?Utf-8?B?Um9iZXJ0IERyb3pkeg==?=

    HKCU Registry Hive & ASP.NET impersonated application

    =?Utf-8?B?Um9iZXJ0IERyb3pkeg==?=, Jul 29, 2004, in forum: ASP .Net
    Replies:
    1
    Views:
    557
    Nicole Calinoiu
    Jul 29, 2004
  3. Phil Wilson
    Replies:
    0
    Views:
    1,700
    Phil Wilson
    Feb 12, 2005
  4. Mat

    How can you hive

    Mat, Dec 11, 2006, in forum: ASP .Net
    Replies:
    3
    Views:
    317
    Marina Levit [MVP]
    Dec 11, 2006
  5. Matt Ernst
    Replies:
    2
    Views:
    373
    Matt Ernst
    Oct 3, 2009
Loading...

Share This Page