J2ME LocationProvider hanging

Discussion in 'Java' started by aaziz, Nov 24, 2008.

  1. aaziz

    aaziz Guest

    Hi. I'm writing a mobile application in j2me, however on one certain
    phone (Sanyo Pro-200), the call to LocationProvider.getInstance is
    hanging and not returning a LocationProvider instance. It works on the
    Pro-200 emulator (among others), and we've tested it on other physical
    phones (A few recent blackberry models and Motorola i670).

    I don't know whether or not the phone can get the LocationProvider (as
    far as I know this doesn't actually use the GPS connectivity), but I'd
    expect it to throw an exception or something (which it does on other
    phones).

    Any help or insight would be appreciated, thanks. Could sample at
    http://pastebin.com/m14d4c382
     
    aaziz, Nov 24, 2008
    #1
    1. Advertising

  2. aaziz

    aaziz Guest

    Hmm, an update, it seems that it might be the getState() method, as a
    debug message right after LocationProvider.getInstance() shows:
    http://pastebin.com/m51181216

    I've removed the getState calls and we're testing again.
     
    aaziz, Nov 24, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. robin
    Replies:
    0
    Views:
    872
    robin
    Jul 20, 2003
  2. Boldra
    Replies:
    0
    Views:
    1,299
    Boldra
    Dec 3, 2003
  3. Markus
    Replies:
    4
    Views:
    1,807
    Darryl Pierce
    Feb 12, 2005
  4. Simon Brooke
    Replies:
    0
    Views:
    522
    Simon Brooke
    Oct 13, 2006
  5. shach
    Replies:
    0
    Views:
    379
    shach
    Sep 24, 2007
Loading...

Share This Page