Jumping Post Titles in IE

Discussion in 'HTML' started by Johanna, Sep 24, 2006.

  1. Johanna

    Johanna Guest

    Hi!
    Using CSS, when I set position:relative, IE starts behaving very
    strangely. http://www.vikingprincess.net/?cat=3

    First of all, whereas FF and Opera posts and headers remain exactly
    where I expect them to be,
    In IE, they move away, causing me to have to start using the * html hack
    to reposition them.
    I just about succeeded when I noticed that while hovering over the
    titles and text in the posts,
    they jump around! I certainly have not coded this.

    THis is really hard to explain. Best way is to see it, so have a look at
    http://www.vikingprincess.net/?cat=3
    Hover over the title and text and you will see them jumping away!
    I have no idea what's going on, and I do need to use the position:
    relative .
    Any advice for working around this IE bug would be very appreciated.
    You would not see the bug in FF.

    This is a project for me to learn CSS, so please excuse if my coding is
    not so stylish!
    Jo
    Johanna, Sep 24, 2006
    #1
    1. Advertising

  2. Johanna

    richard Guest

    "Johanna" <> wrote in message
    news:4516b080$...
    > Hi!
    > Using CSS, when I set position:relative, IE starts behaving very
    > strangely. http://www.vikingprincess.net/?cat=3
    >
    > First of all, whereas FF and Opera posts and headers remain exactly where
    > I expect them to be,
    > In IE, they move away, causing me to have to start using the * html hack
    > to reposition them.
    > I just about succeeded when I noticed that while hovering over the titles
    > and text in the posts,
    > they jump around! I certainly have not coded this.
    >
    > THis is really hard to explain. Best way is to see it, so have a look at
    > http://www.vikingprincess.net/?cat=3
    > Hover over the title and text and you will see them jumping away!
    > I have no idea what's going on, and I do need to use the position:
    > relative .
    > Any advice for working around this IE bug would be very appreciated.
    > You would not see the bug in FF.
    >
    > This is a project for me to learn CSS, so please excuse if my coding is
    > not so stylish!
    > Jo


    Have you run it through a validator? Might find some tag errors or syntax
    errors.
    Using both IE and FF, I noticed a line break before "Posted in" which is not
    present in IE.
    On first opening, IE displayed the "jumping" then a refresh seemed to fix
    it.

    http://validator.w3.org/check?uri=http://www.vikingprincess.net/?cat=3

    Move the comments off the same line as the </div> tags.
    richard, Sep 24, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Stevie_mac

    Tooltips on datagrid titles

    Stevie_mac, Jul 25, 2003, in forum: ASP .Net
    Replies:
    2
    Views:
    446
    Stevie_mac
    Jul 25, 2003
  2. Gilgamesh

    Page titles

    Gilgamesh, Dec 5, 2003, in forum: ASP .Net
    Replies:
    3
    Views:
    395
    Steve C. Orr [MVP, MCSD]
    Dec 5, 2003
  3. PeeBee
    Replies:
    3
    Views:
    5,266
    William F. Robertson, Jr.
    Apr 1, 2005
  4. jalkadir
    Replies:
    3
    Views:
    416
    jalkadir
    Oct 5, 2005
  5. nick
    Replies:
    3
    Views:
    84
    Scott Sauyet
    May 19, 2010
Loading...

Share This Page