Logon popup for intranet application

Discussion in 'ASP .Net Security' started by David, Dec 2, 2003.

  1. David

    David Guest

    Hi,

    We have several intranet applications (ASP.NET), that are
    deployed on both of our webservers. As these applications
    are used only in the intranet zone, anonymous access is
    disabled, and we are instead using Integrated Windows
    authentication. Some users within the company when
    logging onto the applications on one of our webservers are
    prompted with a logon popup, asking them to enter their
    username, password and domain. These applications run
    fine (i.e. no logon popup) when users connect to exactly
    the same application on the other webserver.

    I've checked, to ensure that users IE settings look
    correct. Bypass proxy for local addresses is selected in
    LAN Settings, as well as in the proxy settings window of
    LAN settings I've checked that the name of the webservers
    (separated witha a ;) are added to the "Do not use proxy
    servers for addresses beginning with:" box.

    Any ideas? Is this likely to have anything to do with the
    way in which the problematic webserver is configured?

    Thanks in advance
    David
     
    David, Dec 2, 2003
    #1
    1. Advertising

  2. David

    Scott M. Guest

    Sounds like someone has put NTFS permissions on the folders in quesiton.


    "David" <> wrote in message
    news:b0e701c3b8cb$90f62c30$...
    > Hi,
    >
    > We have several intranet applications (ASP.NET), that are
    > deployed on both of our webservers. As these applications
    > are used only in the intranet zone, anonymous access is
    > disabled, and we are instead using Integrated Windows
    > authentication. Some users within the company when
    > logging onto the applications on one of our webservers are
    > prompted with a logon popup, asking them to enter their
    > username, password and domain. These applications run
    > fine (i.e. no logon popup) when users connect to exactly
    > the same application on the other webserver.
    >
    > I've checked, to ensure that users IE settings look
    > correct. Bypass proxy for local addresses is selected in
    > LAN Settings, as well as in the proxy settings window of
    > LAN settings I've checked that the name of the webservers
    > (separated witha a ;) are added to the "Do not use proxy
    > servers for addresses beginning with:" box.
    >
    > Any ideas? Is this likely to have anything to do with the
    > way in which the problematic webserver is configured?
    >
    > Thanks in advance
    > David
     
    Scott M., Dec 2, 2003
    #2
    1. Advertising

  3. David

    David Guest

    Thanks Scott, looks as if this problem is now fixed. It
    was indeed NTFS permissions. They'd been applied to the
    wwwroot folder erroneously on the problematic webserver.

    David
     
    David, Dec 3, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. rb
    Replies:
    2
    Views:
    2,083
  2. BluDog
    Replies:
    0
    Views:
    333
    BluDog
    Aug 3, 2004
  3. sanjeeev
    Replies:
    3
    Views:
    531
    Patrice
    Apr 14, 2005
  4. Kjell Kristiansson
    Replies:
    0
    Views:
    302
    Kjell Kristiansson
    Nov 30, 2005
  5. Jens Peter Hansen
    Replies:
    7
    Views:
    566
    Randy Webb
    Jun 19, 2004
Loading...

Share This Page