Making Custom Server control visible at design time...

Discussion in 'ASP .Net' started by Charlie@CBFC, Sep 16, 2005.

  1. Charlie@CBFC

    Charlie@CBFC Guest

    Hi:

    When I drag a my custom server control from the toolbox to design surface it
    appears invisible except for little green arrow. I can change the width and
    fill color of control in prop sheet so I can see it at design time, but this
    interferes with its rendering at runtime. I have seen custom server
    controls that appear like this at design time... [SomeControlClass
    "SomeControlName"]. How do you get it to do this?

    Thanks,
    Charlie
     
    Charlie@CBFC, Sep 16, 2005
    #1
    1. Advertising

  2. You create a Custom Designer for it. See:

    http://msdn.microsoft.com/library/d.../cpguide/html/cpcondesign-timeforwebforms.asp

    --
    HTH,

    Kevin Spencer
    Microsoft MVP
    ..Net Developer
    Neither a follower nor a lender be.

    "Charlie@CBFC" <> wrote in message
    news:...
    > Hi:
    >
    > When I drag a my custom server control from the toolbox to design surface
    > it
    > appears invisible except for little green arrow. I can change the width
    > and
    > fill color of control in prop sheet so I can see it at design time, but
    > this
    > interferes with its rendering at runtime. I have seen custom server
    > controls that appear like this at design time... [SomeControlClass
    > "SomeControlName"]. How do you get it to do this?
    >
    > Thanks,
    > Charlie
    >
    >
     
    Kevin Spencer, Sep 16, 2005
    #2
    1. Advertising

  3. Charlie@CBFC

    Charlie@CBFC Guest

    That's cool! Thanks.

    Charlie
    "Kevin Spencer" <> wrote in message
    news:%...
    > You create a Custom Designer for it. See:
    >
    >

    http://msdn.microsoft.com/library/d.../cpguide/html/cpcondesign-timeforwebforms.asp
    >
    > --
    > HTH,
    >
    > Kevin Spencer
    > Microsoft MVP
    > .Net Developer
    > Neither a follower nor a lender be.
    >
    > "Charlie@CBFC" <> wrote in message
    > news:...
    > > Hi:
    > >
    > > When I drag a my custom server control from the toolbox to design

    surface
    > > it
    > > appears invisible except for little green arrow. I can change the width
    > > and
    > > fill color of control in prop sheet so I can see it at design time, but
    > > this
    > > interferes with its rendering at runtime. I have seen custom server
    > > controls that appear like this at design time... [SomeControlClass
    > > "SomeControlName"]. How do you get it to do this?
    > >
    > > Thanks,
    > > Charlie
    > >
    > >

    >
    >
     
    Charlie@CBFC, Sep 16, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    0
    Views:
    731
  2. Nathan Sokalski
    Replies:
    0
    Views:
    932
    Nathan Sokalski
    Oct 17, 2005
  3. SP
    Replies:
    1
    Views:
    948
  4. Nathan Sokalski
    Replies:
    0
    Views:
    219
    Nathan Sokalski
    Oct 17, 2005
  5. Nathan Sokalski
    Replies:
    0
    Views:
    237
    Nathan Sokalski
    Oct 17, 2005
Loading...

Share This Page