Maximum connections to http server

Discussion in 'ASP .Net' started by Raghu Rudra, Jul 23, 2003.

  1. Raghu Rudra

    Raghu Rudra Guest

    By default, the machine.config contains following information:

    <system.net>
    .......
    <connectionManagement>
    <add address="*" maxconnection="2"/>
    </connectionManagement>
    </system.net>

    This limits the number of connections to web server to 2. For example, if
    you want to write code to post xml to a web server using HttpWebRequest
    object, the call to GetResponse() will be blocked except for first 2
    threads. All other threads will enter GetResponse method as previous threads
    are done.

    Tthe msdn documentation says that if you want increase this number for any
    http server, you need to modify this configuration in either machine.config
    or app confic or policy config file as below:

    <system.net>
    .......
    <connectionManagement>
    <add address="www.abc.com" maxconnection="15"/>
    </connectionManagement>
    </system.net>

    I have a web application that is deployed on internal web server. So I
    modified it as following:

    <system.net>
    .......
    <connectionManagement>
    <add address="mymachine" maxconnection="15"/>
    </connectionManagement>
    </system.net>

    This did not work at all. I also tried the machine in active directory
    network name mymachine.ab.cde. It did not work either.

    But when I modified as below, it worked:

    <system.net>
    .......
    <connectionManagement>
    <add address="*" maxconnection="15"/>
    </connectionManagement>
    </system.net>

    But I do not want to apply this for every server. So can someone tell what
    am I doing wrong?

    Thanks.
    Raghu/..
     
    Raghu Rudra, Jul 23, 2003
    #1
    1. Advertising

  2. Hi Raghu,

    Have you tried using the IP address instead of name?


    --
    Ray Dixon - Microsoft MVP

    (remove NOSPAM. from my e-mail address for a direct reply)


    "Raghu Rudra" <> wrote in message
    news:%...
    > By default, the machine.config contains following information:
    >
    > <system.net>
    > .......
    > <connectionManagement>
    > <add address="*" maxconnection="2"/>
    > </connectionManagement>
    > </system.net>
    >
    > This limits the number of connections to web server to 2. For example, if
    > you want to write code to post xml to a web server using HttpWebRequest
    > object, the call to GetResponse() will be blocked except for first 2
    > threads. All other threads will enter GetResponse method as previous

    threads
    > are done.
    >
    > Tthe msdn documentation says that if you want increase this number for any
    > http server, you need to modify this configuration in either

    machine.config
    > or app confic or policy config file as below:
    >
    > <system.net>
    > .......
    > <connectionManagement>
    > <add address="www.abc.com" maxconnection="15"/>
    > </connectionManagement>
    > </system.net>
    >
    > I have a web application that is deployed on internal web server. So I
    > modified it as following:
    >
    > <system.net>
    > .......
    > <connectionManagement>
    > <add address="mymachine" maxconnection="15"/>
    > </connectionManagement>
    > </system.net>
    >
    > This did not work at all. I also tried the machine in active directory
    > network name mymachine.ab.cde. It did not work either.
    >
    > But when I modified as below, it worked:
    >
    > <system.net>
    > .......
    > <connectionManagement>
    > <add address="*" maxconnection="15"/>
    > </connectionManagement>
    > </system.net>
    >
    > But I do not want to apply this for every server. So can someone tell what
    > am I doing wrong?
    >
    > Thanks.
    > Raghu/..
    >
    >
     
    Ray Dixon [MVP], Jul 23, 2003
    #2
    1. Advertising

  3. Raghu Rudra

    Raghu Rudra Guest

    I did not the first time. Now I did. It is still not working the it is
    supposed to.

    "Ray Dixon [MVP]" <> wrote in message
    news:...
    > Hi Raghu,
    >
    > Have you tried using the IP address instead of name?
    >
    >
    > --
    > Ray Dixon - Microsoft MVP
    >
    > (remove NOSPAM. from my e-mail address for a direct reply)
    >
    >
    > "Raghu Rudra" <> wrote in message
    > news:%...
    > > By default, the machine.config contains following information:
    > >
    > > <system.net>
    > > .......
    > > <connectionManagement>
    > > <add address="*" maxconnection="2"/>
    > > </connectionManagement>
    > > </system.net>
    > >
    > > This limits the number of connections to web server to 2. For example,

    if
    > > you want to write code to post xml to a web server using HttpWebRequest
    > > object, the call to GetResponse() will be blocked except for first 2
    > > threads. All other threads will enter GetResponse method as previous

    > threads
    > > are done.
    > >
    > > Tthe msdn documentation says that if you want increase this number for

    any
    > > http server, you need to modify this configuration in either

    > machine.config
    > > or app confic or policy config file as below:
    > >
    > > <system.net>
    > > .......
    > > <connectionManagement>
    > > <add address="www.abc.com" maxconnection="15"/>
    > > </connectionManagement>
    > > </system.net>
    > >
    > > I have a web application that is deployed on internal web server. So I
    > > modified it as following:
    > >
    > > <system.net>
    > > .......
    > > <connectionManagement>
    > > <add address="mymachine" maxconnection="15"/>
    > > </connectionManagement>
    > > </system.net>
    > >
    > > This did not work at all. I also tried the machine in active directory
    > > network name mymachine.ab.cde. It did not work either.
    > >
    > > But when I modified as below, it worked:
    > >
    > > <system.net>
    > > .......
    > > <connectionManagement>
    > > <add address="*" maxconnection="15"/>
    > > </connectionManagement>
    > > </system.net>
    > >
    > > But I do not want to apply this for every server. So can someone tell

    what
    > > am I doing wrong?
    > >
    > > Thanks.
    > > Raghu/..
    > >
    > >

    >
    >
     
    Raghu Rudra, Jul 23, 2003
    #3
  4. It depends on what your platform is.
    Windows XP and Windows 2000 professional have a hard coded limited of
    10 "simultaneous" connections because they are not "Server" OS's. This
    is usually sufficient for development purposes but not for production
    servers and/ or load testing.
    I "think" that the setting you are referring to in machine.config
    refers to the number of connections per request. Like when you hit a
    webpage and it begins downloading images for that page.. it can use up
    to two connections by default to download these to the client. Someone
    can correct me if I'm wrong.

    Darren Mombourquette

    "Raghu Rudra" <> wrote in message news:<>...
    > I did not the first time. Now I did. It is still not working the it is
    > supposed to.
    >
    > "Ray Dixon [MVP]" <> wrote in message
    > news:...
    > > Hi Raghu,
    > >
    > > Have you tried using the IP address instead of name?
    > >
    > >
    > > --
    > > Ray Dixon - Microsoft MVP
    > >
    > > (remove NOSPAM. from my e-mail address for a direct reply)
    > >
    > >
    > > "Raghu Rudra" <> wrote in message
    > > news:%...
    > > > By default, the machine.config contains following information:
    > > >
    > > > <system.net>
    > > > .......
    > > > <connectionManagement>
    > > > <add address="*" maxconnection="2"/>
    > > > </connectionManagement>
    > > > </system.net>
    > > >
    > > > This limits the number of connections to web server to 2. For example,

    > if
    > > > you want to write code to post xml to a web server using HttpWebRequest
    > > > object, the call to GetResponse() will be blocked except for first 2
    > > > threads. All other threads will enter GetResponse method as previous

    > threads
    > > > are done.
    > > >
    > > > Tthe msdn documentation says that if you want increase this number for

    > any
    > > > http server, you need to modify this configuration in either

    > machine.config
    > > > or app confic or policy config file as below:
    > > >
    > > > <system.net>
    > > > .......
    > > > <connectionManagement>
    > > > <add address="www.abc.com" maxconnection="15"/>
    > > > </connectionManagement>
    > > > </system.net>
    > > >
    > > > I have a web application that is deployed on internal web server. So I
    > > > modified it as following:
    > > >
    > > > <system.net>
    > > > .......
    > > > <connectionManagement>
    > > > <add address="mymachine" maxconnection="15"/>
    > > > </connectionManagement>
    > > > </system.net>
    > > >
    > > > This did not work at all. I also tried the machine in active directory
    > > > network name mymachine.ab.cde. It did not work either.
    > > >
    > > > But when I modified as below, it worked:
    > > >
    > > > <system.net>
    > > > .......
    > > > <connectionManagement>
    > > > <add address="*" maxconnection="15"/>
    > > > </connectionManagement>
    > > > </system.net>
    > > >
    > > > But I do not want to apply this for every server. So can someone tell

    > what
    > > > am I doing wrong?
    > > >
    > > > Thanks.
    > > > Raghu/..
    > > >
    > > >

    > >
    > >
     
    Darren Mombourquette, Jul 28, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Philip Townsend

    Error on maximum number of connections exceeded

    Philip Townsend, May 11, 2004, in forum: ASP .Net
    Replies:
    2
    Views:
    712
  2. Replies:
    1
    Views:
    10,690
  3. Steve Holden
    Replies:
    3
    Views:
    358
    fumanchu
    Feb 10, 2007
  4. Jay Douglas
    Replies:
    1
    Views:
    451
    Alvin Bruney [MVP]
    Apr 27, 2007
  5. phanhuyich
    Replies:
    4
    Views:
    331
Loading...

Share This Page