Membership Services Problem

Discussion in 'ASP .Net' started by Wayne Wengert, Feb 17, 2006.

  1. I am trying to add some profiles to an ASP.NET 2.0 application that uses the
    membership services login control. I created a Sub for
    Public Sub CreateUserWizard1_CreatedUser(ByVal sender As Object, ByVal e As
    EventArgs)

    But that event never fires. The new registration information is getting
    recorded in aspnetdb_Membership, apnetdb_users and MemberInfo tables so I
    know the user is being created. Also, if I put a break in the

    Protected Sub CreateUserFinished(ByVal sender As Object, ByVal e As
    System.Web.UI.WebControls.WizardNavigationEventArgs)

    event I can see that that event fires?

    Any ideas on why the "CreatedUser" event never fires?



    Wayne
    Wayne Wengert, Feb 17, 2006
    #1
    1. Advertising

  2. Wayne much easier to use the ide select the control and the events from the
    dropdownlists in the code editor.

    Protected Sub CreateUserWizard1_CreatedUser(ByVal sender As Object, ByVal e
    As System.EventArgs) Handles CreateUserWizard1.CreatedUser

    End Sub
    Good Luck
    DWS


    "Wayne Wengert" wrote:

    > I am trying to add some profiles to an ASP.NET 2.0 application that uses the
    > membership services login control. I created a Sub for
    > Public Sub CreateUserWizard1_CreatedUser(ByVal sender As Object, ByVal e As
    > EventArgs)
    >
    > But that event never fires. The new registration information is getting
    > recorded in aspnetdb_Membership, apnetdb_users and MemberInfo tables so I
    > know the user is being created. Also, if I put a break in the
    >
    > Protected Sub CreateUserFinished(ByVal sender As Object, ByVal e As
    > System.Web.UI.WebControls.WizardNavigationEventArgs)
    >
    > event I can see that that event fires?
    >
    > Any ideas on why the "CreatedUser" event never fires?
    >
    >
    >
    > Wayne
    >
    >
    >
    =?Utf-8?B?RFdT?=, Feb 17, 2006
    #2
    1. Advertising

  3. Interesting. I actually deleted the sub and recreated it as you suggested
    but it still never fired. Then I manually added the "Handles..." phrase and
    now it fires.

    Thanks for the help. I don't understand why the IDE creates the sub without
    the handles phrase?

    Wayne

    "DWS" <> wrote in message
    news:...
    > Wayne much easier to use the ide select the control and the events from
    > the
    > dropdownlists in the code editor.
    >
    > Protected Sub CreateUserWizard1_CreatedUser(ByVal sender As Object, ByVal
    > e
    > As System.EventArgs) Handles CreateUserWizard1.CreatedUser
    >
    > End Sub
    > Good Luck
    > DWS
    >
    >
    > "Wayne Wengert" wrote:
    >
    >> I am trying to add some profiles to an ASP.NET 2.0 application that uses
    >> the
    >> membership services login control. I created a Sub for
    >> Public Sub CreateUserWizard1_CreatedUser(ByVal sender As Object, ByVal e
    >> As
    >> EventArgs)
    >>
    >> But that event never fires. The new registration information is getting
    >> recorded in aspnetdb_Membership, apnetdb_users and MemberInfo tables so I
    >> know the user is being created. Also, if I put a break in the
    >>
    >> Protected Sub CreateUserFinished(ByVal sender As Object, ByVal e As
    >> System.Web.UI.WebControls.WizardNavigationEventArgs)
    >>
    >> event I can see that that event fires?
    >>
    >> Any ideas on why the "CreatedUser" event never fires?
    >>
    >>
    >>
    >> Wayne
    >>
    >>
    >>
    Wayne Wengert, Feb 17, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. artificer

    ASP.NET Membership Services Question?

    artificer, Sep 7, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    400
    clintonG
    Sep 8, 2005
  2. =?Utf-8?B?YmpvaG5zMzM=?=

    Membership Services, Login and http/https

    =?Utf-8?B?YmpvaG5zMzM=?=, Feb 1, 2006, in forum: ASP .Net
    Replies:
    1
    Views:
    384
    chris
    Feb 1, 2006
  3. Anonieko
    Replies:
    0
    Views:
    6,796
    Anonieko
    Jul 5, 2006
  4. Tino Donderwinkel
    Replies:
    2
    Views:
    751
    Tino Donderwinkel
    Jun 18, 2008
  5. va
    Replies:
    0
    Views:
    158
Loading...

Share This Page