Microblaze XPS Gpio not working with interrupts

Discussion in 'VHDL' started by guru10, Aug 9, 2005.

  1. guru10

    guru10 Guest

    I am trying to run general purpose port of microblaze on interrupts. HOw
    the function to intitialze XGpio structe (name XGpio_Initialize) does not
    work. It does not return at all. And if you use this function in your
    program, the whole programs hangs. Any idea what am i missing here?

    I declared XGpio as global variable. The programs compiles fine but not
    output.
     
    guru10, Aug 9, 2005
    #1
    1. Advertisements

  2. guru10

    Guest

    guru10 wrote:
    > I am trying to run general purpose port of microblaze on interrupts. HOw
    > the function to intitialze XGpio structe (name XGpio_Initialize) does not
    > work. It does not return at all. And if you use this function in your
    > program, the whole programs hangs. Any idea what am i missing here?
    >
    > I declared XGpio as global variable. The programs compiles fine but not
    > output.


    I am currently using the PowerPC but I don't recall using the
    initialise function. I use the set_direction function to set the port
    as an input or output (1 or 0 or vice versa???) but I recall in EDK,
    there was a LED example that uses the GPIO component.

    Paul
     
    , Aug 18, 2005
    #2
    1. Advertisements

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Frank

    microblaze and external RAM

    Frank, Oct 13, 2003, in forum: VHDL
    Replies:
    1
    Views:
    2,809
    Jaytersen
    Oct 13, 2003
  2. Ciaran
    Replies:
    12
    Views:
    6,713
    Frank van Eijkelenburg
    Feb 27, 2004
  3. jluisky

    MICROBLAZE AND SDRAM

    jluisky, May 10, 2005, in forum: VHDL
    Replies:
    2
    Views:
    1,055
    NEWS-T-ONLINE
    May 10, 2005
  4. mon
    Replies:
    1
    Views:
    537
  5. Dave

    Xilinx GPIO help...

    Dave, Aug 29, 2006, in forum: VHDL
    Replies:
    0
    Views:
    1,696
  6. Richard Steele

    Convert Word to XPS

    Richard Steele, Aug 28, 2009, in forum: ASP .Net
    Replies:
    0
    Views:
    734
    Richard Steele
    Aug 28, 2009
  7. ThatsIT.net.au

    Cant find System.Windows.Xps

    ThatsIT.net.au, Jan 22, 2010, in forum: ASP .Net
    Replies:
    4
    Views:
    1,693
    Herfried K. Wagner [MVP]
    Jan 22, 2010
  8. Replies:
    1
    Views:
    227
    Dave Burt
    Mar 7, 2007
Loading...