"Missing parameter values." in Crystal Reports

Discussion in 'ASP .Net' started by Peter Afonin, Sep 9, 2010.

  1. Peter Afonin

    Peter Afonin Guest

    Hello,

    I'm using Crystal Reports 2008 and ASP.NET 3.5.

    Suddenly one of my reports started to give me an error message: "Missing
    parameter values."

    I did the research and found many similar issues, but they all apply to the
    reports with parameters. But I'm not setting any parameters to this report,
    I'm only passing parameters to the stored procedures, so I have no idea
    where this message is coming from. The same report worked fine yesterday,
    and I even don't know what has been changed.

    The only special thing about this report is that it has two subreports. But
    all my other reports with subreports work just fine.

    I would appreciate any suggestions about this.

    Thank you,

    Peter
     
    Peter Afonin, Sep 9, 2010
    #1
    1. Advertising

  2. Peter Afonin

    Peter Afonin Guest

    I've found the problem - the subreports links were not correct. Aparently
    they are treated as parameters.

    "Peter Afonin" <> wrote in message
    news:%...
    > Hello,
    >
    > I'm using Crystal Reports 2008 and ASP.NET 3.5.
    >
    > Suddenly one of my reports started to give me an error message: "Missing
    > parameter values."
    >
    > I did the research and found many similar issues, but they all apply to
    > the reports with parameters. But I'm not setting any parameters to this
    > report, I'm only passing parameters to the stored procedures, so I have no
    > idea where this message is coming from. The same report worked fine
    > yesterday, and I even don't know what has been changed.
    >
    > The only special thing about this report is that it has two subreports.
    > But all my other reports with subreports work just fine.
    >
    > I would appreciate any suggestions about this.
    >
    > Thank you,
    >
    > Peter
    >
     
    Peter Afonin, Sep 9, 2010
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.

Share This Page