Mod_python installation: apache Warning

Discussion in 'Python' started by Andrea Fiore, Mar 16, 2005.

  1. Andrea Fiore

    Andrea Fiore Guest

    Hello,
    i have compiled mod_python 2.7.10 on a Linux box with Apache 1.3.31,
    but after i restarted the web server, i had a strange warning that i
    did non understand....

    **
    bash-2.05b# apachectl configtest
    [Wed Mar 16 11:50:26 2005] [warn] Loaded DSO
    /usr/libexec/apache/mod_python.so uses plain Apache 1.3 API, this
    module might crash under EAPI! (please recompile it with -DEAPI)
    Syntax OK
    **

    What is EAPI? what is DEAPI?
    How can i recompile it with DEAPI? (./configure -with-DEAPI doesn't
    work! ;-)


    Thank you in advance,
    Andrea
    Andrea Fiore, Mar 16, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rolfe
    Replies:
    2
    Views:
    341
    Rolfe
    Sep 26, 2003
  2. Rolfe
    Replies:
    2
    Views:
    367
    Rolfe
    Sep 29, 2003
  3. Piet
    Replies:
    6
    Views:
    1,192
    David Fraser
    Sep 2, 2004
  4. Replies:
    2
    Views:
    426
  5. blbmdsmith
    Replies:
    1
    Views:
    633
    Graham Dumpleton
    Dec 14, 2006
Loading...

Share This Page