.NET 2.0 and namespaces in web apps

Discussion in 'ASP .Net' started by Amil, Mar 14, 2006.

  1. Amil

    Amil Guest

    I was reading "Rick Strahl's WebLog" and he mentions that in .net 2.0 web
    apps, there are no namespaces (I verified this by creating simple web app).

    I converted a VS 2003 web app that had namespaces and the VS 2005 still has
    them in there. Should I remove them?

    I'm also having an issue dynamically loading user controls and think it
    might have to do with the use of namespaces.

    Amil
    Amil, Mar 14, 2006
    #1
    1. Advertising

  2. Too funny,

    I just bumped into the same problem with my VS 2005 app that was converted
    from VS 2003.

    http://msdn.microsoft.com/asp.net/r...naspp/html/conversionissuesasp_net.asp#issue1

    This might help you understand the issue and some ways to work around it
    (not clean ways).

    Rob.


    "Amil" <> wrote in message
    news:%...
    >I was reading "Rick Strahl's WebLog" and he mentions that in .net 2.0 web
    >apps, there are no namespaces (I verified this by creating simple web app).
    >
    > I converted a VS 2003 web app that had namespaces and the VS 2005 still
    > has them in there. Should I remove them?
    >
    > I'm also having an issue dynamically loading user controls and think it
    > might have to do with the use of namespaces.
    >
    > Amil
    >
    Rob R. Ainscough, Mar 14, 2006
    #2
    1. Advertising

  3. Amil

    Amil Guest

    Rob,

    Thanks for the link. This reiterated the proper use of doing a LoadControl.
    Specifically, it indicates that the "Reference Control" directive should be
    used. When I use just this directive, I still get my exceptions, but only
    sporatically (can't figure out why they start). If I add an additional
    "Register" directive (by dragging the control to the page, then deleting it
    so that the directive has the correct syntax), then my problem appears to go
    away for good. Hum... It is most confusing since I have other pages that
    only have the Reference directive and they appear to work fine. I've seen
    stuff about cleaning up the .NET cache and restarting IIS. I've tried that,
    but without the Register, it seems to come back after a bit.

    Amil

    "Rob R. Ainscough" <> wrote in message
    news:...
    > Too funny,
    >
    > I just bumped into the same problem with my VS 2005 app that was converted
    > from VS 2003.
    >
    > http://msdn.microsoft.com/asp.net/r...naspp/html/conversionissuesasp_net.asp#issue1
    >
    > This might help you understand the issue and some ways to work around it
    > (not clean ways).
    >
    > Rob.
    >
    >
    > "Amil" <> wrote in message
    > news:%...
    >>I was reading "Rick Strahl's WebLog" and he mentions that in .net 2.0 web
    >>apps, there are no namespaces (I verified this by creating simple web
    >>app).
    >>
    >> I converted a VS 2003 web app that had namespaces and the VS 2005 still
    >> has them in there. Should I remove them?
    >>
    >> I'm also having an issue dynamically loading user controls and think it
    >> might have to do with the use of namespaces.
    >>
    >> Amil
    >>

    >
    >
    Amil, Mar 14, 2006
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. aph
    Replies:
    4
    Views:
    400
    Peter Hansen
    Jan 14, 2006
  2. Steve B.
    Replies:
    0
    Views:
    413
    Steve B.
    Nov 28, 2006
  3. dev648237923
    Replies:
    3
    Views:
    520
    Steven Cheng[MSFT]
    Feb 9, 2007
  4. anonymous

    Call windows apps from web apps

    anonymous, Feb 22, 2005, in forum: ASP .Net Datagrid Control
    Replies:
    4
    Views:
    211
    anonymous
    Feb 28, 2005
  5. Richard Choate

    Web enabled apps/Thin client apps

    Richard Choate, Jul 23, 2003, in forum: ASP General
    Replies:
    2
    Views:
    294
    Chris Barber
    Jul 23, 2003
Loading...

Share This Page