Netbeans 5.5 java.lang.OutOfMemoryError

Discussion in 'Java' started by evgchech, Dec 26, 2006.

  1. evgchech

    evgchech Guest

    Hello Everybody
    I am trying to compile pretty big project using NM 5.5 - SDK 1.4
    During compilation the IDE throws Out of memory exception
    I have edited the following file
    ( As explained in :
    http://performance.netbeans.org/howto/jvmswitches/index.html )

    C:\Program Files\netbeans-5.5\etc\netbeans.conf
    -----------------------------------------------------------------------
    netbeans_default_userdir="${HOME}/.netbeans/5.5"
    netbeans_default_options="-J-Xms128m -J-Xmx512m -J-Xverify:none"
    netbeans_jdkhome="C:\Java\jdk1.5.0_09"

    And still the same exception:
    -------------------------------------------
    Compiling 2435 source files to
    C:\Development\NMS-2.15.05-DLYC\NMS\build
    The system is out of resources.
    Consult the following stack trace for details.
    java.lang.OutOfMemoryError
    BUILD FAILED (total time: 17 seconds)

    P.S
    ------
    I have 1 GB Ram on my system
    The strange thing is that Javac fails after allocated 72 MB, in spite
    of the fact the system has 400MB ram free.
    I have also tried to execute the IDE from CLI using switches :
    netbeans.exe -J-Xms32m -J-Xmx1024m

    What am i doing wrong here??
     
    evgchech, Dec 26, 2006
    #1
    1. Advertising

  2. Hello,

    NetBans spawns a new process for compiling, which does not inherit the settings
    from the JVM running the IDE.

    In the Project Properties, under "Compiling" you can define additional
    parameters for the call to javac. Remember that the memory options for javac are
    slightly different than for java, so to pass the -Xmx parameter to javac you
    need to specify that as -J-Xmx...

    Thomas

    evgchech wrote on 26.12.2006 16:36:
    > Hello Everybody
    > I am trying to compile pretty big project using NM 5.5 - SDK 1.4
    > During compilation the IDE throws Out of memory exception
    > I have edited the following file
    > ( As explained in :
    > http://performance.netbeans.org/howto/jvmswitches/index.html )
    >
    > C:\Program Files\netbeans-5.5\etc\netbeans.conf
    > -----------------------------------------------------------------------
    > netbeans_default_userdir="${HOME}/.netbeans/5.5"
    > netbeans_default_options="-J-Xms128m -J-Xmx512m -J-Xverify:none"
    > netbeans_jdkhome="C:\Java\jdk1.5.0_09"
    >
    > And still the same exception:
    > -------------------------------------------
    > Compiling 2435 source files to
    > C:\Development\NMS-2.15.05-DLYC\NMS\build
    > The system is out of resources.
    > Consult the following stack trace for details.
    > java.lang.OutOfMemoryError
    > BUILD FAILED (total time: 17 seconds)
    >
    > P.S
    > ------
    > I have 1 GB Ram on my system
    > The strange thing is that Javac fails after allocated 72 MB, in spite
    > of the fact the system has 400MB ram free.
    > I have also tried to execute the IDE from CLI using switches :
    > netbeans.exe -J-Xms32m -J-Xmx1024m
    >
    > What am i doing wrong here??
    >
     
    Thomas Kellerer, Dec 26, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ian Suttle
    Replies:
    2
    Views:
    2,326
    Wolfram Rittmeyer
    Aug 27, 2003
  2. Xiaopeng Xiong

    java.lang.OutOfMemoryError problem

    Xiaopeng Xiong, Nov 14, 2003, in forum: Java
    Replies:
    3
    Views:
    445
    Xiaopeng Xiong
    Nov 15, 2003
  3. Mit Majithia
    Replies:
    6
    Views:
    15,184
    Moazam Raja
    Feb 26, 2004
  4. H.MuthuKumaraRajan

    java.lang.OutOfMemoryError

    H.MuthuKumaraRajan, Apr 3, 2004, in forum: Java
    Replies:
    1
    Views:
    1,234
    e.Morr
    Apr 3, 2004
  5. Goofball
    Replies:
    9
    Views:
    787
    Goofball
    Nov 8, 2006
Loading...

Share This Page