newbie - IIS needed?

Discussion in 'ASP .Net' started by Mark Oliver, Nov 18, 2004.

  1. Mark Oliver

    Mark Oliver Guest

    Hi,

    Do i have to install IIS to develop (but not host) an asp.net application?
    i don't want to install IIS because of the security problems it causes, and
    so far i haven't been able to install IIS because it asks for infocomm.dll
    from XP service pack 1 - and the only place i have seen infocomm.dll is at
    KB q192296 from 1998.


    Thanks,
    Mark
    Mark Oliver, Nov 18, 2004
    #1
    1. Advertising

  2. Mark Oliver

    John M Deal Guest

    Take a look at www.asp.net with the WebMatrix project. WebMatrix comes
    with an alternate personal web server capable of serving up ASP.Net and
    web services. Hope that helps.

    Have A Better One!

    John M Deal, MCP
    Necessity Software

    Mark Oliver wrote:
    > Hi,
    >
    > Do i have to install IIS to develop (but not host) an asp.net application?
    > i don't want to install IIS because of the security problems it causes, and
    > so far i haven't been able to install IIS because it asks for infocomm.dll
    > from XP service pack 1 - and the only place i have seen infocomm.dll is at
    > KB q192296 from 1998.
    >
    >
    > Thanks,
    > Mark
    >
    >
    John M Deal, Nov 18, 2004
    #2
    1. Advertising

  3. U can use ASP.NET WebMAtrix.
    Download it from http://www.asp.net
    GDLUCK

    "Mark Oliver" wrote:

    > Hi,
    >
    > Do i have to install IIS to develop (but not host) an asp.net application?
    > i don't want to install IIS because of the security problems it causes, and
    > so far i haven't been able to install IIS because it asks for infocomm.dll
    > from XP service pack 1 - and the only place i have seen infocomm.dll is at
    > KB q192296 from 1998.
    >
    >
    > Thanks,
    > Mark
    >
    >
    >
    =?Utf-8?B?UGF0cmljay5PLklnZQ==?=, Nov 18, 2004
    #3
  4. Mark Oliver

    Mark Oliver Guest

    Hi,

    i finally got IIS to install by expand ing a couple of files on the WinXP
    SP1a DVD. i still can't make a asp.net job in VS7, now i get a message
    that my server doesn't support asp.net 1.1. WebMatrix worked great on the
    Web Matrix Server! On IIS only the label from myFirstPage showed up. How
    do i get IIS to support asp.net 1.1? Should i reinstall the 1.1 Framework
    update?

    Thanks,
    Mark
    "Mark Oliver" <> wrote in message
    news:...
    > Hi,
    >
    > Do i have to install IIS to develop (but not host) an asp.net

    application?
    > i don't want to install IIS because of the security problems it causes,

    and
    > so far i haven't been able to install IIS because it asks for infocomm.dll
    > from XP service pack 1 - and the only place i have seen infocomm.dll is at
    > KB q192296 from 1998.
    >
    >
    > Thanks,
    > Mark
    >
    >
    Mark Oliver, Nov 18, 2004
    #4
  5. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i

    --
    HTH,
    Kevin Spencer
    ..Net Developer
    Microsoft MVP
    Neither a follower
    nor a lender be.

    "Mark Oliver" <> wrote in message
    news:...
    > Hi,
    >
    > i finally got IIS to install by expand ing a couple of files on the

    WinXP
    > SP1a DVD. i still can't make a asp.net job in VS7, now i get a message
    > that my server doesn't support asp.net 1.1. WebMatrix worked great on

    the
    > Web Matrix Server! On IIS only the label from myFirstPage showed up.

    How
    > do i get IIS to support asp.net 1.1? Should i reinstall the 1.1

    Framework
    > update?
    >
    > Thanks,
    > Mark
    > "Mark Oliver" <> wrote in message
    > news:...
    > > Hi,
    > >
    > > Do i have to install IIS to develop (but not host) an asp.net

    > application?
    > > i don't want to install IIS because of the security problems it causes,

    > and
    > > so far i haven't been able to install IIS because it asks for

    infocomm.dll
    > > from XP service pack 1 - and the only place i have seen infocomm.dll is

    at
    > > KB q192296 from 1998.
    > >
    > >
    > > Thanks,
    > > Mark
    > >
    > >

    >
    >
    >
    Kevin Spencer, Nov 18, 2004
    #5
  6. Mark Oliver

    Mark Oliver Guest

    Now i can develop in VS7 or ASP.NET WebMatrix. Thanks!
    Mark

    "Kevin Spencer" <> wrote in message
    news:...
    > C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\aspnet_regiis.exe -i
    >
    > --
    > HTH,
    > Kevin Spencer
    > .Net Developer
    > Microsoft MVP
    > Neither a follower
    > nor a lender be.
    >
    > "Mark Oliver" <> wrote in message
    > news:...
    > > Hi,
    > >
    > > i finally got IIS to install by expand ing a couple of files on the

    > WinXP
    > > SP1a DVD. i still can't make a asp.net job in VS7, now i get a message
    > > that my server doesn't support asp.net 1.1. WebMatrix worked great on

    > the
    > > Web Matrix Server! On IIS only the label from myFirstPage showed up.

    > How
    > > do i get IIS to support asp.net 1.1? Should i reinstall the 1.1

    > Framework
    > > update?
    > >
    > > Thanks,
    > > Mark
    > > "Mark Oliver" <> wrote in message
    > > news:...
    > > > Hi,
    > > >
    > > > Do i have to install IIS to develop (but not host) an asp.net

    > > application?
    > > > i don't want to install IIS because of the security problems it

    causes,
    > > and
    > > > so far i haven't been able to install IIS because it asks for

    > infocomm.dll
    > > > from XP service pack 1 - and the only place i have seen infocomm.dll

    is
    > at
    > > > KB q192296 from 1998.
    > > >
    > > >
    > > > Thanks,
    > > > Mark
    > > >
    > > >

    > >
    > >
    > >

    >
    >
    Mark Oliver, Nov 19, 2004
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John
    Replies:
    0
    Views:
    511
  2. =?Utf-8?B?Q2h1Y2sgSGFlYmVybGU=?=

    classic IE -> IIS -> SQL Double hop issue - Help needed resolving

    =?Utf-8?B?Q2h1Y2sgSGFlYmVybGU=?=, Oct 14, 2005, in forum: ASP .Net
    Replies:
    2
    Views:
    3,170
    Bruce Barker
    Oct 15, 2005
  3. Thomas Nick
    Replies:
    0
    Views:
    1,877
    Thomas Nick
    Jun 13, 2005
  4. Ryan Macy

    Ideas needed & help needed!

    Ryan Macy, Jul 19, 2006, in forum: Ruby
    Replies:
    2
    Views:
    507
    Ryan Macy
    Jul 19, 2006
  5. John Farold
    Replies:
    0
    Views:
    384
    John Farold
    Aug 29, 2012
Loading...

Share This Page