No ASPNET user account

Discussion in 'ASP .Net' started by =?Utf-8?B?U2Ft?=, Mar 16, 2005.

  1. Hi,

    I have installed .NET but the ASPNET account, which I need to add to virtual
    directories in order to get ASP.NET applications to work, is not on the
    computer. I've checked everywhere and it just hasn't been created.

    I searched the web and all other instances of this problem seem to have been
    solved (or the person has given up on that particular NG) by running
    regiis.exe -i from the .NET Framework directory. However, this doesn't work
    for me.

    I'm running Windows Small Business Server 2003.

    Thanks for your help in advance,

    Sam
     
    =?Utf-8?B?U2Ft?=, Mar 16, 2005
    #1
    1. Advertising

  2. For Windows Server 2003, ASP.NET uses a user account named "NetworkService"
    instead of "ASPNET" by default.

    --
    I hope this helps,
    Steve C. Orr, MCSD, MVP
    http://SteveOrr.net


    "Sam" <> wrote in message
    news:...
    > Hi,
    >
    > I have installed .NET but the ASPNET account, which I need to add to
    > virtual
    > directories in order to get ASP.NET applications to work, is not on the
    > computer. I've checked everywhere and it just hasn't been created.
    >
    > I searched the web and all other instances of this problem seem to have
    > been
    > solved (or the person has given up on that particular NG) by running
    > regiis.exe -i from the .NET Framework directory. However, this doesn't
    > work
    > for me.
    >
    > I'm running Windows Small Business Server 2003.
    >
    > Thanks for your help in advance,
    >
    > Sam
     
    Steve C. Orr [MVP, MCSD], Mar 16, 2005
    #2
    1. Advertising

  3. How did you check for the ASP.NET acct?
    And if not there may try re-installing.
    Patrick


    *** Sent via Developersdex http://www.developersdex.com ***
    Don't just participate in USENET...get rewarded for it!
     
    Patrick Olurotimi Ige, Mar 16, 2005
    #3
  4. Hi Sam,

    Is it running as this account?: NT Authority\NetworkService

    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnnetsec/html/THCMCh20.asp

    If not, you might need repair ASP.NET. Try this from the command line in
    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

    aspnet_regiis.exe -ua
    aspnet_regiis.exe -i -enable
    aspnet_regiis.exe -lv

    If necessary, you can create a custom account to run ASP.NET:

    http://msdn.microsoft.com/library/default.asp?url=/library/en-us/secmod/html/secmod15.asp

    Ken


    "Sam" <> wrote in message
    news:...
    > Hi,
    >
    > I have installed .NET but the ASPNET account, which I need to add to
    > virtual
    > directories in order to get ASP.NET applications to work, is not on the
    > computer. I've checked everywhere and it just hasn't been created.
    >
    > I searched the web and all other instances of this problem seem to have
    > been
    > solved (or the person has given up on that particular NG) by running
    > regiis.exe -i from the .NET Framework directory. However, this doesn't
    > work
    > for me.
    >
    > I'm running Windows Small Business Server 2003.
    >
    > Thanks for your help in advance,
    >
    > Sam
     
    Ken Cox [Microsoft MVP], Mar 16, 2005
    #4
  5. Many thanks Steve. You have no idea how long I spent looking for something
    like that. I thought it may be a different username on SBS but they're
    keeping it a closely guarded secret.

    Thanks again,

    Sam

    "Steve C. Orr [MVP, MCSD]" wrote:

    > For Windows Server 2003, ASP.NET uses a user account named "NetworkService"
    > instead of "ASPNET" by default.
    >
    > --
    > I hope this helps,
    > Steve C. Orr, MCSD, MVP
    > http://SteveOrr.net
    >
    >
    > "Sam" <> wrote in message
    > news:...
    > > Hi,
    > >
    > > I have installed .NET but the ASPNET account, which I need to add to
    > > virtual
    > > directories in order to get ASP.NET applications to work, is not on the
    > > computer. I've checked everywhere and it just hasn't been created.
    > >
    > > I searched the web and all other instances of this problem seem to have
    > > been
    > > solved (or the person has given up on that particular NG) by running
    > > regiis.exe -i from the .NET Framework directory. However, this doesn't
    > > work
    > > for me.
    > >
    > > I'm running Windows Small Business Server 2003.
    > >
    > > Thanks for your help in advance,
    > >
    > > Sam

    >
    >
    >
     
    =?Utf-8?B?U2Ft?=, Mar 16, 2005
    #5
  6. =?Utf-8?B?U2Ft?=

    rtn_dev

    Joined:
    Jan 15, 2009
    Messages:
    1
    Thanks to Ken's post that solved my problem. In the past I had all kinds problems with the ASPNET account but this time the ASPNET account was gone after my computer name was changed and reconnected to the network! Now I got it back.
     
    rtn_dev, Jan 15, 2009
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Joseph D. DeJohn

    ASPNET user account

    Joseph D. DeJohn, Jul 2, 2003, in forum: ASP .Net
    Replies:
    2
    Views:
    394
    Yangtsi River
    Jul 2, 2003
  2. Joseph D. DeJohn

    ASPNET user account

    Joseph D. DeJohn, Jul 5, 2003, in forum: ASP .Net
    Replies:
    1
    Views:
    421
    Benjie Fallar
    Jul 7, 2003
  3. Replies:
    7
    Views:
    702
    Juan T. Llibre
    Mar 23, 2007
  4. nilapenn
    Replies:
    3
    Views:
    691
    Joe Kaplan \(MVP - ADSI\)
    Feb 14, 2005
  5. Replies:
    4
    Views:
    679
    Paul Clement
    Sep 15, 2005
Loading...

Share This Page