not working: <customErrors mode="Off"/>

Discussion in 'ASP .Net' started by Beemer Biker, Jan 24, 2007.

  1. Beemer Biker

    Beemer Biker Guest

    I made the above change to my web.config file so that errors would be
    reported from a remote site as explained in the Server Error:
    Details: To enable the details of this specific error message to be viewable
    on remote machines, please create a <customErrors> tag within a "web.config"
    configuration file located in the root directory of the current web
    application. This <customErrors> tag should then have its "mode" attribute
    set to "Off".

    OK, this had no effect. I verifed the change to web.config did take place.

    I can publish my project to my own localhost IIs, to another system
    running its own XP IIS.

    I can even publish a FP2003 (non- aspx) app to the server that has the
    problem and it runs fine. I cannot get an error message from the server
    indicating the problem. I am publishing using local file as in
    \\servername\acqlib and attempting to run page using
    http://servername/acqlib/default.aspx

    OK - to make a long story short, I got the administrator to run the page
    while logged onto the system and it gave an error at:
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">



    This indicates the server is not running dotnet 2.0 Admin is looking into
    installing dotnet 2.0 on the server.



    My question: Why didnt that error message show up where I could figure out
    the problem myself?




    --
    =======================================================================
    Joseph "Beemer Biker" Stateson
    http://ResearchRiders.org Ask about my 99'R1100RT
    =======================================================================
     
    Beemer Biker, Jan 24, 2007
    #1
    1. Advertising

  2. The way it works, unless I am very much mistaken, is that the server side
    code throws an exception, which you catch and deal with on your client.

    Since your code could not even run - because .NET 2.0 is not present, it
    would not be possible even to load the assembly, never mind create and throw
    an exception.

    That's my best guess anyway.


    Peter


    "Beemer Biker" <> wrote in message
    news:...
    >I made the above change to my web.config file so that errors would be
    >reported from a remote site as explained in the Server Error:
    > Details: To enable the details of this specific error message to be
    > viewable on remote machines, please create a <customErrors> tag within a
    > "web.config" configuration file located in the root directory of the
    > current web application. This <customErrors> tag should then have its
    > "mode" attribute set to "Off".
    >
    > OK, this had no effect. I verifed the change to web.config did take
    > place.
    >
    > I can publish my project to my own localhost IIs, to another system
    > running its own XP IIS.
    >
    > I can even publish a FP2003 (non- aspx) app to the server that has the
    > problem and it runs fine. I cannot get an error message from the server
    > indicating the problem. I am publishing using local file as in
    > \\servername\acqlib and attempting to run page using
    > http://servername/acqlib/default.aspx
    >
    > OK - to make a long story short, I got the administrator to run the page
    > while logged onto the system and it gave an error at:
    > <configuration
    > xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    >
    >
    >
    > This indicates the server is not running dotnet 2.0 Admin is looking into
    > installing dotnet 2.0 on the server.
    >
    >
    >
    > My question: Why didnt that error message show up where I could figure
    > out the problem myself?
    >
    >
    >
    >
    > --
    > =======================================================================
    > Joseph "Beemer Biker" Stateson
    > http://ResearchRiders.org Ask about my 99'R1100RT
    > =======================================================================
    >
    >
     
    Peter Bradley, Jan 24, 2007
    #2
    1. Advertising

  3. Beemer Biker

    bruce barker Guest

    well if the error is parsing the config file, then you can turn error
    reporting on with the web config.

    -- bruce (sqlwork.com)

    Beemer Biker wrote:
    > I made the above change to my web.config file so that errors would be
    > reported from a remote site as explained in the Server Error:
    > Details: To enable the details of this specific error message to be viewable
    > on remote machines, please create a <customErrors> tag within a "web.config"
    > configuration file located in the root directory of the current web
    > application. This <customErrors> tag should then have its "mode" attribute
    > set to "Off".
    >
    > OK, this had no effect. I verifed the change to web.config did take place.
    >
    > I can publish my project to my own localhost IIs, to another system
    > running its own XP IIS.
    >
    > I can even publish a FP2003 (non- aspx) app to the server that has the
    > problem and it runs fine. I cannot get an error message from the server
    > indicating the problem. I am publishing using local file as in
    > \\servername\acqlib and attempting to run page using
    > http://servername/acqlib/default.aspx
    >
    > OK - to make a long story short, I got the administrator to run the page
    > while logged onto the system and it gave an error at:
    > <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
    >
    >
    >
    > This indicates the server is not running dotnet 2.0 Admin is looking into
    > installing dotnet 2.0 on the server.
    >
    >
    >
    > My question: Why didnt that error message show up where I could figure out
    > the problem myself?
    >
    >
    >
    >
     
    bruce barker, Jan 24, 2007
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Greg Burns

    Re: <customErrors mode="Off" />

    Greg Burns, Sep 9, 2004, in forum: ASP .Net
    Replies:
    3
    Views:
    3,889
    Greg Burns
    Sep 9, 2004
  2. Julia
    Replies:
    4
    Views:
    10,324
    Dan Linn
    Jun 29, 2005
  3. Andy Fish

    customErrors mode="Off" does not work

    Andy Fish, Mar 31, 2008, in forum: ASP .Net
    Replies:
    1
    Views:
    655
    Alvin Bruney [ASP.NET MVP]
    Apr 2, 2008
  4. Cam
    Replies:
    0
    Views:
    1,029
  5. Cam
    Replies:
    2
    Views:
    404
Loading...

Share This Page