Older versions of Ruby

Discussion in 'Ruby' started by Dave Ford, Mar 2, 2011.

  1. Dave Ford

    Dave Ford Guest

    Hello,

    I am a total newbie with regard to Ruby. I am finding that the only
    version available for download is 1.9.2. However, I need this as a
    prerequisite for installing Redmine, which requires 1.8.6 or 1.8.7. I
    lack the ability/experience to troubleshoot install issues, so I am
    wondering if 1.9.2 will work with Redmine 1.1.1. My platform is Oracle
    Enterprise Linux, which is basically Red Hat Enterprise Linux. Any help
    or advice would be greatly appreciated.

    Thanks,
    Dave

    --
    Posted via http://www.ruby-forum.com/.
     
    Dave Ford, Mar 2, 2011
    #1
    1. Advertising

  2. Dave Ford

    David Jacobs Guest

    [Note: parts of this message were removed to make it a legal post.]

    I don't know what the package repositories have in Oracle Enterprise Linux, but you can always download 1.8.7 from the Ruby language site and compile it to your liking. (Ruby is written in C.)

    David
    On Tuesday, 1 March 2011 at 9:07 pm, Dave Ford wrote:
    > Hello,
    >
    > I am a total newbie with regard to Ruby. I am finding that the only
    > version available for download is 1.9.2. However, I need this as a
    > prerequisite for installing Redmine, which requires 1.8.6 or 1.8.7. I
    > lack the ability/experience to troubleshoot install issues, so I am
    > wondering if 1.9.2 will work with Redmine 1.1.1. My platform is Oracle
    > Enterprise Linux, which is basically Red Hat Enterprise Linux. Any help
    > or advice would be greatly appreciated.
    >
    > Thanks,
    > Dave
    >
    > --
    > Posted via http://www.ruby-forum.com/.
    >
     
    David Jacobs, Mar 2, 2011
    #2
    1. Advertising

  3. Dave Ford

    Chris Kottom Guest

    [Note: parts of this message were removed to make it a legal post.]

    This problem goes away if you use Ruby Version Manager (rvm). Wayne Seguin
    maintains the tool with a set of Rubies that includes latest patch releases
    of MRI 1.8.6, 1.8.7, 1.9.1, 1.9.2 as well as alternative interpreters.

    See:
    http://rvm.beginrescueend.com/
    <http://rvm.beginrescueend.com/>http://rvm.beginrescueend.com/rvm/install/
    <http://rvm.beginrescueend.com/rvm/install/>

    On Wed, Mar 2, 2011 at 4:25 AM, David Jacobs <
    > wrote:

    > I don't know what the package repositories have in Oracle Enterprise Linux,
    > but you can always download 1.8.7 from the Ruby language site and compile it
    > to your liking. (Ruby is written in C.)
    >
    > David
    > On Tuesday, 1 March 2011 at 9:07 pm, Dave Ford wrote:
    > > Hello,
    > >
    > > I am a total newbie with regard to Ruby. I am finding that the only
    > > version available for download is 1.9.2. However, I need this as a
    > > prerequisite for installing Redmine, which requires 1.8.6 or 1.8.7. I
    > > lack the ability/experience to troubleshoot install issues, so I am
    > > wondering if 1.9.2 will work with Redmine 1.1.1. My platform is Oracle
    > > Enterprise Linux, which is basically Red Hat Enterprise Linux. Any help
    > > or advice would be greatly appreciated.
    > >
    > > Thanks,
    > > Dave
    > >
    > > --
    > > Posted via http://www.ruby-forum.com/.
    > >

    >
     
    Chris Kottom, Mar 2, 2011
    #3
  4. Dave Ford wrote in post #984839:
    > Hello,
    >
    > I am a total newbie with regard to Ruby. I am finding that the only
    > version available for download is 1.9.2.


    Where did you look?

    > My platform is Oracle
    > Enterprise Linux, which is basically Red Hat Enterprise Linux.


    Then by default you'll probably get something ancient like 1.8.1 :)

    A search for "ruby rpm" gives:
    http://www.rpmfind.net/linux/rpm2html/search.php?query=ruby

    The Fedora packages might be usable, but you might have to rebuild them
    from the source RPM. Last time I did this, I think there was a minor
    dependency change needed (one of the X11 libs had changed its name, I'm
    sorry I can't remember exactly which one)

    Otherwise, you can just build from source. All the versions are
    available at ftp://ftp.ruby-lang.org/pub/ruby/

    --
    Posted via http://www.ruby-forum.com/.
     
    Brian Candler, Mar 2, 2011
    #4
  5. Dave Ford

    Dave Ford Guest

    Thank you all for your replies. Unfortunaly, RVM is not an option for
    me, as the server is on a network with no connection to the internet.
    The FTP site is precisely what I was looking for. Again, thank you so
    much for your quick and thorough replies. What a great community! And
    thank you for not slamming a total newbie question.

    Cheers,
    Dave

    --
    Posted via http://www.ruby-forum.com/.
     
    Dave Ford, Mar 4, 2011
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Nikos Kostis
    Replies:
    0
    Views:
    1,109
    Nikos Kostis
    Jul 6, 2003
  2. Curt_C [MVP]

    Obtaining older versions of IE for testing

    Curt_C [MVP], Apr 16, 2004, in forum: ASP .Net
    Replies:
    4
    Views:
    1,276
    Guest
    Apr 16, 2004
  3. Replies:
    3
    Views:
    384
    Lee Fesperman
    Mar 28, 2005
  4. juppie
    Replies:
    1
    Views:
    542
    Gregory Vaughan
    Aug 16, 2003
  5. yawnmoth
    Replies:
    1
    Views:
    435
    Andrew Thompson
    Aug 4, 2008
Loading...

Share This Page