only adminusers can login

Discussion in 'ASP .Net' started by viki, Oct 3, 2004.

  1. viki

    viki Guest

    Hi,
    I got stuck with this for more than a week.

    I developed a asp.net project in my local machine and deployed using
    websetup project. The problem is only the admin users can view the
    page, When other try to view it, it pops up for the login , password
    and domain. I am using windows authentication with identity
    impersonate= true.

    Please can anybody help me with this issue...
    thanks,
    viki
    viki, Oct 3, 2004
    #1
    1. Advertising

  2. viki

    Scott Allen Guest

    Hi viki:

    Can we see the <authentication> and <authorization> sections of the
    web.config? What do you have for <allow> and <deny>?

    --
    Scott
    http://www.OdeToCode.com/

    On 3 Oct 2004 08:45:14 -0700, (viki) wrote:

    >Hi,
    >I got stuck with this for more than a week.
    >
    >I developed a asp.net project in my local machine and deployed using
    >websetup project. The problem is only the admin users can view the
    >page, When other try to view it, it pops up for the login , password
    >and domain. I am using windows authentication with identity
    >impersonate= true.
    >
    >Please can anybody help me with this issue...
    >thanks,
    >viki
    Scott Allen, Oct 3, 2004
    #2
    1. Advertising

  3. viki

    viki Guest

    Hi Scott,
    Thanks for your resposne,
    i have used allow user="*" for authorization, and authentication is windows.

    Do u have any idea why it allows only admin users, could u please help me..

    Thanks in advance,
    Viki
    viki, Oct 4, 2004
    #3
  4. viki

    Scott Allen Guest

    HI viki:

    This could also be a browser setting. In IE, look at Tools -> Internet
    Options -> Security -> Custom Level (for the appropriate zone). Scroll
    down to the User Authentication : Logon area and see if the setting is
    set to prompt.

    --
    Scott
    http://www.OdeToCode.com/

    On 3 Oct 2004 18:35:39 -0700, (viki) wrote:

    >Hi Scott,
    >Thanks for your resposne,
    >i have used allow user="*" for authorization, and authentication is windows.
    >
    >Do u have any idea why it allows only admin users, could u please help me..
    >
    >Thanks in advance,
    >Viki
    Scott Allen, Oct 4, 2004
    #4
  5. viki

    viki Guest

    Hi Scott,
    I looked into the user authentication of internet exploret it is
    automatic logon within intranet zone. Moreover the users can access
    the other web applicaiton which has html pages without any logon
    prompt. THis is the first asp.net web application we developed for the
    intranet site.

    please help me

    Thanks again,
    Viki
    viki, Oct 4, 2004
    #5
  6. viki

    Scott Allen Guest

    Hi Viki:

    I know these authentication issues can be difficult to troubleshoot.
    One technique I've used in the past is to enable auditing and see what
    identity is actually trying to login. See the following document,
    particularly the references at the end:
    http://support.microsoft.com/default.aspx?scid=kb;en-us;300549&sd=tech
    Sometimes these problems are hard to track down because it might be
    caused by a disabled account, and you can't find this out till you
    enable auditing to see what is happening.

    You also may want to try removing authentication in both web.config
    (and make sure the IIS directory secfurity allows anonymous access).

    HTH,

    --
    Scott
    http://www.OdeToCode.com/

    On 4 Oct 2004 06:41:45 -0700, (viki) wrote:
    >Hi Scott,
    >I looked into the user authentication of internet exploret it is
    >automatic logon within intranet zone. Moreover the users can access
    >the other web applicaiton which has html pages without any logon
    >prompt. THis is the first asp.net web application we developed for the
    >intranet site.
    >
    >please help me
    >
    >Thanks again,
    >Viki
    Scott Allen, Oct 4, 2004
    #6
  7. viki

    viki Guest

    Hi Scott,
    Today i tried for the unanonymous access but i didnot change the
    web.config file which has been set to identity impersonate=true. Now
    it does not ask for login and password name.

    But i want to restrict the users based on the NTFS , when i tried to
    check the Integrate windows authentication it asks for the login and
    password.How could i restrict the users based on the network login
    id..

    Thanks for all your help,
    Vik


    Scott Allen <bitmask@[nospam].fred.net> wrote in message news:<>...
    > Hi Viki:
    >
    > I know these authentication issues can be difficult to troubleshoot.
    > One technique I've used in the past is to enable auditing and see what
    > identity is actually trying to login. See the following document,
    > particularly the references at the end:
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;300549&sd=tech
    > Sometimes these problems are hard to track down because it might be
    > caused by a disabled account, and you can't find this out till you
    > enable auditing to see what is happening.
    >
    > You also may want to try removing authentication in both web.config
    > (and make sure the IIS directory secfurity allows anonymous access).
    >
    > HTH,
    >
    > --
    > Scott
    > http://www.OdeToCode.com/
    >
    >
    viki, Oct 5, 2004
    #7
  8. viki

    Scott Allen Guest

    Hi Viki:

    It should be working for you. Are the users on the same domain as the
    web server?

    --
    Scott
    http://www.OdeToCode.com/

    On 4 Oct 2004 17:28:35 -0700, (viki) wrote:

    >Hi Scott,
    >Today i tried for the unanonymous access but i didnot change the
    >web.config file which has been set to identity impersonate=true. Now
    >it does not ask for login and password name.
    >
    >But i want to restrict the users based on the NTFS , when i tried to
    >check the Integrate windows authentication it asks for the login and
    >password.How could i restrict the users based on the network login
    >id..
    >
    >Thanks for all your help,
    >Vik
    >
    >
    >Scott Allen <bitmask@[nospam].fred.net> wrote in message news:<>...
    >> Hi Viki:
    >>
    >> I know these authentication issues can be difficult to troubleshoot.
    >> One technique I've used in the past is to enable auditing and see what
    >> identity is actually trying to login. See the following document,
    >> particularly the references at the end:
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;300549&sd=tech
    >> Sometimes these problems are hard to track down because it might be
    >> caused by a disabled account, and you can't find this out till you
    >> enable auditing to see what is happening.
    >>
    >> You also may want to try removing authentication in both web.config
    >> (and make sure the IIS directory secfurity allows anonymous access).
    >>
    >> HTH,
    >>
    >> --
    >> Scott
    >> http://www.OdeToCode.com/
    >>
    >>
    Scott Allen, Oct 5, 2004
    #8
  9. viki

    viki Guest

    Hi Scott,
    When i set the integrated windows Authentication, identity impersonate
    to true in web.config and i have also set in the iis directory access
    to everyone group to check whether it works. It allow access only to
    admin users not to everyone , it asks for the login and password and
    only allows for the admin login and passwords.

    Do i need to set anything else other than this...

    Thanks
    Viki



    Scott Allen <bitmask@[nospam].fred.net> wrote in message news:<>...
    > Hi Viki:
    >
    > It should be working for you. Are the users on the same domain as the
    > web server?
    >
    > --
    > Scott
    > http://www.OdeToCode.com/
    >
    viki, Oct 5, 2004
    #9
  10. viki

    Scott Allen Guest

    I'm afraid I really can't think of anything else!

    --s

    On 5 Oct 2004 12:29:44 -0700, (viki) wrote:

    >Hi Scott,
    >When i set the integrated windows Authentication, identity impersonate
    >to true in web.config and i have also set in the iis directory access
    >to everyone group to check whether it works. It allow access only to
    >admin users not to everyone , it asks for the login and password and
    >only allows for the admin login and passwords.
    >
    >Do i need to set anything else other than this...
    >
    >Thanks
    >Viki
    >
    >
    >
    >Scott Allen <bitmask@[nospam].fred.net> wrote in message news:<>...
    >> Hi Viki:
    >>
    >> It should be working for you. Are the users on the same domain as the
    >> web server?
    >>
    >> --
    >> Scott
    >> http://www.OdeToCode.com/
    >>


    --
    Scott
    http://www.OdeToCode.com/
    Scott Allen, Oct 5, 2004
    #10
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ad
    Replies:
    2
    Views:
    706
  2. ad

    Can login with Login Control

    ad, Aug 28, 2006, in forum: ASP .Net
    Replies:
    9
    Views:
    932
    Tim_Mac
    Aug 31, 2006
  3. Sasquatch
    Replies:
    2
    Views:
    1,278
    Sasquatch
    Oct 3, 2006
  4. Sasquatch
    Replies:
    2
    Views:
    440
    Sasquatch
    Oct 4, 2006
  5. Colin Graham

    Login to admin system through login screen only

    Colin Graham, Apr 10, 2005, in forum: ASP .Net Security
    Replies:
    1
    Views:
    234
    Joseph MCAD
    Apr 11, 2005
Loading...

Share This Page