Operation not Allowed

Discussion in 'ASP General' started by Ron Hinds, Sep 5, 2008.

  1. Ron Hinds

    Ron Hinds Guest

    I recently moved my ASP application from W2K SP4 to W2K3 Web Edition SP2.
    Previously, everything worked fine. Now I get the following error from a
    couple of pages that read in and process a XML document:

    Event Type: Error
    Event Source: Active Server Pages
    Event Category: None
    Event ID: 5
    Date: 9/4/2008
    Time: 11:58:46 PM
    User: N/A
    Computer: XXXXX
    Description:
    Error: File /ASPPage.asp Line 27 Operation not Allowed.

    Here is the line of code in question:

    oDocIn.load(Request.BinaryRead(Request.TotalBytes))

    oDocIn is defined as follows:

    Set oDocIn = Server.CreateObject("MSXML2.DOMDocument")

    As I said, this code was working fine on the old web server. Does anyone
    have any ideas? Thanks!
     
    Ron Hinds, Sep 5, 2008
    #1
    1. Advertising

  2. "Ron Hinds" <> wrote in message
    news:...
    >I recently moved my ASP application from W2K SP4 to W2K3 Web Edition SP2.
    >Previously, everything worked fine. Now I get the following error from a
    >couple of pages that read in and process a XML document:
    >
    > Event Type: Error
    > Event Source: Active Server Pages
    > Event Category: None
    > Event ID: 5
    > Date: 9/4/2008
    > Time: 11:58:46 PM
    > User: N/A
    > Computer: XXXXX
    > Description:
    > Error: File /ASPPage.asp Line 27 Operation not Allowed.
    >
    > Here is the line of code in question:
    >
    > oDocIn.load(Request.BinaryRead(Request.TotalBytes))
    >
    > oDocIn is defined as follows:
    >
    > Set oDocIn = Server.CreateObject("MSXML2.DOMDocument")
    >
    > As I said, this code was working fine on the old web server. Does anyone
    > have any ideas? Thanks!
    >


    How big is the entity body you are loading. Its likely larger than 200K.

    IIS6 limits the AspMaxRequestEntityBody to 200K. (It was something much
    larger on IIS5). You will need to modify this value to allow the larger
    body.

    --
    Anthony Jones - MVP ASP/ASP.NET
     
    Anthony Jones, Sep 5, 2008
    #2
    1. Advertising

  3. Ron Hinds

    Ron Hinds Guest

    "Anthony Jones" <> wrote in message
    news:%...
    > IIS6 limits the AspMaxRequestEntityBody to 200K. (It was something much
    > larger on IIS5). You will need to modify this value to allow the larger
    > body.


    Is that a regsitry setting?
     
    Ron Hinds, Sep 5, 2008
    #3
  4. "Ron Hinds" <> wrote in message
    news:...
    > "Anthony Jones" <> wrote in message
    > news:%...
    >> IIS6 limits the AspMaxRequestEntityBody to 200K. (It was something much
    >> larger on IIS5). You will need to modify this value to allow the larger
    >> body.

    >
    > Is that a regsitry setting?
    >


    No its a Metabase setting. In IIS there is Metabase.xml file tuck away with
    all the settings. Many IIS admins well tinker with this directly but its
    better to use a tool whose job it is to do that.

    If you haven't already got the resource kit:-

    http://www.microsoft.com/downloads/...ee-a71a-4c73-b628-ade629c89499&displaylang=en

    Now you could set this value for your entire site but it would be better to
    limit it to only the directories (or even files that need it). The purpose
    of the setting is to limit your site exsposure to inadvertant or malicous
    attempt to tie up your site by sending ludicrously large amounts of data to
    it.

    In IIS Manager find the directory or file you want to apply the setting to.
    Open its properties and look at the enable content expiration check box on
    the http headers tab. If its on skip the rest of this paragraph. If its
    off turn it on, apply, turn it off and OK. This creates a path to the
    folder or file in the metabase and saves a fair bit of faffing about.

    Now open the MetaBase explorer from the IIS resources.

    Navigate down the path LM\W3SVC\xxxx\root\yourpath where xxxx is the site ID
    (if you have multiple sites click on each and the ServerComment value in the
    right hand pane will tell which one it is) and yourpath is the path down to
    the folder or file you want to apply the setting to.

    Right mouse click the folder or file in the tree and choose New | DWord
    record. In the Record Name or Identifier drop down choose
    AspMaxRequestEntityBody (or simply type 7053 in the same box). Click OK.

    Double click the value that has appeared in the right hand pane and enter
    the max bytes you want to allow.




    --
    Anthony Jones - MVP ASP/ASP.NET
     
    Anthony Jones, Sep 6, 2008
    #4
  5. Ron Hinds

    Ron Hinds Guest

    "Anthony Jones" <> wrote in message
    news:...
    > "Ron Hinds" <> wrote in message
    > news:...
    >> "Anthony Jones" <> wrote in message
    >> news:%...
    >>> IIS6 limits the AspMaxRequestEntityBody to 200K. (It was something much
    >>> larger on IIS5). You will need to modify this value to allow the larger
    >>> body.

    >>
    >> Is that a regsitry setting?
    >>

    >
    > No its a Metabase setting. In IIS there is Metabase.xml file tuck away
    > with all the settings. Many IIS admins well tinker with this directly but
    > its better to use a tool whose job it is to do that.
    >
    > If you haven't already got the resource kit:-
    >
    > http://www.microsoft.com/downloads/...ee-a71a-4c73-b628-ade629c89499&displaylang=en
    >
    > Now you could set this value for your entire site but it would be better
    > to limit it to only the directories (or even files that need it). The
    > purpose of the setting is to limit your site exsposure to inadvertant or
    > malicous attempt to tie up your site by sending ludicrously large amounts
    > of data to it.
    >
    > In IIS Manager find the directory or file you want to apply the setting
    > to. Open its properties and look at the enable content expiration check
    > box on the http headers tab. If its on skip the rest of this paragraph.
    > If its off turn it on, apply, turn it off and OK. This creates a path to
    > the folder or file in the metabase and saves a fair bit of faffing about.
    >
    > Now open the MetaBase explorer from the IIS resources.
    >
    > Navigate down the path LM\W3SVC\xxxx\root\yourpath where xxxx is the site
    > ID (if you have multiple sites click on each and the ServerComment value
    > in the right hand pane will tell which one it is) and yourpath is the path
    > down to the folder or file you want to apply the setting to.
    >
    > Right mouse click the folder or file in the tree and choose New | DWord
    > record. In the Record Name or Identifier drop down choose
    > AspMaxRequestEntityBody (or simply type 7053 in the same box). Click OK.
    >
    > Double click the value that has appeared in the right hand pane and enter
    > the max bytes you want to allow.
    >
    >
    >
    >
    > --
    > Anthony Jones - MVP ASP/ASP.NET
    >


    Much Thanks!
     
    Ron Hinds, Sep 8, 2008
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. ronaldlee
    Replies:
    0
    Views:
    2,394
    ronaldlee
    Jan 23, 2005
  2. Replies:
    1
    Views:
    2,134
    Kevin Spencer
    Aug 10, 2005
  3. Dave
    Replies:
    2
    Views:
    768
  4. Rishi
    Replies:
    1
    Views:
    3,759
    Alexey Smirnov
    Nov 11, 2009
  5. Iñaki Baz Castillo
    Replies:
    13
    Views:
    535
    Iñaki Baz Castillo
    May 1, 2011
Loading...

Share This Page