Page works fine with internal webserver but not on IIS

Discussion in 'ASP .Net' started by Eric, Dec 5, 2005.

  1. Eric

    Eric Guest

    Hi,

    I developed my ASPX page on the build in webserver of VS2005 but when I try
    to run it on IIS it doesn't work.

    The error I get is:

    XML Parsing Error: not well-formed
    Location:
    file:///E:/VB.NET%20projecten/website%20field%20service/PrecompiledWeb/website%20field%20service/fshome.aspx?page=home
    Line Number 1, Column 2:<%@ page language="VB" autoeventwireup="false"
    inherits="_Default, App_Web_hrphk8cp" %>
    -^


    What does it mean and what must/can I do to make it work on the IIS server
    because that is what they are using at the office?

    rg,
    Eric
     
    Eric, Dec 5, 2005
    #1
    1. Advertising

  2. Eric

    Rajeev Gopal Guest

    Hello Eric,

    When you created the project in VS2005, did you opt for HTTP as the
    Location type of File Based as location type?
    For running of IIS, you should set it as HTTP.

    Thanks,
    Rajeev
     
    Rajeev Gopal, Dec 5, 2005
    #2
    1. Advertising

  3. Eric

    Eric Guest

    Hi,

    Thanks for answering.

    Can you point me in the right direction on how to do this?

    I assume I can still switch?

    rg,
    Eric


    "Rajeev Gopal" <> schreef in bericht
    news:...
    > Hello Eric,
    >
    > When you created the project in VS2005, did you opt for HTTP as the
    > Location type of File Based as location type?
    > For running of IIS, you should set it as HTTP.
    >
    > Thanks,
    > Rajeev
    >
     
    Eric, Dec 5, 2005
    #3
  4. Eric

    Rajeev Gopal Guest

    Hi Eric,

    I am not sure whether you can switch them....

    What is happening is that by default, you create the project using File
    System Based. As I said, you can change the option, when creating the
    project.

    Now what you can do is :
    1. Go to IIS and create a new virtual directory.
    2. go the folder, where your aspx files are saved. copy all the files
    and paste them to the new directory
    just created.

    Now access the site as:
    http://localhost/(New Folder Created)/Filename.aspx.

    This should work.

    Alternative is, you might want to create a new project (this time, opt
    for HTTP.)

    P.S: I will check whether you can switch in between or not.

    Cheers!
    Rajeev
     
    Rajeev Gopal, Dec 5, 2005
    #4
  5. Eric

    Eric Guest

    Thanks Rajeev, I'll try this...


    "Rajeev Gopal" <> schreef in bericht
    news:...
    > Hi Eric
    >
    > I am not sure whether you can switch them....
    >
    > What is happening is that by default, you create the project using File
    > System Based. As I said, you can change the option, when creating the
    > project.
    >
    > Now what you can do is :
    > 1. Go to IIS and create a new virtual directory.
    > 2. go the folder, where your aspx files are saved. copy all the files
    > and paste them to the new directory
    > just created.
    >
    > Now access the site as:
    > http://localhost/(New Folder Created)/Filename.aspx.
    >
    > This should work.
    >
    > Alternative is, you might want to create a new project (this time, opt
    > for HTTP.)
    >
    > P.S: I will check whether you can switch in between or not.
    >
    > Cheers!
    > Rajeev
    >
     
    Eric, Dec 5, 2005
    #5
  6. Eric

    Eric Guest

    It works, Rajeev.

    Thanks for your help.

    rg,
    Eric


    "Rajeev Gopal" <> schreef in bericht
    news:...
    > Hi Eric,
    >
    > I am not sure whether you can switch them....
    >
    > What is happening is that by default, you create the project using File
    > System Based. As I said, you can change the option, when creating the
    > project.
    >
    > Now what you can do is :
    > 1. Go to IIS and create a new virtual directory.
    > 2. go the folder, where your aspx files are saved. copy all the files
    > and paste them to the new directory
    > just created.
    >
    > Now access the site as:
    > http://localhost/(New Folder Created)/Filename.aspx.
    >
    > This should work.
    >
    > Alternative is, you might want to create a new project (this time, opt
    > for HTTP.)
    >
    > P.S: I will check whether you can switch in between or not.
    >
    > Cheers!
    > Rajeev
    >
     
    Eric, Dec 5, 2005
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Adam P
    Replies:
    0
    Views:
    483
    Adam P
    Sep 27, 2005
  2. catweezle2010
    Replies:
    0
    Views:
    402
    catweezle2010
    Jan 26, 2006
  3. Mufasa
    Replies:
    2
    Views:
    342
    Michael Nemtsev
    Apr 19, 2007
  4. .spider
    Replies:
    2
    Views:
    517
    Juan T. Llibre
    Jul 17, 2007
  5. guy
    Replies:
    2
    Views:
    444
    Aaron Bertrand [MVP]
    Feb 23, 2004
Loading...

Share This Page