Parser Error on the base project created by Visual Studio

Discussion in 'ASP .Net Security' started by Maras, Oct 9, 2003.

  1. Maras

    Maras Guest

    Hi,

    [...]

    > Is it me or am I doing something wrong???


    I think you should configure your web directory in IIS as application.

    Cheers,
    --
    Maras
    Maras, Oct 9, 2003
    #1
    1. Advertising

  2. Maras

    CES Guest

    All,
    I've just started to use VBStudio, up tell now I've coded with note pad, so
    this is all new to me. I'm trying to create my first project but I'm running
    into problems.

    I've created a base ASP.net web application and used the default name
    WebApplication1. Without doing !!anything!! to the WebForm1.aspx I build the
    project by going to File Menu Build\Build Solution (Ctr+Shift+B) :

    In the Output window I get:

    ------ Build started: Project: WebApplication1, Configuration: Debug
    ..NET ------
    Preparing resources...
    Updating references...
    Performing main compilation...
    Building satellite assemblies...
    ---------------------- Done ----------------------
    Build: 1 succeeded, 0 failed, 0 skipped


    I then when I hit F5 to run the project, and IE displays this Parser Error
    message:

    Parser Error Message: Could not load type 'WebApplication1.Global'.

    Source Error:

    Line 1: <%@ Application Codebehind="Global.asax.vb"
    Inherits="WebApplication1.Global" %>

    Source File: \\server\\_temp\WebApplication1\global.asax Line: 1

    I've checked the security privileges on the WebApplication1 and the
    "aspnet_wp account" and the "Internet Guest Account" have "Full Control"
    access. Additionally the "aspnet_wp account" has full privileges on
    Windows\Microsoft.NET\Framework\v1.1.4322 and
    WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.

    The only way I can get the page WebForm1.aspx to load and not throw an error
    is by removing both of the Inherits properties from these files:

    WebForm1.aspx:
    <%@ Page Language="vb" AutoEventWireup="false"
    Inherits="WebApplication1.WebForm1"%>

    Global.asax:
    <%@ Application Codebehind="Global.asax.vb"
    Inherits="WebApplication1.Global" %>

    But that doesn't seem to make any sense, if the page won't work as is why
    are the Inherits="WebApplication1.WebForm1 and
    Inherits="WebApplication1.Global" setup by default???

    Is it me or am I doing something wrong???
    CES, Oct 9, 2003
    #2
    1. Advertising

  3. Maras

    CES Guest

    I"m not sure what you mean but Application Settings under the Home Directory
    Tab for the web site have values of
    Application Name : Default Application
    Starting point: <Default Web Site>
    Execute Permissions: Scripts Only
    Application Protection: Medium (Pooled)

    Which are the defaults.

    CES



    "Maras" <> wrote in message
    news:bm3hck$jmb$...
    > Hi,
    >
    > [...]
    >
    > > Is it me or am I doing something wrong???

    >
    > I think you should configure your web directory in IIS as application.
    >
    > Cheers,
    > --
    > Maras
    CES, Oct 9, 2003
    #3
  4. Maras

    George Durzi Guest

    try running aspnet_regiis.exe -c
    it sits in
    c:\WINNT\Microsoft.NET\Framework\v1.0.3705\
    or wherever your framework is installed


    "CES" <> wrote in message
    news:...
    > I"m not sure what you mean but Application Settings under the Home

    Directory
    > Tab for the web site have values of
    > Application Name : Default Application
    > Starting point: <Default Web Site>
    > Execute Permissions: Scripts Only
    > Application Protection: Medium (Pooled)
    >
    > Which are the defaults.
    >
    > CES
    >
    >
    >
    > "Maras" <> wrote in message
    > news:bm3hck$jmb$...
    > > Hi,
    > >
    > > [...]
    > >
    > > > Is it me or am I doing something wrong???

    > >
    > > I think you should configure your web directory in IIS as application.
    > >
    > > Cheers,
    > > --
    > > Maras

    >
    >
    George Durzi, Oct 9, 2003
    #4
  5. Maras

    CES Guest

    George,
    Tried your suggestion but I'm still getting the error message...I did
    however isolate the problem to IIS and not the code (I copied the
    application to me web site and it runs just fine).

    Any other suggestions would be appreciated.
    CES

    "George Durzi" <gdurzi@nospam_hotmail.com> wrote in message
    news:%...
    > try running aspnet_regiis.exe -c
    > it sits in
    > c:\WINNT\Microsoft.NET\Framework\v1.0.3705\
    > or wherever your framework is installed
    >
    >
    > "CES" <> wrote in message
    > news:...
    > > I"m not sure what you mean but Application Settings under the Home

    > Directory
    > > Tab for the web site have values of
    > > Application Name : Default Application
    > > Starting point: <Default Web Site>
    > > Execute Permissions: Scripts Only
    > > Application Protection: Medium (Pooled)
    > >
    > > Which are the defaults.
    > >
    > > CES
    > >
    > >
    > >
    > > "Maras" <> wrote in message
    > > news:bm3hck$jmb$...
    > > > Hi,
    > > >
    > > > [...]
    > > >
    > > > > Is it me or am I doing something wrong???
    > > >
    > > > I think you should configure your web directory in IIS as application.
    > > >
    > > > Cheers,
    > > > --
    > > > Maras

    > >
    > >

    >
    >
    CES, Oct 9, 2003
    #5
  6. Maras

    CES Guest

    All,
    I've started a new threed please reply their - Setting up a Web Application
    on IIS 5.1
    CES
    "CES" <> wrote in message
    news:...
    > All,
    > I've just started to use VBStudio, up tell now I've coded with note pad,

    so
    > this is all new to me. I'm trying to create my first project but I'm

    running
    > into problems.
    >
    > I've created a base ASP.net web application and used the default name
    > WebApplication1. Without doing !!anything!! to the WebForm1.aspx I build

    the
    > project by going to File Menu Build\Build Solution (Ctr+Shift+B) :
    >
    > In the Output window I get:
    >
    > ------ Build started: Project: WebApplication1, Configuration: Debug
    > .NET ------
    > Preparing resources...
    > Updating references...
    > Performing main compilation...
    > Building satellite assemblies...
    > ---------------------- Done ----------------------
    > Build: 1 succeeded, 0 failed, 0 skipped
    >
    >
    > I then when I hit F5 to run the project, and IE displays this Parser Error
    > message:
    >
    > Parser Error Message: Could not load type 'WebApplication1.Global'.
    >
    > Source Error:
    >
    > Line 1: <%@ Application Codebehind="Global.asax.vb"
    > Inherits="WebApplication1.Global" %>
    >
    > Source File: \\server\\_temp\WebApplication1\global.asax Line: 1
    >
    > I've checked the security privileges on the WebApplication1 and the
    > "aspnet_wp account" and the "Internet Guest Account" have "Full Control"
    > access. Additionally the "aspnet_wp account" has full privileges on
    > Windows\Microsoft.NET\Framework\v1.1.4322 and
    > WINDOWS\Microsoft.NET\Framework\v1.0.3705 directories.
    >
    > The only way I can get the page WebForm1.aspx to load and not throw an

    error
    > is by removing both of the Inherits properties from these files:
    >
    > WebForm1.aspx:
    > <%@ Page Language="vb" AutoEventWireup="false"
    > Inherits="WebApplication1.WebForm1"%>
    >
    > Global.asax:
    > <%@ Application Codebehind="Global.asax.vb"
    > Inherits="WebApplication1.Global" %>
    >
    > But that doesn't seem to make any sense, if the page won't work as is why
    > are the Inherits="WebApplication1.WebForm1 and
    > Inherits="WebApplication1.Global" setup by default???
    >
    > Is it me or am I doing something wrong???
    >
    >
    CES, Oct 9, 2003
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Maras
    Replies:
    5
    Views:
    663
  2. wh
    Replies:
    2
    Views:
    509
    Cowboy \(Gregory A. Beamer\)
    Jan 16, 2004
  3. Thirumalai
    Replies:
    0
    Views:
    651
    Thirumalai
    May 22, 2006
  4. rockdale
    Replies:
    1
    Views:
    600
    Juan T. Llibre
    Aug 23, 2006
  5. xman
    Replies:
    0
    Views:
    486
Loading...

Share This Page