Persistent 'nonsecure content' message when loading a file into an IFRAME element

Discussion in 'ASP .Net Security' started by Helen, Oct 15, 2003.

  1. Helen

    Helen Guest

    Guys and gals,

    I am having a problem with an IFRAME that is embedded into an ASPX
    page (ASP.NET application). The IFRAME is originally empty (src='').
    When a user selects a date from the drop-down list box above the
    IFRAME, the IFRAME loads the content of a file on the local machine
    (c:\bds\blahblahblah.txt).

    The application that contains this page is running on a secure socket
    layer (SSL). When the IFRAME tries to load the file, a message pops up
    stating that "The page you are about to view contains both secure and
    nonsecure content. Would you like to view the nonsecure content?".

    I desperately need to get rid of this message. I have tried every
    trick in the book, and so far, no dice. Here's what I have tried:

    1. Setting security setting for Intranet to Low.
    2. Adding the machine itself to its own list of trusted sites. Setting
    trusted site security to Low.
    3. Enabling everything in the security contents.
    4. Enabling 'Display Mixed Contents'. Then disabling it. Then setting
    it to Prompt. None of this made any difference.
    5. Setting the src attribute of the IFRAME to blank (''). Setting it
    to blank.html. Setting it to javascript:parent.nullSrc();, where
    nullSrc() function in the parent page returns ''.
    6. Setting application trust to full trust.
    7. Installing every patch available. We are running IE 6 with SP1.
    8. Sharing the folder containing the files I am trying to load. Web
    sharing the same folder.

    I can't think of other stuff, but I am sure I tried more than that. I
    really hope you can help me with this, I am kinda running our of
    creative ideas on resolving this problem.

    Many thanks for your attention,
    Helen.
     
    Helen, Oct 15, 2003
    #1
    1. Advertising

  2. Helen

    bruce barker Guest

    in IE under

    Internetnet Options->Advanced->Security
    uncheck "Warn if changing between secure and unsecure mode"




    "Helen" <> wrote in message
    news:...
    > Guys and gals,
    >
    > I am having a problem with an IFRAME that is embedded into an ASPX
    > page (ASP.NET application). The IFRAME is originally empty (src='').
    > When a user selects a date from the drop-down list box above the
    > IFRAME, the IFRAME loads the content of a file on the local machine
    > (c:\bds\blahblahblah.txt).
    >
    > The application that contains this page is running on a secure socket
    > layer (SSL). When the IFRAME tries to load the file, a message pops up
    > stating that "The page you are about to view contains both secure and
    > nonsecure content. Would you like to view the nonsecure content?".
    >
    > I desperately need to get rid of this message. I have tried every
    > trick in the book, and so far, no dice. Here's what I have tried:
    >
    > 1. Setting security setting for Intranet to Low.
    > 2. Adding the machine itself to its own list of trusted sites. Setting
    > trusted site security to Low.
    > 3. Enabling everything in the security contents.
    > 4. Enabling 'Display Mixed Contents'. Then disabling it. Then setting
    > it to Prompt. None of this made any difference.
    > 5. Setting the src attribute of the IFRAME to blank (''). Setting it
    > to blank.html. Setting it to javascript:parent.nullSrc();, where
    > nullSrc() function in the parent page returns ''.
    > 6. Setting application trust to full trust.
    > 7. Installing every patch available. We are running IE 6 with SP1.
    > 8. Sharing the folder containing the files I am trying to load. Web
    > sharing the same folder.
    >
    > I can't think of other stuff, but I am sure I tried more than that. I
    > really hope you can help me with this, I am kinda running our of
    > creative ideas on resolving this problem.
    >
    > Many thanks for your attention,
    > Helen.
     
    bruce barker, Oct 16, 2003
    #2
    1. Advertising

  3. Helen

    Helen Guest

    Bruce:

    Thanks for your reply. I tried that, and it had no effect, before and
    after I rebooted.

    Helen.
     
    Helen, Oct 16, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Helen
    Replies:
    2
    Views:
    1,733
    Helen
    Oct 16, 2003
  2. Brent Burkart
    Replies:
    1
    Views:
    354
    Rob Meade
    Jan 27, 2004
  3. VB Programmer
    Replies:
    7
    Views:
    8,111
    VB Programmer
    Apr 29, 2005
  4. gk
    Replies:
    7
    Views:
    1,004
    Tom Anderson
    Oct 12, 2010
  5. nc
    Replies:
    0
    Views:
    162
Loading...

Share This Page