[Please Help] simple problem

Discussion in 'ASP .Net Web Services' started by Eder, Jan 9, 2004.

  1. Eder

    Eder Guest

    Hello,

    I am a newbie to Web Services. I have been struggling with a very strange
    problem for days. I want to write a simple "Hello World" Web Service, which
    I want to invoke
    from a browser. The automatic test web interface that IIS manages doesn't
    work, when i enter
    http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx, it
    launchs me to .NET IDE and open the content of Service1.asmx only. My IIS
    5.0 server is working since i try http://localhost return my home page
    without any problem. I am using XP SP1 professional with .NET 2002.
    Many many thx !!!

    Best Rgds
    Eder
    Eder, Jan 9, 2004
    #1
    1. Advertising

  2. Eder

    Jan Tielens Guest

    Probably you haven't configured the HelloWorld directory as a Virtual
    Directory in IIS. To so, choose Add New Virtual Directory in the IIS MMC
    plugin, give it a name and point it to the location of your project. Then
    you can use it by browsing to
    http://localhost/NameOfVirtualDir/Service1.ASMX.

    Although if you create a new Web Project in Visual Studio, these things
    should be set automatically.

    --
    Greetz

    Jan Tielens
    ________________________________
    Read my weblog: http://weblogs.asp.net/jan


    "Eder" <> wrote in message
    news:...
    > Hello,
    >
    > I am a newbie to Web Services. I have been struggling with a very

    strange
    > problem for days. I want to write a simple "Hello World" Web Service,

    which
    > I want to invoke
    > from a browser. The automatic test web interface that IIS manages doesn't
    > work, when i enter
    > http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx, it
    > launchs me to .NET IDE and open the content of Service1.asmx only. My IIS
    > 5.0 server is working since i try http://localhost return my home page
    > without any problem. I am using XP SP1 professional with .NET 2002.
    > Many many thx !!!
    >
    > Best Rgds
    > Eder
    >
    >
    Jan Tielens, Jan 9, 2004
    #2
    1. Advertising

  3. Eder

    Eder Guest

    thx, it still doesn't work
    "Jan Tielens" <> wrote in message
    news:#...
    > Probably you haven't configured the HelloWorld directory as a Virtual
    > Directory in IIS. To so, choose Add New Virtual Directory in the IIS MMC
    > plugin, give it a name and point it to the location of your project. Then
    > you can use it by browsing to
    > http://localhost/NameOfVirtualDir/Service1.ASMX.
    >
    > Although if you create a new Web Project in Visual Studio, these things
    > should be set automatically.
    >
    > --
    > Greetz
    >
    > Jan Tielens
    > ________________________________
    > Read my weblog: http://weblogs.asp.net/jan
    >
    >
    > "Eder" <> wrote in message
    > news:...
    > > Hello,
    > >
    > > I am a newbie to Web Services. I have been struggling with a very

    > strange
    > > problem for days. I want to write a simple "Hello World" Web Service,

    > which
    > > I want to invoke
    > > from a browser. The automatic test web interface that IIS manages

    doesn't
    > > work, when i enter
    > > http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx, it
    > > launchs me to .NET IDE and open the content of Service1.asmx only. My

    IIS
    > > 5.0 server is working since i try http://localhost return my home page
    > > without any problem. I am using XP SP1 professional with .NET 2002.
    > > Many many thx !!!
    > >
    > > Best Rgds
    > > Eder
    > >
    > >

    >
    >
    Eder, Jan 9, 2004
    #3
  4. It seems that you are missing ASP.NET mappings from IIS. You can set up the
    mappings with the aspnet_regiis.exe tool in your framework directory.
    aspnet_regiis -i will restore the mappings.

    Regards,
    Sami

    "Eder" <> wrote in message
    news:%...
    > thx, it still doesn't work
    > "Jan Tielens" <> wrote in message
    > news:#...
    > > Probably you haven't configured the HelloWorld directory as a Virtual
    > > Directory in IIS. To so, choose Add New Virtual Directory in the IIS MMC
    > > plugin, give it a name and point it to the location of your project.

    Then
    > > you can use it by browsing to
    > > http://localhost/NameOfVirtualDir/Service1.ASMX.
    > >
    > > Although if you create a new Web Project in Visual Studio, these things
    > > should be set automatically.
    > >
    > > --
    > > Greetz
    > >
    > > Jan Tielens
    > > ________________________________
    > > Read my weblog: http://weblogs.asp.net/jan
    > >
    > >
    > > "Eder" <> wrote in message
    > > news:...
    > > > Hello,
    > > >
    > > > I am a newbie to Web Services. I have been struggling with a very

    > > strange
    > > > problem for days. I want to write a simple "Hello World" Web Service,

    > > which
    > > > I want to invoke
    > > > from a browser. The automatic test web interface that IIS manages

    > doesn't
    > > > work, when i enter
    > > > http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx,

    it
    > > > launchs me to .NET IDE and open the content of Service1.asmx only. My

    > IIS
    > > > 5.0 server is working since i try http://localhost return my home page
    > > > without any problem. I am using XP SP1 professional with .NET 2002.
    > > > Many many thx !!!
    > > >
    > > > Best Rgds
    > > > Eder
    > > >
    > > >

    > >
    > >

    >
    >
    Sami Vaaraniemi, Jan 9, 2004
    #4
  5. Eder

    Eder Guest

    would you tell what parameter should i use with aspnet_regiis.exe, many many
    thx, Eder

    "Sami Vaaraniemi" <> wrote in message
    news:btm2ao$t39$...
    > It seems that you are missing ASP.NET mappings from IIS. You can set up

    the
    > mappings with the aspnet_regiis.exe tool in your framework directory.
    > aspnet_regiis -i will restore the mappings.
    >
    > Regards,
    > Sami
    >
    > "Eder" <> wrote in message
    > news:%...
    > > thx, it still doesn't work
    > > "Jan Tielens" <> wrote in message
    > > news:#...
    > > > Probably you haven't configured the HelloWorld directory as a Virtual
    > > > Directory in IIS. To so, choose Add New Virtual Directory in the IIS

    MMC
    > > > plugin, give it a name and point it to the location of your project.

    > Then
    > > > you can use it by browsing to
    > > > http://localhost/NameOfVirtualDir/Service1.ASMX.
    > > >
    > > > Although if you create a new Web Project in Visual Studio, these

    things
    > > > should be set automatically.
    > > >
    > > > --
    > > > Greetz
    > > >
    > > > Jan Tielens
    > > > ________________________________
    > > > Read my weblog: http://weblogs.asp.net/jan
    > > >
    > > >
    > > > "Eder" <> wrote in message
    > > > news:...
    > > > > Hello,
    > > > >
    > > > > I am a newbie to Web Services. I have been struggling with a very
    > > > strange
    > > > > problem for days. I want to write a simple "Hello World" Web

    Service,
    > > > which
    > > > > I want to invoke
    > > > > from a browser. The automatic test web interface that IIS manages

    > > doesn't
    > > > > work, when i enter
    > > > > http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx,

    > it
    > > > > launchs me to .NET IDE and open the content of Service1.asmx only.

    My
    > > IIS
    > > > > 5.0 server is working since i try http://localhost return my home

    page
    > > > > without any problem. I am using XP SP1 professional with .NET 2002.
    > > > > Many many thx !!!
    > > > >
    > > > > Best Rgds
    > > > > Eder
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >

    >
    >
    Eder, Jan 10, 2004
    #5
  6. Try aspnet_regiis -i.

    "Eder" <> wrote in message
    news:...
    > would you tell what parameter should i use with aspnet_regiis.exe, many

    many
    > thx, Eder
    >
    > "Sami Vaaraniemi" <> wrote in message
    > news:btm2ao$t39$...
    > > It seems that you are missing ASP.NET mappings from IIS. You can set up

    > the
    > > mappings with the aspnet_regiis.exe tool in your framework directory.
    > > aspnet_regiis -i will restore the mappings.
    > >
    > > Regards,
    > > Sami
    > >
    > > "Eder" <> wrote in message
    > > news:%...
    > > > thx, it still doesn't work
    > > > "Jan Tielens" <> wrote in message
    > > > news:#...
    > > > > Probably you haven't configured the HelloWorld directory as a

    Virtual
    > > > > Directory in IIS. To so, choose Add New Virtual Directory in the IIS

    > MMC
    > > > > plugin, give it a name and point it to the location of your project.

    > > Then
    > > > > you can use it by browsing to
    > > > > http://localhost/NameOfVirtualDir/Service1.ASMX.
    > > > >
    > > > > Although if you create a new Web Project in Visual Studio, these

    > things
    > > > > should be set automatically.
    > > > >
    > > > > --
    > > > > Greetz
    > > > >
    > > > > Jan Tielens
    > > > > ________________________________
    > > > > Read my weblog: http://weblogs.asp.net/jan
    > > > >
    > > > >
    > > > > "Eder" <> wrote in message
    > > > > news:...
    > > > > > Hello,
    > > > > >
    > > > > > I am a newbie to Web Services. I have been struggling with a

    very
    > > > > strange
    > > > > > problem for days. I want to write a simple "Hello World" Web

    > Service,
    > > > > which
    > > > > > I want to invoke
    > > > > > from a browser. The automatic test web interface that IIS manages
    > > > doesn't
    > > > > > work, when i enter
    > > > > >

    http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx,
    > > it
    > > > > > launchs me to .NET IDE and open the content of Service1.asmx only.

    > My
    > > > IIS
    > > > > > 5.0 server is working since i try http://localhost return my home

    > page
    > > > > > without any problem. I am using XP SP1 professional with .NET

    2002.
    > > > > > Many many thx !!!
    > > > > >
    > > > > > Best Rgds
    > > > > > Eder
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >

    >
    >
    Sami Vaaraniemi, Jan 10, 2004
    #6
  7. Eder

    Eder Guest

    it doesn't work too, thx
    "Sami Vaaraniemi" <> wrote in message
    news:btp034$o16$...
    > Try aspnet_regiis -i.
    >
    > "Eder" <> wrote in message
    > news:...
    > > would you tell what parameter should i use with aspnet_regiis.exe, many

    > many
    > > thx, Eder
    > >
    > > "Sami Vaaraniemi" <> wrote in message
    > > news:btm2ao$t39$...
    > > > It seems that you are missing ASP.NET mappings from IIS. You can set

    up
    > > the
    > > > mappings with the aspnet_regiis.exe tool in your framework directory.
    > > > aspnet_regiis -i will restore the mappings.
    > > >
    > > > Regards,
    > > > Sami
    > > >
    > > > "Eder" <> wrote in message
    > > > news:%...
    > > > > thx, it still doesn't work
    > > > > "Jan Tielens" <> wrote in message
    > > > > news:#...
    > > > > > Probably you haven't configured the HelloWorld directory as a

    > Virtual
    > > > > > Directory in IIS. To so, choose Add New Virtual Directory in the

    IIS
    > > MMC
    > > > > > plugin, give it a name and point it to the location of your

    project.
    > > > Then
    > > > > > you can use it by browsing to
    > > > > > http://localhost/NameOfVirtualDir/Service1.ASMX.
    > > > > >
    > > > > > Although if you create a new Web Project in Visual Studio, these

    > > things
    > > > > > should be set automatically.
    > > > > >
    > > > > > --
    > > > > > Greetz
    > > > > >
    > > > > > Jan Tielens
    > > > > > ________________________________
    > > > > > Read my weblog: http://weblogs.asp.net/jan
    > > > > >
    > > > > >
    > > > > > "Eder" <> wrote in message
    > > > > > news:...
    > > > > > > Hello,
    > > > > > >
    > > > > > > I am a newbie to Web Services. I have been struggling with a

    > very
    > > > > > strange
    > > > > > > problem for days. I want to write a simple "Hello World" Web

    > > Service,
    > > > > > which
    > > > > > > I want to invoke
    > > > > > > from a browser. The automatic test web interface that IIS

    manages
    > > > > doesn't
    > > > > > > work, when i enter
    > > > > > >

    > http://localhost/XMLWebServices/Chapter02/HelloWorld1/Service1.asmx,
    > > > it
    > > > > > > launchs me to .NET IDE and open the content of Service1.asmx

    only.
    > > My
    > > > > IIS
    > > > > > > 5.0 server is working since i try http://localhost return my

    home
    > > page
    > > > > > > without any problem. I am using XP SP1 professional with .NET

    > 2002.
    > > > > > > Many many thx !!!
    > > > > > >
    > > > > > > Best Rgds
    > > > > > > Eder
    > > > > > >
    > > > > > >
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >

    > >
    > >

    >
    >
    Eder, Jan 11, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Replies:
    4
    Views:
    502
    Chris Uppal
    May 5, 2005
  2. KK
    Replies:
    2
    Views:
    545
    Big Brian
    Oct 14, 2003
  3. MuZZy
    Replies:
    7
    Views:
    1,740
    Mike Hewson
    Jan 7, 2005
  4. Replies:
    14
    Views:
    538
    Karl Heinz Buchegger
    Nov 2, 2005
  5. mera
    Replies:
    7
    Views:
    1,096
Loading...

Share This Page