POD docs and ANSI escapes

Discussion in 'Perl Misc' started by Sisyphus, Sep 27, 2003.

  1. Sisyphus

    Sisyphus Guest

    Hi,
    On my linux box 'perldoc' (but not 'man') is failing to interpret the
    ANSI escapes. How do I remedy this ?

    I'm seeing:
    ESC[1mNAMEESC[0m
    instead of:
    NAME

    (Is this answered in the faq somewhere ? I have a feeling it is, but
    couldn't find it.)

    Cheers,
    Rob
    --
    To reply by email u have to take out the u in kalinaubears.
     
    Sisyphus, Sep 27, 2003
    #1
    1. Advertising

  2. On Sat, 27 Sep 2003 22:29:36 +1000
    Sisyphus <> wrote:
    > Hi,
    > On my linux box 'perldoc' (but not 'man') is failing to interpret
    > the ANSI escapes. How do I remedy this ?
    >
    > I'm seeing:
    > ESC[1mNAMEESC[0m
    > instead of:
    > NAME
    >
    > (Is this answered in the faq somewhere ? I have a feeling it is, but
    >
    > couldn't find it.)


    The "quick fix" is to run perldoc with the '-t' option.

    I tend to remember having the same issue, but it was a _long_ time
    ago. I _think_ you _may_ have to change the language setting to
    something more "sane" (like en_US). Do an 'echo $LANG' if in bash to
    see what it's set to now. However, I could be wrong about this.

    HTH

    --
    Jim

    Copyright notice: all code written by the author in this post is
    released under the GPL. http://www.gnu.org/licenses/gpl.txt
    for more information.

    a fortune quote ...
    I'm a Lisp variable -- bind me!
     
    James Willmore, Sep 27, 2003
    #2
    1. Advertising

  3. James Willmore <> wrote:
    > On Sat, 27 Sep 2003 22:29:36 +1000
    > Sisyphus <> wrote:
    > > Hi,
    > > On my linux box 'perldoc' (but not 'man') is failing to interpret
    > > the ANSI escapes. How do I remedy this ?
    > >
    > > I'm seeing:
    > > ESC[1mNAMEESC[0m
    > > instead of:
    > > NAME
    > >
    > > (Is this answered in the faq somewhere ? I have a feeling it is, but
    > >
    > > couldn't find it.)

    >
    > The "quick fix" is to run perldoc with the '-t' option.


    You can also set the LESS environment variable to "-r".

    --
    Steve
     
    Steve Grazzini, Sep 27, 2003
    #3
  4. Sisyphus

    Sisyphus Guest

    Steve Grazzini wrote:
    > James Willmore <> wrote:
    >
    >>On Sat, 27 Sep 2003 22:29:36 +1000
    >>Sisyphus <> wrote:
    >>
    >>>Hi,
    >>>On my linux box 'perldoc' (but not 'man') is failing to interpret
    >>>the ANSI escapes. How do I remedy this ?
    >>>


    >>
    >>The "quick fix" is to run perldoc with the '-t' option.

    >
    >
    > You can also set the LESS environment variable to "-r".
    >


    Thanks guys.

    Cheers,
    Rob


    --
    To reply by email u have to take out the u in kalinaubears.
     
    Sisyphus, Sep 28, 2003
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ajax Chelsea

    Is array of POD still a POD type?

    Ajax Chelsea, Dec 1, 2003, in forum: C++
    Replies:
    1
    Views:
    347
    Ron Natalie
    Dec 1, 2003
  2. Replies:
    1
    Views:
    490
  3. Replies:
    11
    Views:
    1,073
    Keith Thompson
    Apr 28, 2008
  4. Frank Iannarilli

    pre-ansi to ansi c++ conversion?

    Frank Iannarilli, Jul 21, 2009, in forum: C++
    Replies:
    2
    Views:
    416
  5. Himanshu Garg
    Replies:
    1
    Views:
    166
    Himanshu Garg
    Sep 21, 2003
Loading...

Share This Page