pop-up logon dialog box - Integrated Windows authentication - asp.net

Discussion in 'ASP .Net Security' started by E. Kwong, Sep 23, 2005.

  1. E. Kwong

    E. Kwong Guest

    I'm experimentating with Integrated Windows authentication and am puzzled by
    certain aspect of the native pop-up logon dialog box. After all the setup,
    everything seems to work as expected: when logon to the domain, the dialog
    box does not show; when logon outside the domain the dialog box pops up to
    ask for credentials. What puzzles me is that after checking the "remember
    my password" box, the dialog box never come up again whenever I logon
    locally ("workstation" box checked), even after the machine is rebooted.

    I went to our contractor's site which I know asking for credentials with a
    Windows native dialog box, and checked that "remember password" box. I
    exit out of the browser and then go back in; the dialog box has the user id
    and password auto-filled. That's what I expect of the "remember password"
    feature.

    So do I configure the web pages wrong or is it some settings in my
    workstation? W2K IIS5 server; XP workstation.

    Thanks,
    E. Kwong, Sep 23, 2005
    #1
    1. Advertising

  2. E. Kwong

    Brock Allen Guest

    Keith discusses this in his MSDN article:

    http://msdn.microsoft.com/msdnmag/issues/05/09/SecurityBriefs/default.aspx

    -Brock
    DevelopMentor
    http://staff.develop.com/ballen

    > I'm experimentating with Integrated Windows authentication and am
    > puzzled by certain aspect of the native pop-up logon dialog box.
    > After all the setup, everything seems to work as expected: when logon
    > to the domain, the dialog box does not show; when logon outside the
    > domain the dialog box pops up to ask for credentials. What puzzles
    > me is that after checking the "remember my password" box, the dialog
    > box never come up again whenever I logon locally ("workstation" box
    > checked), even after the machine is rebooted.
    >
    > I went to our contractor's site which I know asking for credentials
    > with a Windows native dialog box, and checked that "remember password"
    > box. I exit out of the browser and then go back in; the dialog box
    > has the user id and password auto-filled. That's what I expect of
    > the "remember password" feature.
    >
    > So do I configure the web pages wrong or is it some settings in my
    > workstation? W2K IIS5 server; XP workstation.
    >
    > Thanks,
    >
    Brock Allen, Sep 23, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mark
    Replies:
    0
    Views:
    676
  2. Joergen Bech
    Replies:
    2
    Views:
    3,288
    Joergen Bech
    Jul 2, 2005
  3. Will
    Replies:
    5
    Views:
    2,616
  4. bienwell
    Replies:
    5
    Views:
    5,198
    bienwell
    Aug 13, 2006
  5. Kjell Kristiansson
    Replies:
    0
    Views:
    285
    Kjell Kristiansson
    Nov 30, 2005
Loading...

Share This Page